PPP connection alarm, exit (to ATT worldnet)

PPP connection alarm, exit (to ATT worldnet)

Post by Paul Coluc » Wed, 20 Nov 1996 04:00:00



Hello,
   I am hoping someone out there can give me a hand.  I successfully
have ppp 2.1.2d running (Linux kernel 2.1.13). With little difficulty
I have managed to get a working ppp connection with my university.

   Recently I decided to utilize my ATT worldnet service (ppp connection)
which I typically use through windoze95 for use with Linux.  
I made a script which properly connects me to the att ppp machine
and properly enters password/username, however after a few moments
I get an alarm and exit.  I suspect there is some negotiation but then
a failure to authenticate.  The following is an excerpt from the
/var/log/messages file relevent to the lost ppp connection:

Nov  7 23:29:00 galileo pppd[132]: Connected...
Nov  7 23:29:01 galileo kernel: ppp: channel ppp0 mtu = 1500, mru = 1500
Nov  7 23:29:01 galileo kernel: ppp: channel ppp0 open
Nov  7 23:29:01 galileo pppd[132]: set kernel debugging level to 0
Nov  7 23:29:01 galileo pppd[132]: Using interface ppp0
Nov  7 23:29:01 galileo pppd[132]: Connect: ppp0 <--> /dev/modem
Nov  7 23:29:01 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
Nov  7 23:29:01 galileo pppd[132]: LCP: sending Configure-Request, id 1
Nov  7 23:29:04 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
Nov  7 23:29:04 galileo pppd[132]: LCP: sending Configure-Request, id 1
Nov  7 23:29:07 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
Nov  7 23:29:07 galileo pppd[132]: LCP: sending Configure-Request, id 1
Nov  7 23:29:10 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
Nov  7 23:29:10 galileo pppd[132]: LCP: sending Configure-Request, id 1
Nov  7 23:29:13 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
Nov  7 23:29:13 galileo pppd[132]: LCP: sending Configure-Request, id 1
Nov  7 23:29:16 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
Nov  7 23:29:16 galileo pppd[132]: LCP: sending Configure-Request, id 1
Nov  7 23:29:19 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
Nov  7 23:29:19 galileo pppd[132]: LCP: sending Configure-Request, id 1
Nov  7 23:29:22 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
Nov  7 23:29:22 galileo pppd[132]: LCP: sending Configure-Request, id 1
Nov  7 23:29:25 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
Nov  7 23:29:25 galileo pppd[132]: LCP: sending Configure-Request, id 1
Nov  7 23:29:28 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
Nov  7 23:29:28 galileo pppd[132]: LCP: sending Configure-Request, id 1
Nov  7 23:29:31 galileo pppd[132]: Connection terminated.
Nov  7 23:29:31 galileo kernel: ppp_ioctl: set debug level 2, netpacket 0
Nov  7 23:29:31 galileo pppd[132]: set kernel debugging level to 2
Nov  7 23:29:31 galileo kernel: ppp: channel ppp0 going down for IP packets!
Nov  7 23:29:31 galileo kernel: ppp: channel ppp0 closing.
Nov  7 23:29:31 galileo pppd[132]: Exit.

Can someone please give me a hand with this problem,

I sincerly appreciate any comments/suggestions,

Paul Colucci

 
 
 

PPP connection alarm, exit (to ATT worldnet)

Post by Phillip Kh » Thu, 28 Nov 1996 04:00:00


: Hello,
:    I am hoping someone out there can give me a hand.  I successfully
: have ppp 2.1.2d running (Linux kernel 2.1.13). With little difficulty
: I have managed to get a working ppp connection with my university.
:
:    Recently I decided to utilize my ATT worldnet service (ppp connection)
: which I typically use through windoze95 for use with Linux.  
: I made a script which properly connects me to the att ppp machine
: and properly enters password/username, however after a few moments
: I get an alarm and exit.  I suspect there is some negotiation but then
: a failure to authenticate.  The following is an excerpt from the
: /var/log/messages file relevent to the lost ppp connection:
:
:
: Nov  7 23:29:00 galileo pppd[132]: Connected...
: Nov  7 23:29:01 galileo kernel: ppp: channel ppp0 mtu = 1500, mru = 1500
: Nov  7 23:29:01 galileo kernel: ppp: channel ppp0 open
: Nov  7 23:29:01 galileo pppd[132]: set kernel debugging level to 0
: Nov  7 23:29:01 galileo pppd[132]: Using interface ppp0
: Nov  7 23:29:01 galileo pppd[132]: Connect: ppp0 <--> /dev/modem
: Nov  7 23:29:01 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
: Nov  7 23:29:01 galileo pppd[132]: LCP: sending Configure-Request, id 1
: Nov  7 23:29:04 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
: Nov  7 23:29:04 galileo pppd[132]: LCP: sending Configure-Request, id 1
: Nov  7 23:29:07 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
: Nov  7 23:29:07 galileo pppd[132]: LCP: sending Configure-Request, id 1
: Nov  7 23:29:10 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
: Nov  7 23:29:10 galileo pppd[132]: LCP: sending Configure-Request, id 1
: Nov  7 23:29:13 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
: Nov  7 23:29:13 galileo pppd[132]: LCP: sending Configure-Request, id 1
: Nov  7 23:29:16 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
: Nov  7 23:29:16 galileo pppd[132]: LCP: sending Configure-Request, id 1
: Nov  7 23:29:19 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
: Nov  7 23:29:19 galileo pppd[132]: LCP: sending Configure-Request, id 1
: Nov  7 23:29:22 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
: Nov  7 23:29:22 galileo pppd[132]: LCP: sending Configure-Request, id 1
: Nov  7 23:29:25 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
: Nov  7 23:29:25 galileo pppd[132]: LCP: sending Configure-Request, id 1
: Nov  7 23:29:28 galileo pppd[132]: fsm_sdata(LCP): Sent code 1, id 1.
: Nov  7 23:29:28 galileo pppd[132]: LCP: sending Configure-Request, id 1
: Nov  7 23:29:31 galileo pppd[132]: Connection terminated.
: Nov  7 23:29:31 galileo kernel: ppp_ioctl: set debug level 2, netpacket 0
: Nov  7 23:29:31 galileo pppd[132]: set kernel debugging level to 2
: Nov  7 23:29:31 galileo kernel: ppp: channel ppp0 going down for IP packets!
: Nov  7 23:29:31 galileo kernel: ppp: channel ppp0 closing.
: Nov  7 23:29:31 galileo pppd[132]: Exit.
:
:
: Can someone please give me a hand with this problem,
:
: I sincerly appreciate any comments/suggestions,
:
: Paul Colucci

If you run setserial -a (I think that's the option to show info on it)
is your bps rate set at 115200 and is spd_vhi one of the flags? If you
see the string  spd_hi (Note the missing v) along with a bps rate of
115200, then do a setserial /dev/modem spd_vhi (I think that's the
proper syntax) and that should fix it. Good luck.

Phil.

 
 
 

PPP connection alarm, exit (to ATT worldnet)

Post by Marco Stol » Thu, 12 Dec 1996 04:00:00


Hello,

after configuring ppp 2.1.2 (Linux Kernel 1.2.13, Distribution:
S.u.S.E) I successfully connected to my provider (it's not ATT
worldnet). But then I got the following messages (excerpt from
"/usr/adm/messages"):

pppd[215]: pppd 2.1.2 started by asmodeus, uid 0
pppd[215]: Connecting with </usr/sbin/chat -v -f /usr/bin/ppp.chat>

[...]

pppd[215]: Connected...
pppd[215]: set kernel debugging level to 0
pppd[215]: Using interface ppp0
pppd[215]: Connect: ppp0 <--> /dev/modem
pppd[215]: fsm_sdata(LCP): Sent code 1, id 1.
pppd[215]: LCP: sending Configure-Request, id 1
kernel: ppp: channel ppp0 mtu = 1500, mru = 1500
kernel: ppp: channel ppp0 open
pppd[215]: fsm_sdata(LCP): Sent code 1, id 1.
pppd[215]: LCP: sending Configure-Request, id 1
pppd[215]: fsm_rconfreq(LCP): Rcvd id 1.
pppd[215]: lcp_reqci: rcvd unknown option 0
pppd[215]:  (REJ)
pppd[215]: lcp_reqci: rcvd MRU
pppd[215]: (1524)
pppd[215]:  (ACK)
pppd[215]: lcp_reqci: rcvd ASYNCMAP
pppd[215]: (a0000)
pppd[215]:  (ACK)
pppd[215]: lcp_reqci: rcvd AUTHTYPE
pppd[215]:  (REJ)
pppd[215]: lcp_reqci: rcvd PCOMPRESSION
pppd[215]:  (ACK)
pppd[215]: lcp_reqci: rcvd ACCOMPRESSION
pppd[215]:  (ACK)
pppd[215]: lcp_reqci: rcvd unknown option 17
pppd[215]:  (REJ)
pppd[215]: lcp_reqci: rcvd unknown option 19
pppd[215]:  (REJ)
pppd[215]: lcp_reqci: returning CONFREJ.
pppd[215]: fsm_sdata(LCP): Sent code 4, id 1.
pppd[215]: fsm_rconfack(LCP): Rcvd id 1.
pppd[215]: fsm_rtermreq(LCP): Rcvd id 2.
pppd[215]: fsm_sdata(LCP): Sent code 6, id 2.
pppd[215]: fsm_sdata(LCP): Sent code 1, id 255.
pppd[215]: LCP: sending Configure-Request, id 255
pppd[215]: fsm_sdata(LCP): Sent code 1, id 255.
pppd[215]: LCP: sending Configure-Request, id 255
pppd[215]: fsm_sdata(LCP): Sent code 1, id 255.
pppd[215]: LCP: sending Configure-Request, id 255
pppd[215]: fsm_sdata(LCP): Sent code 1, id 255.
pppd[215]: LCP: sending Configure-Request, id 255
pppd[215]: fsm_sdata(LCP): Sent code 1, id 255.
pppd[215]: LCP: sending Configure-Request, id 255
pppd[215]: fsm_sdata(LCP): Sent code 1, id 255.
pppd[215]: LCP: sending Configure-Request, id 255
su: asmodeus on /dev/ttyp3
pppd[215]: fsm_sdata(LCP): Sent code 1, id 255.
pppd[215]: LCP: sending Configure-Request, id 255
pppd[215]: fsm_sdata(LCP): Sent code 1, id 255.
pppd[215]: LCP: sending Configure-Request, id 255
pppd[215]: fsm_sdata(LCP): Sent code 1, id 255.
pppd[215]: LCP: sending Configure-Request, id 255
pppd[215]: fsm_sdata(LCP): Sent code 1, id 255.
pppd[215]: LCP: sending Configure-Request, id 255
kernel: ppp_ioctl: set debug level 2, netpacket 0
kernel: ppp: channel ppp0 going down for IP packets!
kernel: ppp: channel ppp0 closing.
pppd[215]: Connection terminated.
pppd[215]: set kernel debugging level to 2
pppd[215]: Exit.

Could anybody help me, please? I'm really desperate.

CU Marco