ppp: Protocol-Reject for unsupported protocol?

ppp: Protocol-Reject for unsupported protocol?

Post by Carsten G Brautiga » Sat, 15 May 1999 04:00:00



After upgrading to RedHat 6.0, I have problms with PPP.
The lgo file says:

May 13 22:48:17 unicorn pppd[6890]: pppd 2.3.7 started by carsten, uid
501
May 13 22:48:17 unicorn pppd[6890]: Using interface ppp0
May 13 22:48:17 unicorn pppd[6890]: Connect: ppp0 <--> /dev/modem
May 13 22:48:23 unicorn modprobe: can't locate module ppp-compress-21
May 13 22:48:24 unicorn modprobe: can't locate module ppp-compress-26
May 13 22:48:24 unicorn modprobe: can't locate module ppp-compress-24
May 13 22:48:25 unicorn pppd[6890]: Protocol-Reject for unsupported
protocol 0x7263
May 13 22:48:25 unicorn pppd[6890]: Protocol-Reject for unsupported
protocol 0x7263
May 13 22:48:26 unicorn pppd[6890]: Protocol-Reject for unsupported
protocol 0x7263
May 13 22:48:26 unicorn pppd[6890]: Protocol-Reject for unsupported
protocol 0x5072
May 13 22:48:26 unicorn pppd[6890]: Protocol-Reject for unsupported
protocol 0x5072

Does anyone know what's wrong/missing?

Please cc answers to my address,

Thanks,

Carsten.
--

 
 
 

ppp: Protocol-Reject for unsupported protocol?

Post by Clifford Ki » Sat, 15 May 1999 04:00:00



: After upgrading to RedHat 6.0, I have problms with PPP.
: The lgo file says:

: May 13 22:48:17 unicorn pppd[6890]: pppd 2.3.7 started by carsten, uid
: 501
: May 13 22:48:17 unicorn pppd[6890]: Using interface ppp0
: May 13 22:48:17 unicorn pppd[6890]: Connect: ppp0 <--> /dev/modem
: May 13 22:48:23 unicorn modprobe: can't locate module ppp-compress-21
: May 13 22:48:24 unicorn modprobe: can't locate module ppp-compress-26
: May 13 22:48:24 unicorn modprobe: can't locate module ppp-compress-24

These are CCP compression modules that needed aliasing according to many
other posts regarding them.  I don't do RH or modules (well I did use
insmod to load a couple of modules once, but not with kmod) and can't
say offhand what to do to get rid of them.

: May 13 22:48:25 unicorn pppd[6890]: Protocol-Reject for unsupported
: protocol 0x7263
: May 13 22:48:25 unicorn pppd[6890]: Protocol-Reject for unsupported
: protocol 0x7263
: May 13 22:48:26 unicorn pppd[6890]: Protocol-Reject for unsupported
: protocol 0x7263
: May 13 22:48:26 unicorn pppd[6890]: Protocol-Reject for unsupported
: protocol 0x5072
: May 13 22:48:26 unicorn pppd[6890]: Protocol-Reject for unsupported
: protocol 0x5072

Some or all of the PPP link negotiation messages are likely being sent
to the modem's serial port somehow.  Notice that 5072 is hex for `Pr'
(from ProtRej or Protocol) and 7263 is hex for `rc' (from rcvd [LCP.. ).
Adding the pppd option kdebug 7 may show what's happening better - one of
the few times where kdebug 7 is useful.  The log file for link negotiation
messages varies with the distribution; /etc/syslog.conf is where the log
files are configured.

The recent ppp-2.3.7 has changed and, for reasons that are not at all
clear to me, kppp can cause (and *has* caused) this type of behavior, and
perhaps other programs can cause it as well.  You can get the latest kppp
when it is suspect and it should cure the problem.  You can also *try*
specifying to pppd the modem's device file ttySx as /dev/ttySx rather
than as the symbolic link /dev/modem, but I'm not sure this will work.

--

/* The signal-to-noise ratio is too low in many [news] groups to make
 * them good candidates for archiving.
 *    --- Mike Moraes, Answers to FAQs about Usenet */

 
 
 

ppp: Protocol-Reject for unsupported protocol?

Post by Clifford Ki » Sun, 16 May 1999 04:00:00



: After upgrading to RedHat 6.0, I have problms with PPP.

Here's an update:  ppp-2.3.8 is just out with fixes and enhancements.
It *may* help with problems involving unwanted bytes that appear in the
serial port data stream.

: The lgo file says:

: May 13 22:48:26 unicorn pppd[6890]: Protocol-Reject for unsupported
: protocol 0x5072

--

/* Better is the enemy of good enough. */

 
 
 

ppp: Protocol-Reject for unsupported protocol?

Post by Bill Unr » Sun, 16 May 1999 04:00:00




>: After upgrading to RedHat 6.0, I have problms with PPP.
>: The lgo file says:
>: May 13 22:48:17 unicorn pppd[6890]: pppd 2.3.7 started by carsten, uid
>: 501
>: May 13 22:48:17 unicorn pppd[6890]: Using interface ppp0
>: May 13 22:48:17 unicorn pppd[6890]: Connect: ppp0 <--> /dev/modem
>: May 13 22:48:23 unicorn modprobe: can't locate module ppp-compress-21
>: May 13 22:48:24 unicorn modprobe: can't locate module ppp-compress-26
>: May 13 22:48:24 unicorn modprobe: can't locate module ppp-compress-24

Try
alias ppp-compress-21   bsd_comp
alias ppp-compress-24   ppp_deflate     # From original RFC draft
alias ppp-compress-26   ppp_deflate     # Final standard per ppp-2.3.4

n /etc/conf.modules

 
 
 

ppp: Protocol-Reject for unsupported protocol?

Post by Randall Ros » Tue, 18 May 1999 04:00:00


I successfully installed RH 6.0 Intel (Kernel 2.2.5-15) and have a strange problem
related to the one below:

I can successfully establish a PPP connection through ttyS0 to my Ricochet wireless
modem. KPPP connects and gets an IP address. I can then ping, traceroute, and do
DNS lookups without any problems. The output from netstat looks fine.

However, if I try www, ftp, or other TCP based services, I receive no responses to
the packets that are sent out. I have verified with tcpdump that I am indeed
sending packets out ppp0 but am not receiving the replies, or at least if I am,
Linux is unaware of it! If I use Lynx, Netscape, or other client software the
response is always the same... DNS succeeds, the remote host is contacted but then
it hangs at 'waiting for reply'.

I have aliased as indicated below, thinking that those error messages were the
cause of my problems. After doing so, the error messages went away, but the problem
still occurs.

Any advice/suggestions would be appreciated.

Regards,
Randall.




> >: After upgrading to RedHat 6.0, I have problms with PPP.
> >: The lgo file says:

> >: May 13 22:48:17 unicorn pppd[6890]: pppd 2.3.7 started by carsten, uid
> >: 501
> >: May 13 22:48:17 unicorn pppd[6890]: Using interface ppp0
> >: May 13 22:48:17 unicorn pppd[6890]: Connect: ppp0 <--> /dev/modem
> >: May 13 22:48:23 unicorn modprobe: can't locate module ppp-compress-21
> >: May 13 22:48:24 unicorn modprobe: can't locate module ppp-compress-26
> >: May 13 22:48:24 unicorn modprobe: can't locate module ppp-compress-24

> Try
> alias ppp-compress-21   bsd_comp
> alias ppp-compress-24   ppp_deflate     # From original RFC draft
> alias ppp-compress-26   ppp_deflate     # Final standard per ppp-2.3.4

> n /etc/conf.modules

  randall.vcf
< 1K Download
 
 
 

ppp: Protocol-Reject for unsupported protocol?

Post by Joost Gever » Thu, 20 May 1999 04:00:00



> I successfully installed RH 6.0 Intel (Kernel 2.2.5-15) and have a strange problem
> related to the one below:

> I can successfully establish a PPP connection through ttyS0 to my Ricochet wireless
> modem. KPPP connects and gets an IP address. I can then ping, traceroute, and do
> DNS lookups without any problems. The output from netstat looks fine.

> However, if I try www, ftp, or other TCP based services, I receive no responses to
> the packets that are sent out. I have verified with tcpdump that I am indeed
> sending packets out ppp0 but am not receiving the replies, or at least if I am,
> Linux is unaware of it! If I use Lynx, Netscape, or other client software the
> response is always the same... DNS succeeds, the remote host is contacted but then
> it hangs at 'waiting for reply'.

> I have aliased as indicated below, thinking that those error messages were the
> cause of my problems. After doing so, the error messages went away, but the problem
> still occurs.

> Any advice/suggestions would be appreciated.

> Regards,
> Randall.

I have exactly the same problem but no solution for it. Is it possible that the
framelength is not good, the settings MTU and MRU?
If you find a solution, let me know.

Thanks in advance,

Joost Gevers

 
 
 

ppp: Protocol-Reject for unsupported protocol?

Post by Chris Goodacr » Fri, 21 May 1999 04:00:00


I had the same problem.  Last night I set my mtu and mru to 512.  The connection started
to fly.  I'm going to experiment with the settings later to try to find the best one.
Hopefully it's that simple of a change for you too.


> > I successfully installed RH 6.0 Intel (Kernel 2.2.5-15) and have a strange problem
> > related to the one below:

> > I can successfully establish a PPP connection through ttyS0 to my Ricochet wireless
> > modem. KPPP connects and gets an IP address. I can then ping, traceroute, and do
> > DNS lookups without any problems. The output from netstat looks fine.

> > However, if I try www, ftp, or other TCP based services, I receive no responses to
> > the packets that are sent out. I have verified with tcpdump that I am indeed
> > sending packets out ppp0 but am not receiving the replies, or at least if I am,
> > Linux is unaware of it! If I use Lynx, Netscape, or other client software the
> > response is always the same... DNS succeeds, the remote host is contacted but then
> > it hangs at 'waiting for reply'.

> > I have aliased as indicated below, thinking that those error messages were the
> > cause of my problems. After doing so, the error messages went away, but the problem
> > still occurs.

> > Any advice/suggestions would be appreciated.

> > Regards,
> > Randall.

> I have exactly the same problem but no solution for it. Is it possible that the
> framelength is not good, the settings MTU and MRU?
> If you find a solution, let me know.

> Thanks in advance,

> Joost Gevers

 
 
 

ppp: Protocol-Reject for unsupported protocol?

Post by Ronald Col » Sat, 22 May 1999 04:00:00



> I had the same problem.  Last night I set my mtu and mru to 512.
> The connection started to fly.  I'm going to experiment with the
> settings later to try to find the best one.  Hopefully it's that
> simple of a change for you too.

If you're using IP Masquerading, then it's recommended that you leave
mtu and mru at 1500.

--
Forte International, P.O. Box 1412, Ridgecrest, CA  93556-1412

President, CEO                             Fax: (760) 499-9152
My PGP fingerprint: 15 6E C7 91 5F AF 17 C4  24 93 CB 6B EB 38 B5 E5

 
 
 

ppp: Protocol-Reject for unsupported protocol?

Post by bent.. » Thu, 10 Jun 1999 04:00:00




> I successfully installed RH 6.0 Intel (Kernel

2.2.5-15) and have a strange problem
Quote:> related to the one below:

> I can successfully establish a PPP connection

through ttyS0 to my Ricochet wireless
Quote:> modem. KPPP connects and gets an IP address. I

can then ping, traceroute, and do
Quote:> DNS lookups without any problems. The output

from netstat looks fine.
Quote:

> However, if I try www, ftp, or other TCP based

services, I receive no responses to

Quote:> the packets that are sent out.

I've seen the same problem, and the MTU/MRU
limitation suggested in follow-up notes didn't do
the trick.  I did some packet tracing of Ricochet
vs. modem access to a local ISP and discovered
that there were some subtle differences in the
protocol negotiation.  This persuaded me to
disable Van Jacobson compression and all is well!

FYI: pppd 2.3.7 with kernel 2.2.5-15 w/ ppp 2.3.3
and kernel 2.2.9 w/ ppp 2.3.7 had the same
problems.

Since diagnosing the problem, I found Alan Cox
reported this problem for a pre-release of 2.2.0.
It looks like this problem has not been resolved.
He suggests setting the pppd option "-vj", but
you'll have to use "novj" with later versions of
pppd.

Sent via Deja.com http://www.deja.com/
Share what you know. Learn what you don't.