Q: PCI IRQ (3COM590 & AHA 2940 problem

Q: PCI IRQ (3COM590 & AHA 2940 problem

Post by Robert Haraka » Wed, 03 Apr 1996 04:00:00



Hello.
 I have P5, Atlantis MB, 2 x AHA 2940 SCSI PCI card and 3COM590 ethernet
card. The problem is, that the ethernet card have always IRQ of one SCSI
card.:

1. SCSI ....... IRQ 10
2. SCSI ....... IRQ 11  !!
   3com590 .... IRQ 11  !!

Problem is that I dont know change any IRQ. When I use 3com59xcfg program it
write that IRQ is set by PCI and I cannot change it.
When I use WIN95 the IRQs are:
1. SCSI ........IRQ 15
2. SCSI ........IRQ 14
   3com590 .....IRQ 11

It seems, that problem will be in shared interrupts, but I cannot compile
3c590 driver with HAVE_SHARED_IRQ due to <linux/shared_irq.h> doesn't exist.
I use linux 1.3.81 kernel.

Thanks for any suggestion and tip.
                                                Robert Harakaly

 
 
 

Q: PCI IRQ (3COM590 & AHA 2940 problem

Post by Yann Stettle » Wed, 03 Apr 1996 04:00:00



> Hello.
>  I have P5, Atlantis MB, 2 x AHA 2940 SCSI PCI card and 3COM590 ethernet
> card. The problem is, that the ethernet card have always IRQ of one SCSI
> card.:

> 1. SCSI ....... IRQ 10
> 2. SCSI ....... IRQ 11  !!
>    3com590 .... IRQ 11  !!

> Problem is that I dont know change any IRQ. When I use 3com59xcfg program it
> write that IRQ is set by PCI and I cannot change it.

You should be able to change the IRQ assign to a PCI slot directly in the
BIOS of your motherboard. Some motherboard may need a change of jumper also
to match the IRQ you assing in the BIOS.

Generaly first master PCI slot is assigned IRQ 10 and second master IRQ 11.

Cheers,
Yann S.

PS : Good luck with the timeout on the 3C590 card....

--
------------------------------------------------------------------
TheNet - Internet Services AG              CohProg SaRL

http://www.thenet.ch/                      http://www.cohprog.com/

 
 
 

1. AHA 2940 & PCI

Hi
Linux doesn't recognize my SCSI contoller.
I bought a CD-ROM with Linux 2.01 (kernel 1.0.9)
and got Slackware Linux 2.2.0 kernel from ftp.cdrom.com.
Here is my system configuration :
  AWARD  PCI/I-P54N4 with Pentium P90
  BIOS AWARD v4.50 G
  40 MB-RAM
  Adaptec PCI SCSI-conroller AHA-2940 Bios v1.11
    HD: Quatum PD1800S(ID 0), DEC RZ25(ID 4)
    Syquest SQ5110(ID 1), CD-ROM Toshiba XM-3401 TA(ID 5)
    Tape Tandberg TSC4200(ID 2)
  ATI MACH-32 with 2MB
  AVM B1 ISDN controller
  Soundblaster-Pro 16
As I boot LILO with both version he says sys hosts : 0
and i can't access sda or sdb.
(But he recognize it's a bugged P5 ;-)

Is there a new kernel version i need ?
Thanks to all that can help me.


2. KDE1.1.1pre1 Install Blues

3. AHA 2920, AHA 2940W, AHA 2940??

4. *** PLEASE READ THIS BEFORE POSTING *** (misc-2.09)

5. 3COM590 & 2940

6. Xserver can't find fonts

7. Adaptec AHA-2940 and PCI problems

8. Multi-boot: BeOS, MacOC, LinuxPPC, Possible?

9. system hangs 1.2.13 AHA-2940 & SB16-SCSI-II & ATI Mach64

10. Adaptec AHA 2940 and network and SCSI award PCI

11. Adaptec AHA-2940 PCI B/M SCSI-2

12. Linux/AHA-2940 PCI

13. Adaptec AHA-2940 PCI