Intermittent Squid problem, no responce from squid

Intermittent Squid problem, no responce from squid

Post by Graeme Hinchliff » Fri, 31 Oct 2003 19:06:23



hiya
        We are running several Squid proxies (2.4.STABLE6) for one of our
services, however we are seeing oddness in the monitoring systems logs.  

To test the servers are up and running our monitoring software tries to
connect to various sites via the proxies to ensure they are operating
correctly.  At very irregular intervals (don't match up to running cron's
or anything), we get a timeout responce from one of these tests, the next
time it runs, there is no issue.  I cannot see anything in the logs which
look suspicious.  We are testing with different sites (google, bbc, demon
etc) as the destination and the fault does not affect the same site,
different sites at different times on different cache boxes.

From what we can tell the service is running happily, just these errors in
our monitoring are starting to become irritating (we want perfection :) ).

Does anyone have any ideas what may be causing this? or possible
solutions?

Many Thanks

Graeme Hinchliffe

 
 
 

Intermittent Squid problem, no responce from squid

Post by C3 » Fri, 31 Oct 2003 21:51:02


If it means anything to anybody, I also have this problem. It seems to pop
up and disappear at a whim.

C3

 
 
 

1. squid questions, newbie to squid

I am using firestarter firewall with ipmasqing turned on. all users can
access the internet. I am starting to use squid, and I was under the
impression that if I turned off ipmasqing, users would use the squid cache.
I turned of ipmasqing and noone could access the INET. so I turned it back
on, now they can access it again. so I took the default gateway out of the
network configuration, and directed the browsers to go thru the squid proxy
cache,using the IP address of the squid machine, no access to the INET
again. ok so I put the default gateway back in and they access the inet no
problem. ok next I undo the browser configuration in the browser and all can
still access the internet. so I am confused, do I need ipmasqing turned on
so they can access the internet ? yet I want to make sure that certain
people don't access certain sites, or the internet at all. I have been
reading the FAQ and users manual, but it doesn't talk about wha you need as
in ipmasqing or firewalling stuff, at least I haven't found it yet. thanks

2. ksh on Sun's and HP's

3. SQUID-Problems using Port 444

4. Xserver shutting down....

5. squid.conf problem (http_access)

6. IP masquerade for FreeBSD ?

7. Squid and Redirection problem

8. automatic email reply with URL content

9. Problem with Squid 2.1 patch2: Dnsserver not starting?

10. Transparent proxy with Squid and Apache problem

11. Squid 2.4STABLE instalation problem on Red Hat 7.3

12. Squid DNS-Problem with 1&1

13. mandatory proxy / squid problem