NAT ROUTER PROBLEM...PLEASE HELP!

NAT ROUTER PROBLEM...PLEASE HELP!

Post by Digital Monste » Mon, 06 Aug 2001 11:20:15



Hi,

My NATROUTER running with RH 7.1 with kernel 2.4.2 ,  eth0 connected to
cable modem with DHCP , eth1 connected to intranet with fiax IP 192.168.0.1
.... the problem is after a few hours when no user in intranet using the
internet service , the NAT ROUTER will become mal-function until I active
again the eth0 , can you tell me how to fix the fault?

Regards,

Sunny

 
 
 

NAT ROUTER PROBLEM...PLEASE HELP!

Post by antoni » Mon, 06 Aug 2001 12:45:56


i have the same problem, or similar, after 15 minutes of inactivite my modem

i have add this line to my rc.local file:

ping -i 120  ip# or my router (ex. 24.112.0.1)

i added 4 diferent entries here and since then the modem is always alive,
maybe this could help you


Quote:> Hi,

> My NATROUTER running with RH 7.1 with kernel 2.4.2 ,  eth0 connected to
> cable modem with DHCP , eth1 connected to intranet with fiax IP
192.168.0.1
> .... the problem is after a few hours when no user in intranet using the
> internet service , the NAT ROUTER will become mal-function until I active
> again the eth0 , can you tell me how to fix the fault?

> Regards,

> Sunny


 
 
 

NAT ROUTER PROBLEM...PLEASE HELP!

Post by Greenhan » Mon, 06 Aug 2001 13:18:06


I have this problem too but I think this script isn't that good?
Can u give a better script such as testing if the condition is alive or not,
if alive then no need ping else ping
some ip? I didn't know the syntax in shells script and I wonder if this
script will consume much network resource? I am just a novice in linux..so
if I said anything wrong, plz. excluse me


> i have the same problem, or similar, after 15 minutes of inactivite my
modem

alive
> i have add this line to my rc.local file:

> ping -i 120  ip# or my router (ex. 24.112.0.1)

> i added 4 diferent entries here and since then the modem is always alive,
> maybe this could help you



> > Hi,

> > My NATROUTER running with RH 7.1 with kernel 2.4.2 ,  eth0 connected to
> > cable modem with DHCP , eth1 connected to intranet with fiax IP
> 192.168.0.1
> > .... the problem is after a few hours when no user in intranet using the
> > internet service , the NAT ROUTER will become mal-function until I
active
> > again the eth0 , can you tell me how to fix the fault?

> > Regards,

> > Sunny

 
 
 

NAT ROUTER PROBLEM...PLEASE HELP!

Post by antoni » Mon, 06 Aug 2001 18:22:09



minutes,, i have time in diferent ocassions, so my rc.local load a ping at
start up of the machine:

ping -i 850 <ip number>

the ping gets send every 14 minutes or so, write a scripts to test the
condition of the connection i did not fins reazon for it as i am sure the
connection dies after that amount of time i just send a ping to my gateway,
to keep the connection alive. Some friends that run winblows also have the
same problem and they just leave they mail to check every 15 minutes....
script i really dont need it, but if you do let me know i will write you
one.


> I have this problem too but I think this script isn't that good?
> Can u give a better script such as testing if the condition is alive or
not,
> if alive then no need ping else ping
> some ip? I didn't know the syntax in shells script and I wonder if this
> script will consume much network resource? I am just a novice in linux..so
> if I said anything wrong, plz. excluse me



> > i have the same problem, or similar, after 15 minutes of inactivite my
> modem

> alive
> > i have add this line to my rc.local file:

> > ping -i 120  ip# or my router (ex. 24.112.0.1)

> > i added 4 diferent entries here and since then the modem is always
alive,
> > maybe this could help you



> > > Hi,

> > > My NATROUTER running with RH 7.1 with kernel 2.4.2 ,  eth0 connected
to
> > > cable modem with DHCP , eth1 connected to intranet with fiax IP
> > 192.168.0.1
> > > .... the problem is after a few hours when no user in intranet using
the
> > > internet service , the NAT ROUTER will become mal-function until I
> active
> > > again the eth0 , can you tell me how to fix the fault?

> > > Regards,

> > > Sunny

 
 
 

NAT ROUTER PROBLEM...PLEASE HELP!

Post by Greenhan » Tue, 07 Aug 2001 02:25:59


oh yes, I really need that



15
> minutes,, i have time in diferent ocassions, so my rc.local load a ping at
> start up of the machine:

> ping -i 850 <ip number>

> the ping gets send every 14 minutes or so, write a scripts to test the
> condition of the connection i did not fins reazon for it as i am sure the
> connection dies after that amount of time i just send a ping to my
gateway,
> to keep the connection alive. Some friends that run winblows also have the
> same problem and they just leave they mail to check every 15 minutes....
> script i really dont need it, but if you do let me know i will write you
> one.



> > I have this problem too but I think this script isn't that good?
> > Can u give a better script such as testing if the condition is alive or
> not,
> > if alive then no need ping else ping
> > some ip? I didn't know the syntax in shells script and I wonder if this
> > script will consume much network resource? I am just a novice in
linux..so
> > if I said anything wrong, plz. excluse me



> > > i have the same problem, or similar, after 15 minutes of inactivite my
> > modem

> > alive
> > > i have add this line to my rc.local file:

> > > ping -i 120  ip# or my router (ex. 24.112.0.1)

> > > i added 4 diferent entries here and since then the modem is always
> alive,
> > > maybe this could help you



> > > > Hi,

> > > > My NATROUTER running with RH 7.1 with kernel 2.4.2 ,  eth0 connected
> to
> > > > cable modem with DHCP , eth1 connected to intranet with fiax IP
> > > 192.168.0.1
> > > > .... the problem is after a few hours when no user in intranet using
> the
> > > > internet service , the NAT ROUTER will become mal-function until I
> > active
> > > > again the eth0 , can you tell me how to fix the fault?

> > > > Regards,

> > > > Sunny

 
 
 

NAT ROUTER PROBLEM...PLEASE HELP!

Post by Leonard Even » Wed, 08 Aug 2001 23:21:07




> I have this problem too but I think this script isn't that good? Can u
> give a better script such as testing if the condition is alive or not,
> if alive then no need ping else ping

Pinging something every few minutes is not going to use signficant amount
of system resources.   You could even do it every 30 seconds without
making an impact.

--


Dept. of Mathematics, Northwestern Univ., Evanston, IL 60208

 
 
 

1. ISDN Routers (NAT) vs. External Modems Linux does the NAT

I keep feeling like buying an ISDN router would be a bad idea for me.  I do
alot of gaming and several of the software based NAT tools out there are
continously adding modules to support different games. (quake, etc).  I'm
probably going to be using multiple machines behind one IP.. and one
of those will most definately be a gaming machine.  I've already seen
one person posting that they bought a ISDN router but it wont support
a game they want to play.  In turn this makes me want to lean towards just
getting an external setup with a highspeed serial port card.  What is the
general consensus on this?

I'd love to see a good thread start on this. I think alot of people are
curious about these topics.

-Matthew

2. Talking about YTALK

3. Specific nat problem - GURUS HELP (bug in pf/nat?)

4. DEC Tulip Problem Trying to Build 2.0.35 Kernel for AS200

5. PLEASE PLEASE HELP Major problem with my SCSI & Redhat 5.0 PLEASE Help

6. NEC SuperScript 870 printer

7. Sendmail problems. Please please please please help!

8. ADSL - MS to set the standard?

9. LINUX instalation problems, PLEASE HELP !?!Subject: LINUX , instalation problems, PLEASE HELP !?!

10. Red Hat 7.3 Router problems. Please Help.

11. Linux Router Project (LRP) problem / please help

12. HELP: Apache & NAT router

13. newbie with a NAT ISDN router needs help