pppd 2.2.0f won't compile under Kernel 2.0.20

pppd 2.2.0f won't compile under Kernel 2.0.20

Post by Curtis Ma » Sun, 06 Oct 1996 04:00:00



OK, I have upgrade my kernel from 1.2.13 to 2.0.20 and my gcc to the
newest version (including the library.)  Then my old PPPD does not work,
so go and download the src of pppd-2.2.0f.  Since my kernel already
include the newest PPP code, I don't have to recompile my kernel.

So I go to compile the program.  I type 'make', when I compile to the
file cpp.c, dozen of error message come up.  All of them complain about
undeclared constants like CI_PREDICTOR, etc.  Anyone know which file
does those supposed to be define in, or am I forget to upgrade some
component?  Also anyone know where can I get the LINUX-ELF binary
version of pppd-2.2.0f?

Curtis Man

 
 
 

pppd 2.2.0f won't compile under Kernel 2.0.20

Post by Jizhong Wan » Mon, 07 Oct 1996 04:00:00



> OK, I have upgrade my kernel from 1.2.13 to 2.0.20 and my gcc to the
> newest version (including the library.)  Then my old PPPD does not work,
> so go and download the src of pppd-2.2.0f.  Since my kernel already
> include the newest PPP code, I don't have to recompile my kernel.

I am not sure if kernel 2.0.20 includes the newest ppp code. I am using
2.0.0 and pppd-2.2.0f. I had to recompile the kernel in order to use PPP
connection. You may want to do the same

---------------------------------------------------------------

Systems Analyst
---------------------------------------------------------------

 
 
 

pppd 2.2.0f won't compile under Kernel 2.0.20

Post by Al Longye » Mon, 07 Oct 1996 04:00:00



>> OK, I have upgrade my kernel from 1.2.13 to 2.0.20 and my gcc to the
>> newest version (including the library.)  Then my old PPPD does not work,
>> so go and download the src of pppd-2.2.0f.  Since my kernel already
>> include the newest PPP code, I don't have to recompile my kernel.

>I am not sure if kernel 2.0.20 includes the newest ppp code. I am using
>2.0.0 and pppd-2.2.0f. I had to recompile the kernel in order to use PPP
>connection. You may want to do the same

There have been some work in the drivers for PPP in the kernel with the
2.3 package. These changes are 'not ready for prime time' and so have not
been contributed to the networking group. When they are, they will NOT be
in the 2.0 version but the 2.1 series.

The driver in the 2.x kernel is totally compatible with the 2.2.0f version
of pppd. They are not compatible with the 2.1.2 version of pppd.

--

 
 
 

1. pppd 2.2.0f 'make kernel' won't copy files

In upgrading 1.2.13 kernal source with the pppd 2.2.0f source files, the
'make kernel' routine thinks it doesn't need to copy the updated files
which came with pppd. Rather, it seems to skip everything.

The problem is that it really does need to copy the files as remaking the
kernel is unsuccessful without them. I've checked to insure that one file
in particular, which 'make kernel' should copy, is not copied. So, it
looks like a problem with the pppd 'make kernel' routine and not with the
kernel recompile.

Has anyone else seen this? Any suggestions? (Other than upgrading away
from 1.2.13 which is more work than I'd care to do right now... :)

  Thanks,
   Scott

2. dismiss parameters which followed executable file?????

3. pppd - need help compiling pppd 2.2.0f

4. Mapping keys

5. pppd 2.2.0e won't compile

6. Unnecessary strings in object files from xlc

7. PPPD 2.2 won't compile under 1.3.83

8. static library builds, but won't link

9. PPPD 2.2.0f / CHAT doesn't work

10. pppd 2.2.0f and kernel 2.0.1

11. Kernel 2.0.22 and pppd 2.2.0f

12. Problems with pppd 2.2.0f with 2.0.0 kernel

13. Slack96 + kernel 2.0.0 + PPPD 2.2.0f => cannot even start