PPP and SMP

PPP and SMP

Post by Andrey Smirno » Thu, 29 Jul 1999 04:00:00



What's your kernel?


Quote:> Well, I partly solved the puzzle myself. The reason why
> PPP doesn't work in my computer is that I am running
> a dual 450mhz HP Kayak XA-s workstation, and the kernel
> is compiled to support SMP. When I booted the computer
> in single processor mode, PPP works beautifully!

> Is there a confliction between PPP and SMP? In other words,
> Is PPP supported in SMP? I would love to switch back
> to SMP mode because I have very heavy computations, but
> I also love to be connected to the internet!

> Cheers,
> weidong

> >>> Hi all,

> >>> Please help!

> >>> I would really like to hook up my favorate Linux operation
> >>> system to internet using PPP. I am using Slackware 4.0, and
> >>> have used pppsetup to setup the PPP connection. However,
> >>> each time when the modem is connected, pppd exits immediately
> >>> and complaints with an error message of

> >>> ioctl(PPPIOCGUNIT): Operation not permitted(1)

> >>> skip system log output

> >>> Any comments and suggestions are welcome!

> >>> -Weidong

 
 
 

PPP and SMP

Post by Weidong L » Fri, 30 Jul 1999 04:00:00


Well, I partly solved the puzzle myself. The reason why
PPP doesn't work in my computer is that I am running
a dual 450mhz HP Kayak XA-s workstation, and the kernel
is compiled to support SMP. When I booted the computer
in single processor mode, PPP works beautifully!

Is there a confliction between PPP and SMP? In other words,
Is PPP supported in SMP? I would love to switch back
to SMP mode because I have very heavy computations, but
I also love to be connected to the internet!

Cheers,
weidong

Quote:>>> Hi all,

>>> Please help!

>>> I would really like to hook up my favorate Linux operation
>>> system to internet using PPP. I am using Slackware 4.0, and
>>> have used pppsetup to setup the PPP connection. However,
>>> each time when the modem is connected, pppd exits immediately
>>> and complaints with an error message of

>>> ioctl(PPPIOCGUNIT): Operation not permitted(1)

>>> skip system log output

>>> Any comments and suggestions are welcome!

>>> -Weidong


 
 
 

PPP and SMP

Post by Larry Ozar » Fri, 30 Jul 1999 04:00:00




Quote:> Well, I partly solved the puzzle myself. The reason why
> PPP doesn't work in my computer is that I am running
> a dual 450mhz HP Kayak XA-s workstation, and the kernel
> is compiled to support SMP. When I booted the computer
> in single processor mode, PPP works beautifully!

> Is there a confliction between PPP and SMP? In other words,

^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Quote:> Is PPP supported in SMP? I would love to switch back
> to SMP mode because I have very heavy computations, but
> I also love to be connected to the internet!

> Cheers,
> weidong

No that's not your problem. I have no problem using PPP under an
SMP kernel. Are you sure you have the right module setup? If the kernels
are the same numerical version you've got to make sure their module trees
don't get confused with one another.

Larry

 
 
 

PPP and SMP

Post by Stefan Winte » Mon, 09 Aug 1999 04:00:00


Hi!

I have exactly the same problem.
I am using Kernel 2.2.3 with SMP active; once i recompile the kernel for
single processor usage everything works fine.

Kickdown

Andrey Smirnov schrieb in Nachricht

>What's your kernel?



>> Well, I partly solved the puzzle myself. The reason why
>> PPP doesn't work in my computer is that I am running
>> a dual 450mhz HP Kayak XA-s workstation, and the kernel
>> is compiled to support SMP. When I booted the computer
>> in single processor mode, PPP works beautifully!

>> Is there a confliction between PPP and SMP? In other words,
>> Is PPP supported in SMP? I would love to switch back
>> to SMP mode because I have very heavy computations, but
>> I also love to be connected to the internet!

>> Cheers,
>> weidong

>> >>> Hi all,

>> >>> Please help!

>> >>> I would really like to hook up my favorate Linux operation
>> >>> system to internet using PPP. I am using Slackware 4.0, and
>> >>> have used pppsetup to setup the PPP connection. However,
>> >>> each time when the modem is connected, pppd exits immediately
>> >>> and complaints with an error message of

>> >>> ioctl(PPPIOCGUNIT): Operation not permitted(1)

>> >>> skip system log output

>> >>> Any comments and suggestions are welcome!

>> >>> -Weidong