HELP: Squid.pid won't accept kill -USR1 (to delete log files)

HELP: Squid.pid won't accept kill -USR1 (to delete log files)

Post by Jan-Hennnig Schlagenhau » Mon, 09 Nov 1998 04:00:00



Hi all,

i've installed squid on my linux server without the squid.conf logfile
rotate option and now the logs are getting bigger and bigger. According to
the squid FAQ i should send a kill -USR1 'cat Squid.pid' signal, but the
response is 'no such pid'.

AFAIK squid has been installed by root, I am logged in as root, and still
it does not work.

Is there any way to avoid restarting my server and yet get the logfiles
erased?

Any sugggestions would be welcome!

Thanks,

Jan

 
 
 

1. Can't Kill Zombie processes, even with kill -9 (pid)

Hi, I am running KDE 3.0.5a on a Mandrake Linux 9.0 box and I am
seeing some really strange behaviour. A few processes like the
webrowser(mozilla 1.1) seem to get hung on my system. That is fine,
but when I try and kill the associated processes, it doesn't kill all
the processes. Even the kill -9 (pid) command, doesn't seem to make
any difference. The terminal dump is below:


18023 ?        00:00:05 mozilla-bin
18025 ?        00:00:00 mozilla-bin <defunct>
18273 ?        00:00:37 mozilla-bin
18275 ?        00:00:00 mozilla-bin <defunct>



18023 ?        00:00:05 mozilla-bin
18025 ?        00:00:00 mozilla-bin <defunct>
18273 ?        00:00:37 mozilla-bin
18275 ?        00:00:00 mozilla-bin <defunct>

17781 ?        00:00:00 xmovie



None of these processes go away even after I shutdown the X11
server.Any idea, what I might be doing wrong?

Thanks,

Av.

2. decompress tar.z files???

3. NSCA: "Could not log pid to file httpd.pid"

4. pmap hacking - identity mapping

5. 'kill -HUP pid' doesn't work for restart!

6. sed replacing ' with "

7. CERN HTTPD 3.0 -- Can't create logs and pid file

8. UDMA66 HPT366 linux driver

9. Couldn't write pid to pid file

10. "rm: can't unlink 'files'",can't delete files

11. 'delete' command in ftp delete files in local hard disk ???

12. Hosts.allow file problems, won't accept domains

13. /bin/mail won't accept stdin from file