imq usage grows dramatically

imq usage grows dramatically

Post by to.. » Fri, 05 May 2006 17:50:34



Kernel 2.6.16.12, iptables 1.3.4
imq kernel module loads correctly with 4 interfaces. When my system
works lsmod show imq usage equals few thousands

router:~# lsmod |grep imq
imq                     3588  14237

Morover usage of imq module grows during my system works. I use only 2
imq interfaces
6: imq0: <NOARP,UP> mtu 1500 qdisc htb qlen 30
    link/void
7: imq1: <NOARP,UP> mtu 1500 qdisc htb qlen 30
    link/void

When I observe strange behaviour of imq module all fraffic shaping,
that uses imq seems to work fine. Any ideas?

 
 
 

imq usage grows dramatically

Post by Andy Furnis » Tue, 09 May 2006 04:54:00



> Kernel 2.6.16.12, iptables 1.3.4
> imq kernel module loads correctly with 4 interfaces. When my system
> works lsmod show imq usage equals few thousands

> router:~# lsmod |grep imq
> imq                     3588  14237

> Morover usage of imq module grows during my system works. I use only 2
> imq interfaces
> 6: imq0: <NOARP,UP> mtu 1500 qdisc htb qlen 30
>     link/void
> 7: imq1: <NOARP,UP> mtu 1500 qdisc htb qlen 30
>     link/void

> When I observe strange behaviour of imq module all fraffic shaping,
> that uses imq seems to work fine. Any ideas?

IMQ is a considered a hack and so not in kernel.

Since 2.6.16 you can use IFB which can cover most but not all IMQ
functionality.

I still use IMQ and it seems that the ref count is dropped packets
(+backlog if any). I suppose it's because they are stolen from netfilter
and when dropped by queues they are released in a way which doesn't
expect them to have been stolen from netfilter.

Andy.

 
 
 

1. Apache growing,Growing,GROWING in memory usage

When Apahce first starts, it uses a small amount of memory.  As the days
progress, it gradually uses more and more.  I restarted it (stopped it
completly) at the beginning of the week after it had arrived at 800Meg+
memory used.  The server does go through -HUP restarts and at that time,
some memory is released, but not all of it.  In order to reclaim it I
have to kill it and restart.

I highly suspect one of the perl scripts is allocating memory and not
releasing it.  Are there some tools short of recompiling to help figure
it out or narrow it down?

Using:
Apache 1.3.9, mod_perl 1.21 on a RedHat 6.1 server.

Erik

Sent via Deja.com
http://www.deja.com/

2. Screen Help Needed

3. syslogd grows and grows and grows on 2.6/x86

4. running script in a teminal window

5. why does /var/adm/wtmp grow and grow and grow ...

6. alpha crashes during floppy access?

7. "Cached" grows and grows and grows...

8. Cannot move tty3 (AIX 3.1.5)

9. snmpd CPU usage keeps growing.

10. Root file system usage keeps growing

11. /usr/lpd/qadm.config grows and grows

12. root directory growing and growing and ....

13. Netscape Enterprise collections grow and grow...