changing transceiver on 3Com 3C590 PCI 10MBps board

changing transceiver on 3Com 3C590 PCI 10MBps board

Post by Jule » Thu, 15 Jan 2004 06:32:56



Hi all,

hopefully an easy answer. Any idea how to change the transceiver type on a
PCI 3C590 Etherlink III board (running redhat 7.1 btw)? I have one here
and have a feeling it's been left using something other than the twisted
pair interface.

The board looks happy under linux, the IP config all looks fine, and I'm
using a known-good cable between the board and the hub (curiously both the
light and the board and the light on the hub are on) - I just can't get
any data through the card.

Either the board is broken, or I'm hoping it's just switched to the wrong
interface / transceiver.

The diags at www.scyld.com seem to imply that there's another 3C590 PCI
board which is branded an XL - mine's an Etherlink III 10Mbps though,
which I get the impression is something different despite having the same
model number! The board's quite old, 1996 vintage by the looks of it.

Hopefully I can change the transceiver used from Linux though without
having to hook up a drive with DOS on it and use any 3Com DOS utils from
there.

cheers!

Jules

 
 
 

changing transceiver on 3Com 3C590 PCI 10MBps board

Post by Matt Payto » Thu, 15 Jan 2004 10:45:03



> Hi all,

> The board looks happy under linux, the IP config all looks fine, and I'm
> using a known-good cable between the board and the hub (curiously both the
> light and the board and the light on the hub are on) - I just can't get
> any data through the card.

> Either the board is broken, or I'm hoping it's just switched to the wrong
> interface / transceiver.

> The diags at www.scyld.com seem to imply that there's another 3C590 PCI
> board which is branded an XL - mine's an Etherlink III 10Mbps though,
> which I get the impression is something different despite having the same
> model number! The board's quite old, 1996 vintage by the looks of it.

Ahh, 3com...Great cards, but isn't it fun trying to figure out what
version you have ?

Quote:

> Hopefully I can change the transceiver used from Linux though without
> having to hook up a drive with DOS on it and use any 3Com DOS utils from
> there.

Maybe ifconfig and the media type option ?  I'd start there.

--
- Matt -

 
 
 

changing transceiver on 3Com 3C590 PCI 10MBps board

Post by Carl » Fri, 16 Jan 2004 23:29:46



> Hi all,

> hopefully an easy answer. Any idea how to change the transceiver type on a
> PCI 3C590 Etherlink III board (running redhat 7.1 btw)? I have one here
> and have a feeling it's been left using something other than the twisted
> pair interface.

> The board looks happy under linux, the IP config all looks fine, and I'm
> using a known-good cable between the board and the hub (curiously both the
> light and the board and the light on the hub are on) - I just can't get
> any data through the card.

> Either the board is broken, or I'm hoping it's just switched to the wrong
> interface / transceiver.

> The diags at www.scyld.com seem to imply that there's another 3C590 PCI
> board which is branded an XL - mine's an Etherlink III 10Mbps though,
> which I get the impression is something different despite having the same
> model number! The board's quite old, 1996 vintage by the looks of it.

> Hopefully I can change the transceiver used from Linux though without
> having to hook up a drive with DOS on it and use any 3Com DOS utils from
> there.

> cheers!

> Jules

see what driver is loading for your network card, then look in the
drivers documentation.  Linux is not new so probably somebody has used
such a card and has configured the module to handle the switch.  I think
documentation is installed when you install kernel-source package!?

clg

 
 
 

1. 3COM PCI board (3C590) causes system to hang

I have just set up 3Com PCI cards with the AHDK 1.1a drivers from 3Com. They seem to me to work great. If your card hangs on
the "H ksl init" it looks to me as the drivers could not be initiated, and I would suspect that you have a problem with PNP
functionality or that you have selected wrong connector/speed in the card setup software (DOS based).

2. Parity Option errors 'cu'

3. 3c590 PCI 10mbps ethernet card vx driver? (fwd)

4. network

5. 3COM Etherlink XL Combo 10Mbps (PCI)

6. Unix TIN newsreader setup for Supernews?

7. 3Com PCI 3C590 driver

8. missing getmntent()/getfsstat() on ISC (needed for rdist)

9. 3Com 3C590 PCI card & Linux?

10. Drivers for 3COM PCI Ethernet Card (3C590)

11. Anyone know how to get a 3Com 3C590-tpo PCI card to work?

12. 3Com's 3C590 PCI Ethernet card

13. Is the 3Com 3c590 EtherLink III PCI Adaptor supported?