Problems with CGI on a Virtual Host.

Problems with CGI on a Virtual Host.

Post by IwantFre » Thu, 13 Jan 2000 04:00:00



I made a virtual host on my machine, it works except for CGI won't run
on it.  CGI will run if I use the base address instead of the virtual
host.  When I try to run it I get the script I get the "Server
Configuration Error".  I have tried everything including setting the
Document root settings to full allows.   Security is not an issue here
becuase this is for internal devepment use.
Thanks in advance.
Bri
 
 
 

Problems with CGI on a Virtual Host.

Post by Kevin Steffe » Fri, 14 Jan 2000 04:00:00


In one of the conf-files there stands something about enabling cgi-scripts and
php3-pages outside the /cgi-bin/ alias. Uncomment those lines if you haven't
already tried.

-Kevin


>I made a virtual host on my machine, it works except for CGI won't run
>on it.  CGI will run if I use the base address instead of the virtual
>host.  When I try to run it I get the script I get the "Server
>Configuration Error".  I have tried everything including setting the
>Document root settings to full allows.   Security is not an issue here
>becuase this is for internal devepment use.
>Thanks in advance.
>Bri


 
 
 

1. Apache 1.3b2: Default Host and all virtual hosts serve only first virtual hosts pages?

Hello.

Have been running 1.2b8 for a intranet and decided to move upto 1.3b2. I
have several name based virtual hosts that have been working under
1.2b8. After compiling and installing 1.3b2 my virtual hosts do not
work. In fact what happens is that even though DocumentRoot and default
server name is different, eg: www.serverA.net pointing to /www/default,
Apache 1.3b2 will always take me to the first defined virtual host as if
it's locked to it no matter what virtual host I try to browse. What
gives? Please post and E-Mail.

In /etc/hosts for my machines IP address I have

A.B.C.D         www.default.net www.virtA.net www.virtB.net

In ../conf/httpd.conf I have;

<VirtualHost www.virtA.net>

DocumentRoot /usr/local/www/virtA
ServerName www.virtA.net
ErrorLog logs/virtA.error.log
TransferLog logs/virtA.access.log
</VirtualHost>

<VirtualHost www.virtB.net>

DocumentRoot /usr/local/www/virtB
ServerName www.virtB.net
ErrorLog logs/virtB.error.log
TransferLog logs/virtB.access.log
</VirtualHost>

--

2. mounting NTFS volumes

3. <n> virtual hosts problem + cgi security question

4. Gnome Gui error on Startup, rh7.3 help please

5. Virtual hosting: cgi-bin problem

6. ET4000/W32p ICS5341

7. Virtual Host Cgi problem

8. Computer Parts Forsale

9. Apache / Virtual Hosts for CGI problem

10. Problem with cgi on virtual host for Apache

11. FrontPage virtual hosting, removal or reset of virtual host

12. : How to prevent one named virtual host from "seeing" another virtual hosts files ?

13. Mixing Apache Name Based Virtual Hosts and SSL Virtual Host