pppd 2.2.0e won't compile

pppd 2.2.0e won't compile

Post by sam.. » Tue, 16 Apr 1996 04:00:00



ok here's where I'm at:

lcp.c: In function `RestartIdleTimer':
lcp.c:244: `PPPIOCGIDLE' undeclared (first use this function)
lcp.c:244: (Each undeclared identifier is reported only once
lcp.c:244: for each function it appears in.)
lcp.c: In function `LcpEchoCheck':
lcp.c:1708: `PPPIOCGIDLE' undeclared (first use this function)
make: *** [lcp.o] Error 1

I've upgraded the libraries and include files, nowhere can I find where
PPPIOCGIDLE is defined.

Any suggestions ?
Fred

 
 
 

1. Cannot compile pppd 2.2.0e!

I thought it was time to upgrade to a newer kernel, so I
downloaded and compiled kernel v.1.3.73. I am sure I included
support for ppp and tcp/ip networking etc. BTW, my previous setup
was Slackware 3.0 with kernel 1.2.13.

I reboot my machine and everything looks fine, except that when I
run pppd it says "Sorry: no support for ppp". After some
FAQ-reading I discovered that I needed version >2.2.0 of pppd, so
I downloaded version 2.2.0e.

The readme file states that I need to upgrade some kernel source
files by running "make kernel". "make kernel" did not install
anything because the ppp-part of my kernet was newer than the
files included in the ppp-package.

The readme file has a section about changing the /usr/src/linux/
drivers/net/Makefile, but when I compare the readme file with the
Makefile I notice that they are almost the same, except that
L_OBJS and M_OBJS in the readme file is LX_OBJS resp. MX_OBJS in
the Makefile. Anyway, time to compile pppd!

chat compiled fine, but pppd did not. All errors reported by gcc
are related to declarations that contains the word "int_32u" (or
something like that). It looks to me that there are no support
for this kind of variable. Now, what am I supposed to do? Has
anyone else experienced this problem?
Please help!

--

"Windows 95: from the guys who brought you EDLIN"

2. cgi answer

3. pppd 2.2.0e on 1.2.11 compile problems

4. VL-46 with Trident 9440

5. kernel 2.6.17 dhcp problem

6. Compiling PPPD 2.2.0e

7. Newbie needs help setting up dialout modem

8. PPPD 2.2 won't compile under 1.3.83

9. pppd 2.2.0f won't compile under Kernel 2.0.20

10. Can't compile kernel with ppp 2.2.0e

11. pppd 2.2.0f 'make kernel' won't copy files

12. Installing PPPD 2.2.0e