PCMCIA and Networking on RH61?

PCMCIA and Networking on RH61?

Post by Rob Mitchel » Tue, 01 Feb 2000 04:00:00



Hello,

On restart/book, shouldn't the PCMCIA modules in rc.d load before network if
my laptop uses a PCMCIA networking card?  Does the order matter?  Obviously,
my laptop's networking is not-working so I tried to change this order, but
still doesn't work.

TIA!

---
Rob Mitchell
Base Class Technologies, Inc.

 
 
 

PCMCIA and Networking on RH61?

Post by Simon Gree » Tue, 01 Feb 2000 04:00:00



> Hello,

> On restart/book, shouldn't the PCMCIA modules in rc.d load before network if
> my laptop uses a PCMCIA networking card?

You'd think so, wouldn't you? ;-)

Quote:> Does the order matter?  Obviously,
> my laptop's networking is not-working so I tried to change this order, but
> still doesn't work.

Indeed. However, unless something's gone badly wrong, the Ethernet interface
should be initialised as soon as card services starts. I'd start looking there.
Check /var/log/messages for the output from cardmgr and see whether it even
detects your ether card. You should a whole bunch of stuff there as it starts
up, finds the cards, and then runs init scripts for them.

Some Cirrus Logic chipsets require a "wakeup" option (read the HOWTO) in order
to initialise. I've seen that problem on one laptop I played with.

Cheers
Simon

> TIA!

> ---
> Rob Mitchell
> Base Class Technologies, Inc.



 
 
 

PCMCIA and Networking on RH61?

Post by Hamid Misn » Wed, 02 Feb 2000 04:00:00



>Hello,

>On restart/book, shouldn't the PCMCIA modules in rc.d load before network if
>my laptop uses a PCMCIA networking card?  Does the order matter?  Obviously,
>my laptop's networking is not-working so I tried to change this order, but
>still doesn't work.

Just leave it as is. The pcmcia init script will initialize and bring up your
network and other pcmcia stuff. If you network doesn't working, take a look at
/var/log/messages and check what error messages produced by cardmgr.

--


-                        There's no place like ~

 
 
 

1. BP6 + RH61 = no networking?

For several months I have run my RedHat 5.2/6.0/6.1 machine with no
problems on roadrunner.  After upgrading to a BP6/Dual Celeron system
and reinstalling RH 6.1, the system worked fine for one day, then
the following day, upon rebooting, I couldn't see the network.  I
installed Win95 on an old drive and booted up, and got an address just
fine, so I believe all the hardware is working.

When I boot up under Linux and it initialized eth0, both the NIC and
cable modem show link lights.  pump is never able to get an address.  I
have also tried the latest dhclient and dhcpcd.  In all cases the I see
the TD and RD lights flash as though communication is going on, but the
logs all show that the dhcp client never gets a response--it's like the
kernel is dropping everything.

In the meantime I tried to get PPP working, but it behaves the same
way... I see the TD and RD lights going, but the debug output shows that
no packets are getting in.

This morning I tried the uniprocessor kernel that ships with RH61, same
behavior.  I guess the next step is to build my own kernel; does anyone
have any better ideas?

--Dave

Sent via Deja.com http://www.deja.com/
Before you buy.

2. Obtaining fsck, and getting single-user mode to work...

3. RH61 doesnt print to networked printers

4. SLIP between two Computer..

5. Help with changing the IP header bits

6. Check for TCP checksum of Network Interface

7. RH61 doesnt print to networked computers

8. Matrox Mystique ands X.

9. PCMCIA Grey Cell Network Card and PCMCIA Modem don't work together