Chat script to connect to AT&T Worldnet almost working (drops connection)

Chat script to connect to AT&T Worldnet almost working (drops connection)

Post by David Ric » Sat, 09 Nov 1996 04:00:00




> Hello,

> I'm using Slackware 2.3 (kernel 1.2.8) and pppd to connect to AT&T with:

> pppd connect 'chat -v "" ATDT1234567 CONNECT "" Name:

> /dev/cua0 38400 -detach debug crtscts noipdefault modem defaultroute

> This seems to connect fine, sets the ifconfig on ppp0 with the local
> and remote IP address, but seems to have a problem with the default
> route part. If I try to check the route table with 'route', or ping
> a remote IP address, the connection drops. Yet if I do nothing I can
> sit there and admire the properly configured interface with ifconfig
> ppp0.

> I have the /etc/ppp/chap-secrets file root readable (and of the form):

> I'm pretty sure this is correct because I was getting Chap failures in
> the error logs prior to this. The /var/adm/messages and /var/adm/debug
> are included below. If anyone has any thoughts on it please let me
> know. The basic syntax should be ok because this same setup works fine
> to connect to my other ISPs (if I adapt the pppd connect line of
> course).

> Thanks for any/all advice.

> /var/adm/messages: it sits happily until I do something (21:18:28):
> Nov  2 21:17:52 shadow pppd[163]: ipcp: up
> Nov  2 21:17:52 shadow pppd[163]: local  IP address 199.70.44.165
> Nov  2 21:17:52 shadow pppd[163]: remote IP address 199.70.44.1
> Nov  2 21:18:28 shadow pppd[163]: fsm_rtermreq(LCP): Rcvd id 40.
> Nov  2 21:18:28 shadow pppd[163]: LCP terminated at peer's request
> Nov  2 21:18:28 shadow pppd[163]: ipcp: down
> etc....

> /var/adm/debug: it sits happily until I do something (21:18:28)
> Nov  2 21:17:52 shadow pppd[163]: IO singal received
> Nov  2 21:17:52 shadow pppd[163]: rcvd [IPCP ConfReq id=0x2 <addr
> 199.70.44.165> <compress VJ 0f 01>] d3 bb
> Nov  2 21:17:52 shadow pppd[163]: IO signal received
> Nov  2 21:17:52 shadow pppd[163]: rcvd [IPCP ConfReq id=0x27 <addr
> 199.70.44.1> <compress VJ 0f 01>] 50 86
> Nov  2 21:17:52 shadow pppd[163]: sent [IPCP ConfAck id=0x27 <addr
> 199.70.44.1> <compress VJ 0f 01>]
> Nov  2 21:17:52 shadow pppd[163]: Untimeout 2194:114f0
> Nov  2 21:17:52 shadow pppd[163]: Setting itimer for 0 seconds in
> untimeout.
> Nov  2 21:17:52 shadow pppd[163]: Script /etc/ppp/ip-up started; pid=175
> Nov  2 21:18:28 shadow pppd[163]: IO signal received
> Nov  2 21:18:28 shadow pppd[163]: rcvd [LCP TermReq id=0x28] 18 58
> Nov  2 21:18:28 shadow pppd[163]: Script /etc/ppp/ip-down started;
> pid=180

> (Note, neither ip-up or ip-down exist...)

I am connected vi World net now. My /etc/ppp/chap-secrets looks like:

*       *       my_painfully_long_password

Also in the /etc/ppp/options file I have a line like:

name my_painfully_long_user_id

Hope this helps.

 
 
 

1. ppp & chat scripts for AT&T's worldnet service???

Hi,

I am able to dial up to my ISP (AT&T's worldnet) but I have problems
starting my ppp & chat scripts. (My kernel is compiled with pppd
support). I suspect that my login and password pair is not get accepted.
Note that I can connect fine  through NT. I am new to linux so I don't
really know how to troubleshoot things.

I would greatly appreciate if someone could email me his ppp and chat
scripts for connecting to AT&T worldnet or any other ISP. Should I exit
minicom without reseting the modem before I execute the scripts? I am
using RH linux 4.2.

Thanks a lot,
Makis Gaitanidis

2. Netscape Server Internal Functions

3. How to create a VPN dial-up on Solaris 8

4. Almost connected (drops ppp connection)

5. seeking best IRC servers

6. AT&T WorldNet Dialup/Chat script

7. alt.os.linux.yggdrasil (was: alt.os.linux.caldera)

8. Working: chat, pppd, & Masq but line drops

9. PPP works with manual connection, but not with chat script

10. PPP/Chat: Working chat script Linux==>SCO?

11. script for ppp connection (I can't make 'chat' work)

12. I have AT&T Worldnet & Linux working!