PPPD 2.1.2 and v.34?

PPPD 2.1.2 and v.34?

Post by roo » Mon, 17 Jul 1995 04:00:00



 have kernal version 1.1.59, ppp version 2.7 and pppd version 2.1.2.
I have been trying to get a 115200 connection using ppp, but when
set the speed to 115200 it says it is not supported. Is a
speed of 115200 suported in this version of ppp, or do
I need to get a newer version? Or is my speed speed setup in the
ppp connection invalid? My ppp script is bellow.

./pppd connect 'chat -v "" ATDT7265230 CONNECT "" name xxxx  ord xxxx' \
        /dev/ttyS0 115200 debug crtscts modem defaultroute 0.0.0.0:

Thanks for any help.



 
 
 

PPPD 2.1.2 and v.34?

Post by Peter H. Lemie » Tue, 18 Jul 1995 04:00:00



Quote:

> have kernal version 1.1.59, ppp version 2.7 and pppd version 2.1.2.
>I have been trying to get a 115200 connection using ppp, but when
>set the speed to 115200 it says it is not supported.

Use

        setserial /dev/cua0 spd_vhi

before running pppd.  Use 38400 instead of 115200 in the command line for pppd.
"spd_vhi" tells Linux that 38400 should be interpreted as 115200.

Also you should be using /dev/cua0, not /dev/ttyS0.  The ttySx device series
is for inbound, not outbound serial connections.

Finally, fix your reply address in tin.  (Take a look at your posting to see
what I mean.)

Peter
-----
Peter H. Lemieux, President
cyways, inc.                                    Voice:        (800) 5-cyways
203 Arlington Street                            Foreign:   +1 (617) 924-7991
Watertown, Massachusetts 02172-2036  USA        Fax:       +1 (617) 926-8440
Your source for total Internet solutions (tm)   Home:  http://www.cyways.com

 
 
 

PPPD 2.1.2 and v.34?

Post by Supak Laile » Tue, 18 Jul 1995 04:00:00




Quote:> have kernal version 1.1.59, ppp version 2.7 and pppd version 2.1.2.
>I have been trying to get a 115200 connection using ppp, but when
>set the speed to 115200 it says it is not supported. Is a

Before running pppd, give a command 'setserial /dev/modem spd_vhi' then
fire up pppd using speed 38400.

The first command will give 115200bps connection whenever 38400 is
requested.

Supak Lailert

 
 
 

PPPD 2.1.2 and v.34?

Post by Terry Dawso » Thu, 20 Jul 1995 04:00:00



>  have kernal version 1.1.59, ppp version 2.7 and pppd version 2.1.2.
> I have been trying to get a 115200 connection using ppp, but when
> set the speed to 115200 it says it is not supported. Is a
> speed of 115200 suported in this version of ppp, or do
> I need to get a newer version? Or is my speed speed setup in the
> ppp connection invalid? My ppp script is bellow.

> ../pppd connect 'chat -v "" ATDT7265230 CONNECT "" name xxxx  ord xxxx' \
>         /dev/ttyS0 115200 debug crtscts modem defaultroute 0.0.0.0:

Carl,
Fix your nameserver configuration.

Then read the `setserial` man page. There is an option that looks
something like 'spd_vhi' that forces the uart to actually use
115kbps when you ask it to do 38k4bps. I haven't actually used it
so forgive me not supplying proper syntax.

Terry

 
 
 

1. Kernel 2.0.34 and pppd-2.3.*

Has anyone got kernel 2.0.34 working with pppd-2.3.3 or later?
I'm having a lot of trouble getting it to compile.

(2.2.0f is no use to me because I use pppd-2.3.3's on-demand
dialling.)

--
Richard Lamont                        To hell with Echelon and NSA/GCHQ spooks!

http://www.stonix.demon.co.uk/         encryption now.  http://www.fortify.net/

2. ne2000 not recognized

3. pppd 2.3.5 + kernel 2.0.34 problem !

4. Dual-boot Linux & NT4: a novel twist

5. Does pppd 2.3.5 work with kernel 2.0.34

6. JOIN THE NEW LINUX RESOURCE!!!

7. pppd 2.2.of problem after running kernel 2.0.34

8. Any 486 SMP (multi-CPU) boards available for Linux?

9. Matrox Mystique ands X.

10. pppd 2.2.0a crashing under Linux 1.3.34

11. PC-9800 subarch. support for 2.5.60 (34/34) rtc-update

12. Can't install Linux on 34 MB disk

13. 2048 byte/sector (MO disks), fat32, joliet in 2.0.33, or 2.0.34?