NE2000 ethernet and linux 2.1.125?

NE2000 ethernet and linux 2.1.125?

Post by Karl Steneru » Fri, 16 Oct 1998 04:00:00



I'm having a bit of trouble getting my NE2000 compatible card to work.

Everytime anything does an ioctl() call on eth0 (usually to set
broadcast address or something of the like), it fails.

Unfortunately, I've recently gotten a new motherboard/CPU and
reinstalled everything, plus I've just migrated from 2.0.25 to 2.1.125.

I know the card works, and I know it's on IRQ5, IOBase 0x240, which I am
passing into lilo (I'm currently using the card under windoze in order
to send this message)

In my previous config (on my previous machine), I had it on irq 10,
iobase 0x240, running linux 2.0.25, and it worked fine (though it kept

stupid IDE controller, and then windoze would try changing the irq and
iobase settings for me.  Oh what I have to go through in order to play
Starcraft...)

Is there something new I have to do under the 2.1 kernel to get this to
work properly?

----------------------
To reply via email, remove the SPAMXYZ from my address.

 
 
 

NE2000 ethernet and linux 2.1.125?

Post by |[T3PO] » Fri, 16 Oct 1998 04:00:00


Well, just curious, have you realized that your using a development kernel?

>I'm having a bit of trouble getting my NE2000 compatible card to work.

>Everytime anything does an ioctl() call on eth0 (usually to set
>broadcast address or something of the like), it fails.

>Unfortunately, I've recently gotten a new motherboard/CPU and
>reinstalled everything, plus I've just migrated from 2.0.25 to 2.1.125.

>I know the card works, and I know it's on IRQ5, IOBase 0x240, which I am
>passing into lilo (I'm currently using the card under windoze in order
>to send this message)

>In my previous config (on my previous machine), I had it on irq 10,
>iobase 0x240, running linux 2.0.25, and it worked fine (though it kept

>stupid IDE controller, and then windoze would try changing the irq and
>iobase settings for me.  Oh what I have to go through in order to play
>Starcraft...)

>Is there something new I have to do under the 2.1 kernel to get this to
>work properly?

>----------------------
>To reply via email, remove the SPAMXYZ from my address.


 
 
 

NE2000 ethernet and linux 2.1.125?

Post by bill davids » Fri, 16 Oct 1998 04:00:00




| I know the card works, and I know it's on IRQ5, IOBase 0x240, which I am
| passing into lilo (I'm currently using the card under windoze in order
| to send this message)
|
| In my previous config (on my previous machine), I had it on irq 10,
| iobase 0x240, running linux 2.0.25, and it worked fine (though it kept

| stupid IDE controller, and then windoze would try changing the irq and
| iobase settings for me.  Oh what I have to go through in order to play
| Starcraft...)

Make ne a module.
Config the card where you want it with isapnp.
Install the module.

If it isn't an ISA card I don't know if recent isapnp will also
configure PCI PnP cards or not.

This works for me on 2.0.33 and 2.1.101/106
--

Never underestimate the power of stupid people in large groups

 
 
 

NE2000 ethernet and linux 2.1.125?

Post by Karl Steneru » Sat, 17 Oct 1998 04:00:00


Of course, but I would expect an old driver like ne2000 to still work,
especially this late in the 2.1 kernel...

> Well, just curious, have you realized that your using a development kernel?

 
 
 

1. NE2000 ethernet and linux 2.1.125?

I'm having a bit of trouble getting my NE2000 compatible card to work.

Everytime anything does an ioctl() call on eth0 (usually to set
broadcast address or something of the like), it fails.

Unfortunately, I've recently gotten a new motherboard/CPU and
reinstalled everything, plus I've just migrated from 2.0.25 to 2.1.125.

I know the card works, and I know it's on IRQ5, IOBase 0x240, which I am
passing into lilo (I'm currently using the card under windoze in order
to send this message)

In my previous config (on my previous machine), I had it on irq 10,
iobase 0x240, running linux 2.0.25, and it worked fine (though it kept

stupid IDE controller, and then windoze would try changing the irq and
iobase settings for me.  Oh what I have to go through in order to play
Starcraft...)

Is there something new I have to do under the 2.1 kernel to get this to
work properly?

----------------------
To reply via email, remove the SPAMXYZ from my address.

2. FGETS NOT WORKING AFTER SCANF..

3. Samba 2.0.2 problem : Couldn't set effective gid ...Can't become connected user!

4. linux in a 486 with 125 Megs Hard Drive

5. AD: Linux CD with Slackware 2.3 and ELF, $10

6. ppp with Linux 2.1.125

7. endless reboot loop

8. Linux On DECstation 5000/125

9. PPP on Linux 2.1.125

10. Linux 2.1.125+ & DHCP

11. Linux 2.1.125 unmount problems at shutdown