2.3.11 ppp, framing errors are killing me

2.3.11 ppp, framing errors are killing me

Post by Gene Hesket » Mon, 03 Jan 2000 04:00:00



Unrot13 this;

Help wanted.  I installed ppp-2.3.11 about a week ago, and it seemed to
work great, for about 3 days.  Then it quit logging into my ISP with
exactly the same strings its been running with for months.  The login
failed with a really odd message, stateing that I wasn't allowed to use
the address the ISP gave me.

So I rebooted, wrecking a 51 day uptime, and it went back to work.  The
next day I'm seeing stalls, and even hangups, and ifconfig reports a
framing error for about every 25 packets received.  No tx problems, just
rx.

I'm about to go back to 2.3.10, but 11 has some features I'd like to
play with.

The kernel is 2.2.14pre6 FWIW.  Basic Mandrake 6.0 install with lots of
updates, like the newer ppp's.

Ideas anyone, or is it a known incompatability?

Cheers, Gene
--



                        email gene underscore heskett at iolinc dot net
This messages reply content, but not any previously quoted material, is
? 1999 by Gene Heskett, all rights reserved.
--

 
 
 

2.3.11 ppp, framing errors are killing me

Post by Gene Hesket » Mon, 03 Jan 2000 04:00:00


Unrot13 this;

Gene Heskett sends Greetings to ppp guru's;

 GH> Help wanted.  I installed ppp-2.3.11 about a week ago, and it
 GH> seemed to work great, for about 3 days.  Then it quit logging
 GH> into my ISP with exactly the same strings its been running with
 GH> for months.  The login failed with a really odd message, stateing
 GH> that I wasn't allowed to use the address the ISP gave me.

 GH> So I rebooted, wrecking a 51 day uptime, and it went back to
 GH> work.  The next day I'm seeing stalls, and even hangups, and
 GH> ifconfig reports a framing error for about every 25 packets
 GH> received.  No tx problems, just rx.

 GH> I'm about to go back to 2.3.10, but 11 has some features I'd like
 GH> to play with.

UPDATE: 2.3.10 back in, reboot, no change. I've been online with it for
10 minutes, and ifconfig reports 163 frameing errors in 2.9 megs of
incoming data.

 GH> The kernel is 2.2.14pre6 FWIW.  Basic Mandrake 6.0 install with
 GH> lots of updates, like the newer ppp's.

 GH> Ideas anyone, or is it a known incompatability?

Cheers, Gene
--



                        email gene underscore heskett at iolinc dot net
This messages reply content, but not any previously quoted material, is
? 1999 by Gene Heskett, all rights reserved.
--

 
 
 

2.3.11 ppp, framing errors are killing me

Post by k.. » Mon, 03 Jan 2000 04:00:00



>  GH> Help wanted.  I installed ppp-2.3.11 about a week ago, and it
>  GH> seemed to work great, for about 3 days.  Then it quit logging
>  GH> into my ISP with exactly the same strings its been running with
>  GH> for months.  The login failed with a really odd message, stateing
>  GH> that I wasn't allowed to use the address the ISP gave me.

That sounds like there was a default route to a LAN added at some
point.  The message for that is

   Peer is not authorized to use remote address www.xxx.yyy.zzz

but that means that the peer (ISP) wasn't authorized to use the
address it requested for itself.

That's a security tweak, one that I wish had never been born.

Quote:>  GH> So I rebooted, wrecking a 51 day uptime, and it went back to
>  GH> work.  The next day I'm seeing stalls, and even hangups, and
>  GH> ifconfig reports a framing error for about every 25 packets
>  GH> received.  No tx problems, just rx.
>  GH> I'm about to go back to 2.3.10, but 11 has some features I'd like
>  GH> to play with.
> UPDATE: 2.3.10 back in, reboot, no change. I've been online with it for
> 10 minutes, and ifconfig reports 163 frameing errors in 2.9 megs of
> incoming data.

Try using the pppd "asyncmap a0000" option, it cures a surprising
number of ills.  Check the modem to computer flow-control (pppd option
crtscts and modem hardware handshake, &K3 in the Hayes command set).
Check UART flow-control by lowering the pppd speed option to, say,
38400.  Try the hdparm -u1 option to see if that helps (IDE disk
keeps interrupts off too long).

Quote:>  GH> The kernel is 2.2.14pre6 FWIW.  Basic Mandrake 6.0 install with
>  GH> lots of updates, like the newer ppp's.
>  GH> Ideas anyone, or is it a known incompatability?

I'm using a pristine 2.3.13 kernel and pppd 2.3.11 without any problem.


/* ... packets usually cross many administrative boundaries on their way
 from a source to a destination and often the only point of agreement
 between those separate administrations is that all problems are someone
 else's fault.   --Van Jacobson, abstract of April 97 MSRI talk */

 
 
 

2.3.11 ppp, framing errors are killing me

Post by Gene Hesket » Tue, 04 Jan 2000 04:00:00


Unrot13 this;

Gene Heskett sends Greetings to kite ;


>>  GH> Help wanted.  I installed ppp-2.3.11 about a week ago, and it
>>  GH> seemed to work great, for about 3 days.  Then it quit logging
>>  GH> into my ISP with exactly the same strings its been running
>>  with GH> for months.  The login failed with a really odd message,
>>  stateing GH> that I wasn't allowed to use the address the ISP gave
>>  me.
> That sounds like there was a default route to a LAN added at some
> point.  The message for that is
>    Peer is not authorized to use remote address www.xxx.yyy.zzz
> but that means that the peer (ISP) wasn't authorized to use the
> address it requested for itself.
> That's a security tweak, one that I wish had never been born.

That makes 2 of us.

Quote:>>  GH> So I rebooted, wrecking a 51 day uptime, and it went back to
>>  GH> work.  The next day I'm seeing stalls, and even hangups, and
>>  GH> ifconfig reports a framing error for about every 25 packets
>>  GH> received.  No tx problems, just rx.
>>  GH> I'm about to go back to 2.3.10, but 11 has some features I'd
>>  like GH> to play with.
>> UPDATE: 2.3.10 back in, reboot, no change. I've been online with it
>> for
>> 10 minutes, and ifconfig reports 163 frameing errors in 2.9 megs of
>> incoming data.
> Try using the pppd "asyncmap a0000" option, it cures a surprising
> number of ills.

Did that, no change.  It had been running at about 6k/sec for several
months without it.

Quote:>  Check the modem to computer flow-control (pppd
> option crtscts and modem hardware handshake, &K3 in the Hayes
> command set).

&K3, yes.  The modem init strings are functionally identical, MiamiDX
feeds it all out as one string, and linux rations it out in 3.

 Check UART flow-control by lowering the pppd speed

Quote:> option to, say,
> 38400.

I haven't tried 38400, but 57600 didn't seem to effect it.

  Try the hdparm -u1 option to see if that helps (IDE disk

Quote:> keeps interrupts off too long).

-u1?  I've forgotten that option, but UDMA-33 is working here, as near
as I can tell, on all 5 drives.  Unless one of them has reneged.  hdparm
is showing the hard drives at 15 megs/sec or so.

Quote:> I'm using a pristine 2.3.13 kernel and pppd 2.3.11 without any
> problem.

I'm about to unpack that puppy again, thats the one I built 2.2.14pre18
out of, and it won't boot, buckets of depmod errors and very little
actually works.

Cheers, Gene
--



                        email gene underscore heskett at iolinc dot net
This messages reply content, but not any previously quoted material, is
? 1999 by Gene Heskett, all rights reserved.
--

 
 
 

1. ppp 2.3.11 not working

My linux box is used as a firewall to my LAN, I have been using this setup
without a problem using
ppp2-3.8 one demand with kernel 2.2.14. I decided to upgrade to ppp2.3.11
and had no problem with the installation of it, I reboot the box and
ppp-2.3.11 came up without a problem, but my demand option no longer works,
I used to be able to start the line by just doing a ping to an internet
site, but now that is not working now. Anyone had this problem before ??

thanks
Andres

2. Cannot disable IP Forwarding on Solaris 2.5/2.5.1

3. trouble ppp 2.3.11 & Kernel 2.2.16

4. umsdos/win95

5. ppp 2.3.11 hanging..

6. Help with ELF! Please!

7. Kernel 2.3.11 - error

8. Starting X chooser

9. mod_ssl 2.3.11-1.3.6 & 2.2.8-STABLE install problems

10. Installing elm 2.3.11 on RS6000

11. Where is latest pppd 2.3.11 please?

12. Why am I getting kill by signal 11...randomly

13. pppd.2.4.1 fails where pppd.2.3.11 worked. Why? (fwd)