proxy arp not working in ppp session

proxy arp not working in ppp session

Post by Geoffrey Dan » Tue, 13 Jan 1998 04:00:00



Hi -Hi -
I recently upgraded by fresh installation (not upgrade) the machine
in my office from RedHat 4.2 to RH 5.0.  

Before the upgrade, I had it working so I could dial in from my home
machine (also RH4.2) using diald with ppp, and have internet access.
Now it doesn't work.  

I've re-read the ppp server installation instructions, and think I've
covered the installation ok.  

When dialed-in and logged in, /sbin/route and /sbin/arp -a show the
expected routing on both the home and office machine.  Still, the home
machine can't see any others besides the one it's dialed into, and other
machines on the net can't see my home machine.  

I changed ethernet cards as part of the upgrade, and now have a 3Com
905.  Is that possibly related to proxy arp not working?  

Any known bugs I've missed?  
Thanks..
                                geoff

--
Geoffrey Dann             805-982-1366 or DSN-551-1366 (voice)

Naval Facilities Engineering Service Center, Port Hueneme CA USA 93043

 
 
 

proxy arp not working in ppp session

Post by Geoffrey Dan » Wed, 14 Jan 1998 04:00:00


I solved my own problem (and exchanged email with one other
person with the same problem).  
The solution was found in the mailing list archives
on www.redhat.com.  

I used /usr/bin/netcfg (as root, from an xterm) to edit
/etc/sysconfig/network. I clicked on the box labeled
"Network Packet Forwarding (IPv4)".  
This changed a line in /etc/sysconfig/network to:
     FORWARD_IPV4=yes
Then I rebooted the machine.

On RedHat 4.2, this line is not in the /etc/sysconfig/networks file, and
the
corresponding check box is not in the netcfg tool.

> Hi -
> I recently upgraded by fresh installation (not upgrade) the machine
> in my office from RedHat 4.2 to RH 5.0.

> Before the upgrade, I had it working so I could dial in from my home
> machine (also RH4.2) using diald with ppp, and have internet access.
> Now it doesn't work.

> I've re-read the ppp server installation instructions, and think I've
> covered the installation ok.

> When dialed-in and logged in, /sbin/route and /sbin/arp -a show the
> expected routing on both the home and office machine.  Still, the home
> machine can't see any others besides the one it's dialed into, and other
> machines on the net can't see my home machine.

> I changed ethernet cards as part of the upgrade, and now have a 3Com
> 905.  Is that possibly related to proxy arp not working?

> Any known bugs I've missed?
> Thanks..
>                                 geoff

> --
> Geoffrey Dann             805-982-1366 or DSN-551-1366 (voice)

> Naval Facilities Engineering Service Center, Port Hueneme CA USA 93043

--
Geoffrey Dann             805-982-1366 or DSN-551-1366 (voice)

Naval Facilities Engineering Service Center, Port Hueneme CA USA 93043

 
 
 

1. ppp connection proxy arp not working

Hi -
I recently upgraded by fresh installation (not upgrade) the machine
in my office from RedHat 4.2 to RH 5.0.  
I had it working so I could dial in from my home machine (also RH4.2)
using ppp, and have internet access.  Now it doesn't work.  
I've re-read the installation instructions, and think I've covered
the installation ok.  
When dialed-in and logged in, /sbin/route and /sbin/arp -a show the
expected routing.  Still, the home machine can't see any others besides
the one it's dialed into, and other machines on the net can't see my
home machine.  
I changed ethernet cards as part of the upgrade, and now have a 3Com
905.  
Is that possibly related to proxy arp not working?  
Any known bugs I've missed?  
Thanks..
                                geoff

2. SVGALIB, C++ destructors, signals and general peculiarities...

3. PPP works, but proxy ARP doesn't

4. Wu-ftpd: Forbid one user from deleting files?

5. Proxy arp not working in Linux

6. Transfering *.pll and *.plx files

7. does proxy arp not work in solaris 2.3 or 2.4?

8. nis+ help needed

9. Proxy arp does not work

10. Proxy-arp command not working

11. I can not get ARP to work, even though /proc/net/arp is correct!

12. Proxy arp (how to add an arp entry)

13. HELP: PPP/with Proxy worked one way but not the other