PPP 2.2 is incompatible with the v1.3.x kernels (badly so)

PPP 2.2 is incompatible with the v1.3.x kernels (badly so)

Post by Al Longye » Tue, 10 Oct 1995 04:00:00





>>I'm using the v1.3.30 kernel because I want built in AIC7XXX support (as
>>well as a few other cutting edge enhancements)

>>I've been having slight troubles with the ppp2.1.2b drivers and such in not
>>properly maintaining the line or terminating the connection so I was
>>psyched when PPP 2.2 was relased.  Big let down though...

>>./configure
>>make
>You need to do 'make kernel' first.  That patches the kernel to work with 2.2.
>After that 2.2 works fine.

For what it is worth, I sent Linus the patches for the 2.2 code.

They should be in the 1.3.33 kernel update.

Please do however continue to do the 'make kernel'. Doing this solves some
problems when the package actually does have a more recent version of the
driver or include files than what is shipped with the kernel.

For the pppstats program to work properly with the reports for the compression
statistics you will need the 2.2.0a code from sunsite as well. This change
prevents the kernel panic which happens if you attempt to run the pppstats
program on a system which is doing software floating point (a 386 without
a 387).

There is still a change. The BSD compressor, bsd_comp, can only be built
as a module with the 2.2.0a package. This was an oversight on my part when
I uploaded the 2.2 code to sunsite. If you attempt to build the code without
it being a module then the compile of bsd_comp will fail.

You may put the ppp.c driver into the kernel. You just can't put the BSD
compressor into the kernel because there are some technical reasons as well
as some legal issues which need to be addressed. (Motorola has a software
patent on some of the issues involved. It is felt that the BSD compressor
does not employ the items which Morotola holds a patent but in today's
littiguous society it is better that the code not be an integral part of
anyone's kernel.)

So, for the code to work the best, it is probably better if you obtain
the full kernel distribution for 1.3.33 rather than a patch. If you do use
a patch method then be careful about the patches to the Makefile in the
drivers/net directory. The patches should be made. If they don't go in then
make the necessary changes by hand.

If you don't have the Makefile as given then the compile will fail.

YOU HAVE BEEN WARNED.

Thanks.

--

The above opinions do not necessarily represent those of the Management
of System Integrators nor any of its subsidiaries.

 
 
 

PPP 2.2 is incompatible with the v1.3.x kernels (badly so)

Post by Axel Bold » Fri, 13 Oct 1995 04:00:00



Quote:>> You need to do 'make kernel' first.  That patches the kernel to
>> work with 2.2.  After that 2.2 works fine.

Al> For what it is worth, I sent Linus the patches for the 2.2 code.
Al> They should be in the 1.3.33 kernel update.

Al> Please do however continue to do the 'make kernel'. Doing this solves some
Al> problems when the package actually does have a more recent version of the
Al> driver or include files than what is shipped with the kernel.

Could you please update the information in the PPP-HOWTO? Because it
says that the driver coming with the kernel should not be
changed/replaced.

Axel

 
 
 

1. Slackware 2.2 bug: binutils "strings" incompatible with installpkg

Slackware 2.2 has a /usr/bin/strings binary in two different packages:
a2/util.tgz and d8/binutils.tgz.  The util.tgz version looks like this:

-rwxr-xr-x root/bin       3504 Mar 21 04:37 1995 usr/bin/strings

The binutils.tgz version looks like this:

-rwxr-xr-x root/bin     135172 Dec 14 12:02 1994 usr/bin/strings

Now, it wouldn't be such a big deal that the two versions are different, if it
weren't for the fact that the util.tgz version takes input from stdin and the
binutils.tgz version doesn't.  Unfortunately, /sbin/installpkg expects the
former behavior:

        if cat $file | strings | uniq | fgrep "$shortname:" >> /var/adm/packages/$shortname 2> /dev/null ; then
          cat $file | strings | uniq | fgrep "$shortname:"

Therefore, after installing the binutils.tgz package, installpkg will
suddenly start printing errors of this sort when it runs:

Usage: /cdrom/live/usr/bin/strings [-afov] [-n min-len] [-min-len] [-t {o,x,d}] [-]
       [--all] [--print-file-name] [--bytes=min-len] [--radix={o,x,d}]
       [--target=bfdname] [--help] [--version] file...

It does actually install the package even when it prints this error, but
still, this is sub-optimal.

Every version of "strings" I've ever used has been able to take input from
stdin, so it seems to me that this is a bug with the binutils version of
strings, so I'm CC'ing this to its maintainers as well as to the maintainer of
Slackware.

(If you don't care about the extra functionality that the binutils.tgz version
of "strings" provides, an easy solution to this problem is simply to reinstall
the utils.tgz version after installing binutils.tgz.)

2. Linux not stable after half a day

3. Communicator 4.61 - incompatible with Caldera 2.2?

4. DNS tools?

5. Linuxconf seems incompatible with 2.2.x

6. Problem: On bootup always says to run fsck

7. PPP 2.2.0c and Kernel 1.2.13

8. Leadtek Winfast A170 DDR drivers?

9. ppp 2.2.0c /w kernel 1.3.45: freelist?

10. local ppp no longer working with kernel 2.2.x

11. ppp 2.2.0c kernel compile problems

12. ppp (2.2.0f) with kernel 2.0.11/13: OK not received.

13. for 2.2.x i386 Linux kernel DoS - Affects 2.2.x and probably 2.0.x