Trouble connecting Linux RedHat 5.0 to Internet via cable modem.

Trouble connecting Linux RedHat 5.0 to Internet via cable modem.

Post by Jeff » Sun, 01 Nov 1998 04:00:00



Hi.
I am having a*ens of a time connecting to the internet via cable modem.
Here is what I have:
RedHat 5.0
Tulip DEC Chip 21041 Ethernet Card
I have set this up through "netcfg" and also added a module in Kernel
Configuration. Someone told me that I needed to enable the card with DHCP
since my IP address is assigned dynamically. I'm not sure how to do this.
Could someone please give me a hand?
Any help would be greatly appreciated.
Thanks,
Jeff
 
 
 

Trouble connecting Linux RedHat 5.0 to Internet via cable modem.

Post by Oliver Jon » Mon, 02 Nov 1998 04:00:00




>I am having a*ens of a time connecting to the internet via cable modem.
>Here is what I have:
>RedHat 5.0
>Tulip DEC Chip 21041 Ethernet Card
>I have set this up through "netcfg" and also added a module in Kernel
>Configuration. Someone told me that I needed to enable the card with DHCP
>since my IP address is assigned dynamically.

I have the same setup, except I have RH 5.1.  It works great.
Read the HOWTO/mini/Cable-Modem and HOWTO/mini/DHCPcd (if your cable
company requires you to use DHCPcd).

Note, my cable company requires me to call their customer service line
(...Press 3 for pay-per-view wrestling... :-) and tell them the
HWAddr of my ethernet card, then they punch stuff into the network,
then I have to unplug the cable modem itself (from the power, not the
coax) for two minutes, then reboot everything.

My /etc/sysconfig/network-scripts/ifcfg-eth0 says this:
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

DCHP itself tells my machine the identity of the name servers and
and gateway machine.