Help with RH 6.1 PPP script

Help with RH 6.1 PPP script

Post by Adriano Marcu » Sat, 22 Apr 2000 04:00:00



Hello all,
After many hors of work got Kppp to work.  Now attmpting to automate the
connections script I get the following error during execution of
ppp-on-dialer script.
Ist the set up is RedHat 6.1 on an AMD 333 64M RAM 3COM III Diamond
Stealth PCI and 56K lucent modem.  

ppp-on calls ppp-on-dialer (all set up according to RH
instructions) ppp-on is in /usr/sbin ad ppp=on-dialer  is in /etc/ppp
both have proper file properties set, but when ppp-on-dialer is processed
the error /etc/ppp/ppp-on-dialer: ABORT: command not found     connect
script failed message is then posted.

Canot seem to locate any info as to why this message is posted, why it is
posted and how to correct it........
CAn anyone please help?

Adriano

 
 
 

Help with RH 6.1 PPP script

Post by Clifford Kit » Sat, 22 Apr 2000 04:00:00



> ppp-on calls ppp-on-dialer (all set up according to RH
> instructions) ppp-on is in /usr/sbin ad ppp=on-dialer  is in /etc/ppp
> both have proper file properties set, but when ppp-on-dialer is processed
> the error /etc/ppp/ppp-on-dialer: ABORT: command not found     connect
> script failed message is then posted.

This could happen if you are trying to execute the scripts as a normal
user and the chat program used by ppp-on-dialer doesn't specify the
full pathname.

BTW, exact copies of error messages allow better diagnoses.

--

/* The signal-to-noise ratio is too low in many [news] groups to make
 * them good candidates for archiving.
 *    --- Mike Moraes, Answers to FAQs about Usenet */

 
 
 

1. Probems With Using PPP Scripts In RH 6.1

Hi,
    I have had a problem with connecting to my isp with the Red
Hat 6.1 dialers. (Rh dialer (gnome)) and (Kppp dialer) so I
decided to use my own script with pppd. So far I can connect
to my isp, but, I get a message in /var/log/messages that says
"Not replacing existing default route to eth0 [10.0.0.254].
I guess that this route was set up when I set up my lan with my
other computer. So, even though I got a ppp connection to my isp,
I could not, immediately, do anything with it. So, I did :
route add default ppp0. That worked and then I could use my
internet connection.
  Now, I want to somehow add this defaultroute somewhere so
that I don't have to type it in.
  I have put the "defaultroute" line in both my /etc/ppp/options file
and my /etc/ppp/peers/ispfile, yet it makes no difference. I still
have to type in the aforementioned route statement, manually.
  The way that I connect to my isp is to use the following
command line:   pppd call myispname .

                                                Thanks

                                                    Mike

2. relayfs, a high-speed data relay filesystem

3. RH 6.1 and Mandrake 6.1 Freeze on Install

4. DBX error with threaded program

5. Problems w/ default gateway and PPP on RH 6.1 system

6. BIN_TO_BCD consolidation

7. ppp startup "ifup ppp0" requires two tries RH 6.1

8. Handling cisco-traps by ucd-snmp

9. RH 6.1 and PPP woes...

10. How to set up RH Linux 6.1 box for dial-in ppp access?

11. Slow PPP in RH 6.1

12. RH 6.1- PPP daemon keeps dying on dialup

13. where does ppp "shutdown" occur in RH 6.1?