DHCP problem in RH 7.2

DHCP problem in RH 7.2

Post by Simon Gree » Sat, 03 Nov 2001 20:07:42



Do you have forwarding enabled? Have you setup masquerading?

> Hi,

> I am trying to install RH7.2 from scratch again. :)

> I had a Linux RH 7.2 as router for a WinME box.

> I tried to installed DHCP, I think it had some problem...

> I can "ping www.yahoo.com" from my Linux box,
> I can "ping 192.168.1.2" ( ping WinME from Linux),
> I can "ping 192.168.1.1" ( ping Linux from WinME)
> But
> I can't "ping www.yahoo.com" from my WinME.

> Here's my ifconfig:
> -----------------------------------

> eth0      Link encap:Ethernet  HWaddr 00:60:08:C9:F9:36
>           inet addr:64.217.XX.XXX  Bcast:255.255.255.255
>           Mask:255.255.240.0
>           UP BROADCAST NOTRAILERS RUNNING  MTU:1500  Metric:1
>           RX packets:40 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:53 errors:0 dropped:0 overruns:0 carrier:3
>           collisions:0 txqueuelen:100
>           RX bytes:9461 (9.2 Kb)  TX bytes:11183 (10.9 Kb)
>           Interrupt:10 Base address:0x2000

> eth1      Link encap:Ethernet  HWaddr 00:A0:CC:E3:C1:A9
>           inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
>           UP BROADCAST RUNNING  MTU:1500  Metric:1
>           RX packets:328 errors:54 dropped:0 overruns:0 frame:0
>           TX packets:148 errors:24 dropped:0 overruns:0 carrier:48
>           collisions:0 txqueuelen:100
>           RX bytes:40763 (39.8 Kb)  TX bytes:15627 (15.2 Kb)
>           Interrupt:12 Base address:0x7000

> lo        Link encap:Local Loopback
>           inet addr:127.0.0.1  Mask:255.0.0.0
>           UP LOOPBACK RUNNING  MTU:16436  Metric:1
>           RX packets:230 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:230 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:0
>           RX bytes:16276 (15.8 Kb)  TX bytes:16276 (15.8 Kb)
> ---------------------------------------------------------------

> Is there something wrong about my DHCP setup?

> 1. for eth0:  "UP BROADCAST NOTRAILERS RUNNING"
>    What does it mean?

> 2. for eth1:  "UP BROADCAST RUNNING"
>    It didn't have MULTICAST, is it OK?
>    also, RX, TX all have errors...

> Could some one help me on it?

> Many Thanks.

> Q

 
 
 

DHCP problem in RH 7.2

Post by Whitey Johnso » Sun, 04 Nov 2001 02:55:02




Quote:> Hi,

> I am trying to install RH7.2 from scratch again. :)

> I had a Linux RH 7.2 as router for a WinME box.

> I tried to installed DHCP, I think it had some problem...

> I can "ping www.yahoo.com" from my Linux box, I can "ping 192.168.1.2" (
> ping WinME from Linux), I can "ping 192.168.1.1" ( ping Linux from
> WinME) But
> I can't "ping www.yahoo.com" from my WinME.

Have you set the Linux box up to act as a router (using iptables or
ipchains)?
If so can you ping IP addresses from the win machine? try
ping 216.115.102.78
(that's one of yahoo's servers)
if so have you set up the correct DNS information on the DHCP server to be
sent to the win client? Try running ipconfig /all from a prompt on the Win
machine and see if it shows DNS servers and 192.168.1.1 as the gateway.

--
Whitey Johnson

Save a Tree. Eat a Beaver.

 
 
 

DHCP problem in RH 7.2

Post by a.. » Tue, 13 Nov 2001 15:30:36





> > Hi,

> > I am trying to install RH7.2 from scratch again. :)

> > I had a Linux RH 7.2 as router for a WinME box.

> > I tried to installed DHCP, I think it had some problem...

> > I can "ping www.yahoo.com" from my Linux box, I can "ping 192.168.1.2" (
> > ping WinME from Linux), I can "ping 192.168.1.1" ( ping Linux from
> > WinME) But
> > I can't "ping www.yahoo.com" from my WinME.

> Have you set the Linux box up to act as a router (using iptables or
> ipchains)?
> If so can you ping IP addresses from the win machine? try
> ping 216.115.102.78
> (that's one of yahoo's servers)
> if so have you set up the correct DNS information on the DHCP server to be
> sent to the win client? Try running ipconfig /all from a prompt on the Win
> machine and see if it shows DNS servers and 192.168.1.1 as the gateway.

Whitney:

Thanks you very much...
It solve my problems.... :)

Q

 
 
 

1. Problems booting ASPLinux (RH 7.2 compat) using DHCP

Hello all,

I have a Gateway Solo-9300 notebook with 288M mem, 20GB hd, Xircom
RealPort 10/100 + 56k PCMCIA modem.

This notebook is a dual-boot (Windows 2000 Advanced Server, ASP-Linux
7.2).

Everything (except video) was detected properly during installation.
The video needed special Xconfigurator work to enable the enhanced
resolution.  Further configuration enabled DHCP on the office network.

Yesterday I changed the pcmcia boot sequence to 9 from 45 to start it
before networking and the ethernet.  This worked fine through multiple
reboots.

Today I started the machine on the office network and the DHCP failed.

I received numerous messages during boot, the first one displayed is :

"'./config.opts' line 8: no function bindings"

Many other messages fly past on the screen during the bootup with the
result being that my ethernet connection failed to connect.

After many attempts to get the connection working, I powered down
during the boot sequence (immediately after the pcmcia initialization
failed).  Removed the card, reinserted the card and powered up.

This time, the boot worked and DHCP resolved properly.

Questions:

1) Is this normal ?

2) I still get messages displayed during boot.  Where can I find the
complete listing of these boot messages?

3) My ethernet card doesn't show up in the Network Configuration
utilities first panel (under KDE).  Since it's PCMCIA, should it?  If
yes, how do I get it to show?

TIA

Eric M. Smith

2. home based jobs!!!! 7329

3. DHCP Server configuration problem on RH 7.2

4. Secure login using a palm pilot?

5. RH 7.2, DHCP, LPD and IP Address Cable Modem Problem

6. About Machine Performance issue

7. DHCP will not (RH 7.2)

8. Is it just me?

9. Want to disable DHCP on boot in RH 7.2

10. Pump/DHCP on (generic) RH 7.2 [and Verizon DSL]

11. RH 7.2 DHCP DNS Question

12. RH 7.2 font aliasing problem after upgrading kde and xfree w/RH rpms