SMC EtherEZ 10/100 Ethernet Card

SMC EtherEZ 10/100 Ethernet Card

Post by Scott Dav » Thu, 16 Jul 1998 04:00:00



Has anyone had success with using SMC's EtherEZ 10/100 Card (PCI) with
linux?

I read one post that suggested that the tulip.c driver would possibly
work, but it doesn't.

Looking at the card it seems to be based on a chip by SMC called
"EN5030".

Any comments/suggestions welcome.

Scott
-----------------------------------------
Scott Davey

 
 
 

SMC EtherEZ 10/100 Ethernet Card

Post by photur » Thu, 16 Jul 1998 04:00:00




Quote:>Has anyone had success with using SMC's EtherEZ 10/100 Card (PCI) with
>linux?

>I read one post that suggested that the tulip.c driver would possibly
>work, but it doesn't.

Hello Scott...

I am using the SMC EtherEZ 10/100 PCI card with a 2.0.34 kernel
(used 2.0.33 too) with no problem. I selected the tulip driver
in the kernel config.

--
photuris

 
 
 

SMC EtherEZ 10/100 Ethernet Card

Post by Mark Baint » Thu, 16 Jul 1998 04:00:00


I am using it with the ne2k-pci driver myself, and it works great.  

>Has anyone had success with using SMC's EtherEZ 10/100 Card (PCI) with
>linux?

>I read one post that suggested that the tulip.c driver would possibly
>work, but it doesn't.

>Looking at the card it seems to be based on a chip by SMC called
>"EN5030".

>Any comments/suggestions welcome.

>Scott
>-----------------------------------------
>Scott Davey


 
 
 

1. PCMCIA Ethernet Card Driver Problem - SMC EZ Card 10/100 PC Card

I just bought an "SMC EZ Card 10/100 Mbps PC Card", which from looking at
some lists of supported cards, looks like it is supported by tulip_cb.  
However, apparenly tulip_cb has been integrated into tulip for the 2.4
kernel using the hotplug interface.  

The card is detected.

"cardctl ident" reveals:

Socket 0:
  no product info available
Socket 1:
  product info: "SMC", "8041TX-10/100-PC-Card", "", ""
  manfid: 0x01bf, 0x8041
  function: 6 (network)

After adding the manfid info to /etc/pcmcia/config, it recognizes the card
by name, but fails with one high and one low beep.  /var/log/messages shows:

Jan 18 23:54:53 localhost cardmgr[1067]: initializing socket 1
Jan 18 23:54:53 localhost cardmgr[1067]: socket 1: SMC 8041TX-10/100-PC-Card
Jan 18 23:54:53 localhost cardmgr[1067]: executing: 'modprobe cb_enabler'
Jan 18 23:54:53 localhost cardmgr[1067]: executing: 'modprobe tulip'
Jan 18 23:54:54 localhost kernel: Linux Tulip driver version 0.9.15-pre6
(July 2, 2001)
Jan 18 23:54:54 localhost cardmgr[1067]: +
/lib/modules/2.4.9-13/kernel/drivers/net/tulip/original/tulip.o:
init_module: No such device
Jan 18 23:54:54 localhost cardmgr[1067]: +
/lib/modules/2.4.9-13/kernel/drivers/net/tulip/original/tulip.o: insmod
/lib/modules/2.4.9-13/kernel/drivers/net/tulip/original/tulip.o failed
Jan 18 23:54:54 localhost cardmgr[1067]: + Hint: insmod errors can be
caused by incorrect module parameters, including invalid IO or IRQ
parameters

I'm running a RedHat 7.1 system  Does this mean that the tulip driver is
not compatible with my new card?  If so, can anyone recommend a very
well-supported and compatible pcmcia ethernet card?

Thanks,
bg

2. Sound from Orchid Faherenhit VA/VLB video

3. AIX v4.2 10/100 Ethernet Driver or 10 Ethernet card

4. PCI & SCSI Error

5. SMC EZ 10/100 Ethernet card

6. automount docs

7. SMC 10/100 PCI Ethernet Card Help

8. How find a specefic word into files ?....

9. Help with my SMC etherpower 10/100 (9332) ethernet card

10. Should we NOT buy the SMC EtherPower 10/100 fast ethernet card?

11. Xircom RE-100 10/100 Ethernet Card on TP600E

12. How do I force a 10/100 ethernet card to drop to 10 mbs?

13. 10/100 card won't talk to 10/100 hub