SAMBA-WIN95 problem: "The folder '\\SERVER\service\servicedir' does not exist.

SAMBA-WIN95 problem: "The folder '\\SERVER\service\servicedir' does not exist.

Post by Marco Roberto Land » Sat, 23 Nov 1996 04:00:00



Hi everybody.

I ugraded my SAMBA from 1.9.16p4 to 1.9.16p9 and now I have a little
problem:
the Win95 clients don't descend in the service dir and give me the
error:
        The folder '\\SERVER\service\servicedir' does not exist
After, when I click on the OK button of the error dialog box, the same
dialog box re-appears,
and I must click once again.

I use samba 1.9.16p4 with Linux (kern. 1.2.23). I have the following SMB
conf for the services those cause the error:

[belva-root]
comment = Belva'r root dir
valid users = root otherslogin
path = /
browsable = yes
writable = yes
printable = no
create mode = 766
public = no

[homes]
comment = Home Directories
browsable = yes
read only = no
writable = yes
create mode = 0750
hide dot files = no

[UsrDir]
comment = Users' home dir.
path = /hdb1/home/users/
public = yes
create mode = 0755
writable = no

printable = no

Note: I have the users' home dir in: /hdb2/home/users. When I try a
samba-connection as the user 'mr_hyde', Win95 shows me
a shared service called 'mr_hyde' (built on the fly by the homes
section, I suppose).
When I click on it, Win95 shows the home dir of mr_hyde, but if I try to
click on a sub dir, I get the message
        The folder '\\BELVA\mr_hyde\subdirname' does not exist.

(BELVA is my linux-samba server)
The question is: which is my mistake?

Please, write your answer(s) also to my e-mail address:

Bye,
         thanks in advance,
                                 Marco.