help with rp-pppoe

help with rp-pppoe

Post by Francisc » Thu, 31 Jan 2002 12:53:52



Hi, I've been using this program for a while to connect  to my ADSL
provider. Now I wanted to upgrade my kernel but I can't find the correct
options to make rp-pppoe to work, in the page
(http://www.roaringpenguin.com/pppoe/) says I need to compile the kernel
with support for "packet sockets" and anything else. I've done this, and I
also installed ppp and some other things, but I cant make it to work.
Any Ideas?
Thank you.

Francisco

 
 
 

help with rp-pppoe

Post by Francisc » Thu, 31 Jan 2002 14:13:49


I forgot to say, the network card's are working fine with the new kernel.

Francisco



Quote:> Hi, I've been using this program for a while to connect  to my ADSL
> provider. Now I wanted to upgrade my kernel but I can't find the correct
> options to make rp-pppoe to work, in the page
> (http://www.roaringpenguin.com/pppoe/) says I need to compile the kernel
> with support for "packet sockets" and anything else. I've done this, and I
> also installed ppp and some other things, but I cant make it to work.
> Any Ideas?
> Thank you.

> Francisco


 
 
 

help with rp-pppoe

Post by David Efflan » Fri, 01 Feb 2002 10:44:28



> Hi, I've been using this program for a while to connect  to my ADSL
> provider. Now I wanted to upgrade my kernel but I can't find the correct
> options to make rp-pppoe to work, in the page
> (http://www.roaringpenguin.com/pppoe/) says I need to compile the kernel
> with support for "packet sockets" and anything else. I've done this, and I
> also installed ppp and some other things, but I cant make it to work.
> Any Ideas?

Did you include support for ppp over ethernet (ie, pppoe) and whatever
else you need for iptables or ipchains (as modules)?  I usually helps to
refer to the .config file from your old kernel.

There some other config options explained in the rp-pppoe docs that can
speed your connection, but they are in several different sections of the
config, so they might not be easy to find.

--
David Efflandt - All spam is ignored - http://www.de-srv.com/
http://www.autox.chicago.il.us/  http://www.berniesfloral.net/
http://cgi-help.virtualave.net/  http://hammer.prohosting.com/~cgi-wiz/

 
 
 

help with rp-pppoe

Post by Francisc » Fri, 01 Feb 2002 13:35:00


yes, I had to include support for ppp over async lines. Now it works.
Thank you

Francisco





> > Hi, I've been using this program for a while to connect  to my ADSL
> > provider. Now I wanted to upgrade my kernel but I can't find the correct
> > options to make rp-pppoe to work, in the page
> > (http://www.roaringpenguin.com/pppoe/) says I need to compile the kernel
> > with support for "packet sockets" and anything else. I've done this, and
I
> > also installed ppp and some other things, but I cant make it to work.
> > Any Ideas?

> Did you include support for ppp over ethernet (ie, pppoe) and whatever
> else you need for iptables or ipchains (as modules)?  I usually helps to
> refer to the .config file from your old kernel.

> There some other config options explained in the rp-pppoe docs that can
> speed your connection, but they are in several different sections of the
> config, so they might not be easy to find.

> --
> David Efflandt - All spam is ignored - http://www.de-srv.com/
> http://www.autox.chicago.il.us/  http://www.berniesfloral.net/
> http://cgi-help.virtualave.net/  http://hammer.prohosting.com/~cgi-wiz/

 
 
 

1. RH8.0 bundled rp-pppoe (rp-pppoe-3.4-7) problem, please help.

Hello,

I have a problem in RH8.0 bundled rp-pppoe (rp-pppoe-3.4-7), please
help.

I am setting up linux server as NAT, which share t he internet
connection to the client PCs at home. I was using RH7.2 before and
there is no problem at all. My problem in RH8.0 is that: I setup
rp-pppoe (ifup ppp0) to run at startup of the machine. Basically, it
starts up without any problem at all. But, it never runs
/etc/ppp/ip-up. Which means that the ip masquerading process didn't
bring up at all. What I have to is to ssh to the server everytime
after the server boots up and run /etc/ppp/ip-up manually, before my
clients can use the internet connect. I realized that the
configurations files are quite different from the one that I was using
in 7.2, e.g it doesn't use /etc/ppp/pppoe.conf anymore, instated it
put all the information in
/etc/ppp/sysconfig/network-scripts/ifcfg-ppp0.

Anybody can give me some suggestions ?
Thanks
Bosco

2. lsn crashlog, trimmitud

3. rp-pppoe 3.1 -- Robust PPPoE suite for Linux

4. password syncronization

5. rp-pppoe 3.3 -- Robust PPPoE client for Linux, NetBSD, and Solaris

6. Peculiar download problem :-(

7. SuSE 7.3 kernel pppoe vs. rp-pppoe

8. VM / 2.6 inode corruption

9. rp-pppoe 3.2 -- Robust PPPoE suite for Linux

10. Need explanation of LCP_INTERVAL and computing PPPOE_TIMEOUT w/ RP-PPPoE

11. Getting pmfirewall,rp-pppoe and squid to work together

12. rp-pppoe

13. rp-pppoe and Corel SE