I/O error with new kernel and new pppd

I/O error with new kernel and new pppd

Post by Mark van Hoe » Tue, 25 Jun 1996 04:00:00



I tried to upgrade the kernel (plus lots of other stuff in
/usr/src/linux/Documentation/Changes), but I'm having difficulties with
the new pppd. I get the following message in the syslog file:

Jun 24 11:33:49 thuis pppd[98]: ioctl(TIOCEXCL): I/O error
Jun 24 11:33:49 thuis pppd[98]: ioctl(TIOCGETD): I/O error

That's weird because kermit does work with /dev/cua1, so how come pppd
gets an I/O error? In the debug file I find only messages like:

Jun 24 11:49:05 thuis pppd[101]: sent [LCP ConfReq id=0x1 <mru 1500> <pcomp> <ac
comp>]

and the messages file doesn't bring much help either:

Jun 24 11:33:49 thuis pppd[98]: pppd 2.2.0 started by root, uid 0
Jun 24 11:33:49 thuis pppd[98]: Hangup (SIGHUP)
Jun 24 11:33:49 thuis pppd[98]: Exit.

Has the syntax been changed of pppd? I've upgraded getty but that didn't
make any difference.

Mark van Hoeij

 
 
 

I/O error with new kernel and new pppd

Post by Al Longye » Mon, 01 Jul 1996 04:00:00



Quote:>I tried to upgrade the kernel (plus lots of other stuff in
>/usr/src/linux/Documentation/Changes), but I'm having difficulties with
>the new pppd. I get the following message in the syslog file:
>Jun 24 11:33:49 thuis pppd[98]: ioctl(TIOCEXCL): I/O error
>Jun 24 11:33:49 thuis pppd[98]: ioctl(TIOCGETD): I/O error
>That's weird because kermit does work with /dev/cua1, so how come pppd
>gets an I/O error? In the debug file I find only messages like:
>Jun 24 11:49:05 thuis pppd[101]: sent [LCP ConfReq id=0x1 <mru 1500> <pcomp> <ac
>comp>]
>and the messages file doesn't bring much help either:
>Jun 24 11:33:49 thuis pppd[98]: pppd 2.2.0 started by root, uid 0
>Jun 24 11:33:49 thuis pppd[98]: Hangup (SIGHUP)
>Jun 24 11:33:49 thuis pppd[98]: Exit.
>Has the syntax been changed of pppd? I've upgraded getty but that didn't
>make any difference.

You forgot to do:

chown root /usr/sbin/pppd
chmod 4555 /usr/sbin/pppd

The pppd process must have the effective uid of 'root' or you will get those
error messages.

--


 
 
 

1. SLIP/PPP -->new kernel-->new compiler-->new make

Hello world!

I'm trying to install SLIP or PPP (made no choice yet, any tips?)
Therefore I needed a new kernel and tried to install 1.1.45.
To compile this I needed a new gcc version. I downloaded gcc 2.5.8, libc
4.5.26, binutils 1.9l.4 and tools 2.16.
I un-tar-ed them all and started to compile.
I now need gnu make 3.70 (in stead of 3.69) where can I find this?
I also have problems with libc.so.4, witch is linked to libc.so.4.4.4
It sais: desire minor version 514 and found 404
How do I solve this?
final question: Why isn't there a HOW-TO about these things?

I hope anyone can help me with this.

Greetings and thanx in advance,

Perjan Moors.

2. Ford kicks out Microsoft!

3. PPPd error on new kernel???

4. Managing changes on multiple servers

5. Help to boot new kernel with grub -delited the old kernel before tried the new one

6. HELP: X11 and MEMORY

7. Module dependency errors after new kernel and stty error

8. Result of porting 'f2c' and 'ispell3.00.07'

9. new kernel: LILO "kernel too big" error

10. New way to do QOS and limit bandwidth with Linux, new site , new software Howto Included

11. New Kernel error: Kernel panic

12. NEW NEW NEW

13. NEW NEW NEW!