2 ISP IP Masq works only with 1

2 ISP IP Masq works only with 1

Post by jay » Sat, 22 May 1999 04:00:00



IP Masq with ISP wt.net quit working correctly several months ago. The
winboxes can ftp and read news but Netscape/IE3 fails.  Netscape works on
the linux masq box. I gave up after trying to fix it after trying reinstall
Rh5.1, different configurations, etc.

Now: I tried a student ISP account at uh.edu.  IP Masq works as it should.
Without rebooting either box wt.net still does not work correctly.  Dialing
and connecting with first one then the other gives the same results: with
ISP wt.net ip masq fails to work correctly and with ISP uh.edu ip masq
works correctly.

The uh.edu account is "free" but often busy so it is not an alterative.

Any ideas?

Is something wrong with my configurations or do I need a new ISP?

 
 
 

2 ISP IP Masq works only with 1

Post by Joachim Zob » Tue, 25 May 1999 04:00:00



>IP Masq with ISP wt.net quit working correctly several months ago. The
>winboxes can ftp and read news but Netscape/IE3 fails.  Netscape works on
>the linux masq box. I gave up after trying to fix it after trying reinstall
>Rh5.1, different configurations, etc

Looks like your provider is blocking port 80 to force use of a proxy.

Just a remark: Reinstalling does not work on linux boxes. You find the
source of a problem reding log or (rare) reading source code.

Quote:

>Now: I tried a student ISP account at uh.edu.  IP Masq works as it should.
>Without rebooting either box wt.net still does not work correctly.  Dialing
>and connecting with first one then the other gives the same results: with
>ISP wt.net ip masq fails to work correctly and with ISP uh.edu ip masq
>works correctly.

Looks like your box remembers the dynIP it gets. If you connect to the
same provider twice and get a different IP, does the problem occur?

When is your masquerading set up? Is it an init script or does ip-up
script do it. Does the problem occur if you call ipfwadm to flush all
settings bettween to dialups?

Quote:>Is something wrong with my configurations or do I need a new ISP?

Didn't see any of your configurations.

Hth,
Joachim

 --
"I read the news today oh boy"             - The Beatles - A Day In The Life

Althoug this message has a valid From header, replies

are preferred.

 
 
 

1. IP Masq'd Workstation to connect to IP Masq'd Workstation

I have setup my Linux Box with IPMasq. Everything runs fine from my win box
behind the proxy. Now I just encountered a problem. I have tried to connect
to an ftp server that is behind NAT server which are both on winboxs

------------              -------------                   ------------      
        ------------------
|                 |             | IP Masq    |   Internet    |   NAT       |
| Win workstation |
| Win         |---------|    Linux      |------------|    Sygate
|---------|    FTP                |
|                 |             |   Proxy      |   Internet    |    Win box
|              | server                |
------------              -------------                   -------------    
        ------------------

I can't seem to connect to the FTP even when the FTP Client is set to
passive mode. Does anyone know whether there is anything I can do on my side
of the connection such as reconfiguring my Linux Box to fwd properly?

2. Linux Frequently Asked Questions 1/4 [monthly posted]

3. IP Masq - Specify IP to Masq as?

4. HELP! Cannot ping between sub-nets ...

5. IP Masq (works) and ICQ (!@#$% doesn't work)

6. Build Your Own Network Intrusion Kit!

7. Slow IP Masq, but only with one ISP

8. A little advocacy help, please? Outlook 2000 vs Classic Linux

9. Configuring net (IP-tunnel, IP-Alias, Proxy-ARP, NAT, IP-Masq?)

10. SSL not working through IP Masq

11. IP Masq works for a while then stops.

12. IP Masq Linux to Win95 Almost Working

13. IP Masq. not working under 2.1.x