Lan browsing with Konqueror

Lan browsing with Konqueror

Post by Christopher Boot » Sat, 12 Jan 2002 15:12:05



Hi guys

I've got a question, using samba 2.2.1 on Mandrake 8.1, Konqueror using lisa and reslisa daemons.

I've been trying to setup the lan browsing through Konqueror, talk about undocumented features.
I've finally worked most of it out.
Clicking on Network brings an error - cannot connect to localhost as it trys to connect to lan://localhost
change it to read lan:/hostname and it works depending on lisa configuration shows FTP, SMB, HTTP and NFS shares/connections
clicking on SMB changes the address in the address bar to read smb://hostname
and shows shares

FTP does likewise and asks for authentication and allows you to broswe the ftp site a la explorer/konqueror file manager style.

typing in the address bar rlan:/ scans the local subnet for machines, but doesn't name resolve them all or list them all for that manner

(gnomba when scanning via ip finds heaps more and name resolves them)
Very strange state of affairs.

Has anyone got this set up successfully

Christopher Booth

 
 
 

Lan browsing with Konqueror

Post by Dean Thompso » Sun, 13 Jan 2002 17:25:18


Hi!,

Quote:> I've got a question, using samba 2.2.1 on Mandrake 8.1, Konqueror using
> lisa and reslisa daemons.

> I've been trying to setup the lan browsing through Konqueror, talk about
> undocumented features. I've finally worked most of it out.
> Clicking on Network brings an error - cannot connect to localhost as it
> trys to connect to lan://localhost change it to read lan:/hostname and it
> works depending on lisa configuration shows FTP, SMB, HTTP and NFS
> shares/connections
> clicking on SMB changes the address in the address bar to read
> smb://hostname and shows shares

> FTP does likewise and asks for authentication and allows you to broswe the
> ftp site a la explorer/konqueror file manager style.

> typing in the address bar rlan:/ scans the local subnet for machines, but
> doesn't name resolve them all or list them all for that manner

> (gnomba when scanning via ip finds heaps more and name resolves them)
> Very strange state of affairs.

> Has anyone got this set up successfully

Have you checked in with the konqueror site?, I am sure that I have seen some
of these problems mentioned in their FAQ.  I know that the "local host"
problem has been around for awhile and I think is fixed with an upgrade of the
program.

See ya

Dean Thompson

--
+____________________________+____________________________________________+

| Bach. Computing (Hons)     | ICQ     - 45191180                         |
| PhD Student                | Office  - <Off-Campus>                     |
| School Comp.Sci & Soft.Eng | Phone   - +61 3 9903 2787 (Gen. Office)    |
| MONASH (Caulfield Campus)  | Fax     - +61 3 9903 1077                  |
| Melbourne, Australia       |                                            |
+----------------------------+--------------------------------------------+

 
 
 

1. lan browsing with Konqueror

Follow up

.................

KDE control panel has (on Mandrake) 2 configuration things for this,
Under Configuration,KDE,network, there is Windows Shares and Lan Browsing
These update files
/$HOME/.kde/share/config/kio_lanrc
/$HOME/.kde/share/config/lisarc
/$HOME/.kde/share/config/rlisarc

While looking for these lisarc and rlisarc files, I came across -
/$HOME/.kde/share/apps/konqueror/dirtree/lan.desktop

it has a line which says URL=lan:/
which is the problem I changed that to URL=lan://localhost/localhost and it works by displaying the active network shares for my computer as defined in the KDE control center

I then changed it to read rlan:/

This then should display the machines on the network

On Fri, 11 Jan 2002 17:01:26 +1100

2. RedHat & TigerDirect overreach.

3. problem to browse the LAN with konqueror :-((

4. how can i use the com port?

5. Konqueror lan browsing

6. Dialin PPP Problem

7. Tabbed browsing in Konqueror

8. gnucash on redhat 8

9. Slow Konqueror file browsing after update HELP

10. konqueror hangs browsing samba shares

11. Can't browse html with Konqueror in rc2

12. Konqueror browsing go slow

13. Can't get Konqueror to browse my network