Compiling INN v1.6.x/1.7.x ???

Compiling INN v1.6.x/1.7.x ???

Post by System Administrato » Tue, 30 Dec 1997 04:00:00



Has anyone compiled inn 1.6.x/1.7.x on linux?

I downloaded 1.7 and cant get it to compile. First problem is it can't
find lint..i looked for it on the net and only found tlint..it didn't like
the command line syntax for it.
Second problem i get a undefined reference error in the closeonexec.c file

I'm currently Caldera OpenLinux on a 2.0.33 kernel using INN v.1.5.1sec2
25-Jul-97 but it crashes on me after being up for a day and a 1/2 or so.
The logs show no reason why. That's why i wanted 1.7

If you can help, email and/or post. Thanx,

-Cygnus
---------------------------------------------------------------------------
Anthony J. Biacco                           Network Administrator/Engineer
.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-.
         "The only way to predict the future, is to invent it."
.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-._.-.

                  http://www.intermarket.net/~cygnus/
---------------------------------------------------------------------------

 
 
 

Compiling INN v1.6.x/1.7.x ???

Post by Paul Blac » Tue, 30 Dec 1997 04:00:00



> Has anyone compiled inn 1.6.x/1.7.x on linux?

> I downloaded 1.7 and cant get it to compile. First problem is it can't
> find lint..i looked for it on the net and only found tlint..it didn't like
> the command line syntax for it.
> Second problem i get a undefined reference error in the closeonexec.c file

> I'm currently Caldera OpenLinux on a 2.0.33 kernel using INN v.1.5.1sec2
> 25-Jul-97 but it crashes on me after being up for a day and a 1/2 or so.
> The logs show no reason why. That's why i wanted 1.7

> If you can help, email and/or post. Thanx,

This is a diff of my config.data with the original in INN 1.7.2:

49c49
< LIBS                  #-lutil
---
Quote:> LIBS                  -lutil

211c211
< HAVE_SETPROCTITLE     DONT
---
Quote:> HAVE_SETPROCTITLE     DO

220c220
< HAVE_TM_GMTOFF                DONT
---
Quote:> HAVE_TM_GMTOFF                DO

247c247
< CLX_STYLE             FCNTL
---
Quote:> CLX_STYLE             IOCTL

364c364
< CHECK_INCLUDED_TEXT   DONT
---
Quote:> CHECK_INCLUDED_TEXT   DO

562c562
< _PATH_PERL            /usr/bin/perl
---
Quote:> _PATH_PERL            /usr/bin/perl5

568c568
< _PATH_SED             /bin/sed
---
Quote:> _PATH_SED             /usr/bin/sed

571c571
< _PATH_SORT            /bin/sort
---
Quote:> _PATH_SORT            /usr/bin/sort


Paul

 
 
 

1. inn 1.7 -util error on Solaris 2.5



Um, did you try the obvious?  (removing -lutil from config.data?)
You _did_ use the example config.data for Solaris, didn't you?

While you're at it, upgrade to 1.7.2.  It's the latest.

Followups redirected.

--Dave
--
http://www.cis.ohio-state.edu/~barr/

2. Newbie trying Linux Lite

3. INN 1.7 dying w/ BAD TRAP

4. Ximian Evolution on Sparc Solaris

5. INN 1.7 on solaris 2.5.1

6. TCP/IP on SVR4

7. Anyone get INN v1.5 compiled for Linux yet?

8. RWBoolean : unexpected result

9. osh 1.7 cannot compile it 2.5.1

10. Compile freetype-2.1.7 in Solaris 9

11. SATAN v1.1.1 [released] and v1.1.4 [experimental] both do not compile on Redhat 6.0.

12. kernel v1.1.70

13. Announce: lib3d-0.1.7 - Fast, Free, Cross-platform 3d