vsftpd with ssl - vsftpd.user_list not working

vsftpd with ssl - vsftpd.user_list not working

Post by shape » Thu, 02 Feb 2006 05:04:09



hi there...

i've successfully set up a vsftpd server with ssl running on debian
sarge. but the userlist_enable=YES does not realy work! user "sysadmin"
is able to log in but he isn't listed in /etc/vsftpd.user_list!

here's my server config:

# FTP SETTINGS
write_enable=YES
download_enable=YES
ascii_download_enable=YES
ascii_upload_enable=YES
dirlist_enable=YES
dirmessage_enable=NO
hide_ids=YES
pasv_enable=YES

# LOGGING
log_ftp_protocol=YES
xferlog_enable=YES

# SSHL SETTINGS
ssl_enable=YES
ssl_tlsv1=YES
ssl_sslv2=YES
ssl_sslv3=YES
rsa_cert_file=/etc/ssl/certs/vsftpd.pem
force_local_logins_ssl=YES
force_local_data_ssl=YES

# LISTEN SETTINGS
listen=YES
listen_address=80.*.*.*
listen_port=21
listen_ipv6=NO
max_clients=5
max_per_ip=3
connect_from_port_20=YES

# USER MANAGEMENT
secure_chroot_dir=/var/run/vsftpd
userlist_deny=NO
userlist_enable=YES
userlist_file=/etc/vsftpd.user_list
user_config_dir=/etc/vsftpd_user_conf
chroot_list_file=/etc/vsftpd.chroot_list
chroot_list_enable=YES
chroot_local_user=YES
anon_world_readable_only=NO
anonymous_enable=NO
local_enable=YES
pam_service_name=vsftpd
nopriv_user=ftpsecure

any ideas?

thanks,
christof

 
 
 

1. Redhat 9: tcpd and vsftpd not working together?

I'm trying to enable tcp wrapper support for sshd and vsftpd, so that I
can use banners.  I'm having trouble getting it working with vsftpd,
and I haven't even started playing with sshd yet.

I've edited /etc/vsftpd/vsftpd.conf so that it has the line:
tcp_wrappers=YES
at the bottom of the file.  I've also created a file containing the
text I want to send as /etc/banners/vsftpd.  Finally, I added the
following line to /etc/hosts.allow:
vsftpd:ALL:banners /etc/banners/

I restarted vsftpd to be sure that it picked up the configuration
change.  And nothing new happened.  Then I restarted the whole machine,
just for the heck of it (it's not in production yet).  And again, no
connection banner for ftp service.  I don't see anything in the logs
for tcpd, but I did find the following in /var/log/messages that seemed
odd:

Apr 14 20:57:47 darwin vsftpd: warning: can't get client address: Bad
file descriptor

I'm pretty sure my DNS is working properly (it has been for well over a
year), so I'm not sure what the deal is.  Anyone have any suggestions?

--
Donald Roeber
ISC Networking

2. Don't like linux mouse control

3. vsftpd not working

4. Gcov-kernel patch updates for 2.4.20 and 2.5.70

5. compilation errors comiling vsftpd with ssl

6. __doprint & mcount

7. vsftpd on solaris - wont work with inetd

8. ufs filesystem performance

9. SSH port forwarding can't work with vsftpd

10. About the vsftpd virtual host config

11. VSFTPD problem? or Apache?

12. problem with vsftpd on a non-standard port

13. VSFTPD - 530 - incorrect login error