Probleme avec ping et ARP

Probleme avec ping et ARP

Post by Armando Neve » Tue, 19 Feb 2002 18:36:13



Je suis en train de mettre en place la plate forme de tests suivante :

!----------------!
! Windows 98    ! IP : 192.168.10.1
!                        ! Passerelle : 192.168.10.2
!----------------!
          !
!----------------!    Eth0 : 192.168.10.2
!      Linux          !   Eth1 : 196.196.196.2
! Mandrake 8.1 !
!----------------!  /sbin/route add defaukt gw 196.196.196.2
             !
!----------------!
!      HUB          !
!----------------!
         !
!----------------!  Eth1 : 193.252.19.3
!       Linux         !
! Mandrake 8.1 ! /sbin/route add default gw 193.252.19.3
!----------------! Eth0 : 195.195.195.2
         !
!----------------! IP : 195.195.195.1
!  NT 4.0          !
!----------------! Passerelle : 195.195.195.2

J'utilise l'IP forwarding, la translation d'adresses, et un firewall d'enfer
sur les machine linux par le script :

  echo 1 > /proc/sys/net/ipv4/ip_forward
  iptables -P FORWARD ACCEPT
  iptables -P INPUT ACCEPT
  iptables -P OUTPUT ACCEPT
  iptables -F INPUT
  iptables -F OUTPUT
  iptables -F FORWARD
  iptables -t nat -A POSTROUTING -o eth1 -j MASQUERADE.

 Question :
    je n'arrive pas a "PINGER" les machines windows entre elles. pouquoi ?
    Avec tcpdump je vois bien arriver les requettes icmp sur les interfaces
eth0 des linux mais elles ressortent sous forme
   de requette ARP sur l'interface eth1 et restent sans reponse.
   les machines windows arrivent cependant a "PINGER" les interfaces des
machines linux apres les avoir resolu par ARP

Quelqu'un peut il me renseigner ?

Par avance Merci.

 
 
 

Probleme avec ping et ARP

Post by Carles Arjon » Wed, 20 Feb 2002 05:32:58



> !----------------!    Eth0 : 192.168.10.2
> !      Linux          !   Eth1 : 196.196.196.2
> ! Mandrake 8.1 !
> !----------------!  /sbin/route add defaukt gw 196.196.196.2
>              !
> !----------------!
> !      HUB          !
> !----------------!
>          !
> !----------------!  Eth1 : 193.252.19.3
> !       Linux         !
> ! Mandrake 8.1 ! /sbin/route add default gw 193.252.19.3
> !----------------! Eth0 : 195.195.195.2

<snip>

>  Question :
>     je n'arrive pas a "PINGER" les machines windows entre elles. pouquoi ?

Because you probably can not either reach the first Linux box from the
second one (and vice versa) with ping, since both boxes belong to
different IP networks.

You might have a look to the Net-HOWTO:
http://www.linuxdoc.org/HOWTO/Net-HOWTO/index.html

--
Regards,



 
 
 

1. Probleme avec XFree

Bonjour,

        J'ai un petit probleme avec XFree 3.2.

Voici ce qui se passe:
J'utilise XF86Setup
   -Il faut que je choisisse la sourie Microsoft sinon ca ne marche pas
     (j,ai une sourie logitech)
   -Ma carte video est une Trident tgui9440
        - je ne connais que le nb de memoire et l'opyion de droite (tgui)
        - le reste, je met "probe"
   -Mon ecran est bien configure (c'est un mag dx15f)

Tout marche bien...
Je gosse un peu dans XWindow puis l'image devient de plus en plus noir.
Au bout de 2 a 3 seconde, il n'y a plus rien.   Il faut que je sorte
avec <ctrl><alt><backspace>.
Si j'essaie de retourner, c'est tout noir.

C'est quoi le probleme?
Quels devraient etre les options pour ma carte video?

S.v.p. pas trop technique, je commence avec linux.

        Nicolas
--

2. Help with iptable and port forwarding - Please

3. Probleme avec crack 5.0 + RH 5.0

4. Web-Based Time Tracking Software

5. probleme Xwindows avec MiniLinux FR (1.1.2)

6. NEWBIE-Can't start Xwindows

7. Probleme avec Crack 5

8. Clock slowdown on AIX 4.1.5

9. probleme avec Fdisk

10. Probleme avec mgetty+olitec

11. Pb Mount manuel avec mdk 7.1 et 7.2

12. Accès Internet par modem et wvdial avec suse 7.0

13. Question à propos d'un probleme de compatibilité entre windows et linux