ip sourcerouting dont work

ip sourcerouting dont work

Post by Volker Wid » Mon, 01 May 2000 04:00:00



hy,

i have a problem telling my server to route by source.
the following configuration runns on my server:

Quote:>ip ru ls

0:      from all lookup local
1000:   from all to 192.168.0.0/16 lookup main
1400:   from 192.168.1.200 lookup src192.168.1.200 map-to 195.126.254.244
2000:   from 192.168.0.0/16 lookup main map-to 195.126.254.240
32766:  from all lookup main
32767:  from all lookup default

Quote:>ip ro ls

194.25.34.201 dev ippp0  proto kernel  scope link  src 195.126.254.246
194.25.34.201 dev ippp1  proto kernel  scope link  src 195.126.254.247
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.1
default dev ippp0  scope link

Quote:>ip ro ls table 1

default dev ippp1  scope link

if i try to connect to the net from some clients, the autodial is triggered.

Quote:>monitor

(now i make a ping from 192.168.1.32 to the inet; this works fine!)
local 195.126.254.246 dev ippp0  table local  proto kernel  scope host
  src 195.126.254.246
local 195.126.254.246 dev ippp0  table local  proto kernel  scope host
  src 195.126.254.246
194.25.34.201 dev ippp0  proto kernel  scope link  src 195.126.254.246
default dev ippp0  scope link

(now the same ping from 192.168.1.200; this triggers the line, but no package
 is delivered!)
local 195.126.254.247 dev ippp1  table local  proto kernel  scope host
  src 195.126.254.247
local 195.126.254.247 dev ippp1  table local  proto kernel  scope host
  src 195.126.254.247
194.25.34.201 dev ippp1  proto kernel  scope link  src 195.126.254.247
default dev ippp1  table src192.168.1.200  scope link

is there someone hy did sourcerouting? i dont know how to fix the problem.
maby there is a problem whith nat?
i cant see the differences between the two devices. so i dont anderstand,
why it will not work.

  volker

--
Volker Widor  -  Harmsstr. 125  -  D-24114 Kiel
Fon.: +49 431 583572  Mobil: +49 179 3901852

 
 
 

ip sourcerouting dont work

Post by Volker Wid » Tue, 02 May 2000 04:00:00


hy,

i have a problem telling my server to route by source.
the following configuration runns on my server:

Quote:>ip ru ls

0:      from all lookup local
1000:   from all to 192.168.0.0/16 lookup main
1400:   from 192.168.1.200 lookup src192.168.1.200 map-to 195.126.254.246
2000:   from 192.168.0.0/16 lookup main map-to 195.126.254.247
32766:  from all lookup main
32767:  from all lookup default

Quote:>ip ro ls

194.25.34.201 dev ippp0  proto kernel  scope link  src 195.126.254.246
194.25.34.201 dev ippp1  proto kernel  scope link  src 195.126.254.247
192.168.1.0/24 dev eth0  proto kernel  scope link  src 192.168.1.1
default dev ippp0  scope link

Quote:>ip ro ls table 1

default dev ippp1  scope link

if i try to connect to the net from some clients, the autodial is triggered.

Quote:>monitor

(now i make a ping from 192.168.1.32 to the inet; this works fine!)
local 195.126.254.246 dev ippp0  table local  proto kernel  scope host
  src 195.126.254.246
local 195.126.254.246 dev ippp0  table local  proto kernel  scope host
  src 195.126.254.246
194.25.34.201 dev ippp0  proto kernel  scope link  src 195.126.254.246
default dev ippp0  scope link

(now the same ping from 192.168.1.200; this triggers the line, but no package
 is delivered!)
local 195.126.254.247 dev ippp1  table local  proto kernel  scope host
  src 195.126.254.247
local 195.126.254.247 dev ippp1  table local  proto kernel  scope host
  src 195.126.254.247
194.25.34.201 dev ippp1  proto kernel  scope link  src 195.126.254.247
default dev ippp1  table src192.168.1.200  scope link

is there someone hy did sourcerouting? i dont know how to fix the problem.
maby there is a problem whith nat?
i cant see the differences between the two devices. so i dont anderstand,
why it will not work.

  volker

--
Volker Widor  -  Harmsstr. 125  -  D-24114 Kiel
Fon.: +49 431 583572  Mobil: +49 179 3901852