pppd.2.4.1 fails where pppd.2.3.11 worked. Why? (fwd)

pppd.2.4.1 fails where pppd.2.3.11 worked. Why? (fwd)

Post by G. Georgie » Tue, 24 Jul 2001 06:00:32



        HEllo,

        I used pppd.2.3.11 MPPE patched for a pptp link over my cable
line and it worked well for about an year. Now I have to move to
pppd.2.4.1 and I receive LCP ProtRej messages for every packet I send
trough the line. Apparenly I send garbage to the other end, but why?

        The link establishes well, but nothing may pass over. If I
start the old pppd.2.3.11, there is no problem.

        Config:
noauth
asyncmap 0
noipdefault
user GALILEO.COM\\A0025798
debug
allow-ip 172.20.0.0/16
lock
nodetach
+mppe-40
+mppe-128
+mppe-stateless

Using interface ppp0
Connect: ppp0 <--> /dev/ttya0
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x63bdbac3> <pcomp>
<accomp>]
sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x63bdbac3> <pcomp>
<accomp>]
rcvd [LCP ConfReq id=0x99 <mru 1500> <asyncmap 0xa0000> <auth chap 81>
<magic 0x1eda11de> <pcomp> <accomp>]
sent [LCP ConfAck id=0x99 <mru 1500> <asyncmap 0xa0000> <auth chap 81>
<magic 0x1eda11de> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x63bdbac3> <pcomp>
<accomp>]
rcvd [CHAP Challenge id=0xad <5b4a3eade4174136f794ca4243ce4aec>, name =
"172.20.0.15"]
sent [CHAP Response id=0xad
<8b3da6c664cdb95de7611de9a29089ac00000000000000004a3e75bb8085a0f5060a76d3c4e020bf56d69bfff3639a47
00>, name = "GALILEO.COM\\A0025798"]
rcvd [LCP ConfReq id=0xea <mru 1500> <asyncmap 0xa0000> <auth chap m$oft>
<magic 0x348e4be6> <pcomp> <accomp>]
sent [LCP ConfReq id=0x2 <asyncmap 0x0> <magic 0xf7d4f4f0> <pcomp>
<accomp>]
sent [LCP ConfAck id=0xea <mru 1500> <asyncmap 0xa0000> <auth chap m$oft>
<magic 0x348e4be6> <pcomp> <accomp>]
rcvd [LCP ConfAck id=0x2 <asyncmap 0x0> <magic 0xf7d4f4f0> <pcomp>
<accomp>]
rcvd [CHAP Challenge id=0xad <92152a39b5abaa5b>, name = "172.20.0.15"]
sent [CHAP Response id=0xad
<000000000000000000000000000000000000000000000000dced1d122aabf4994832d6c6bb2dc1a7019959d126782748
01>, name = "GALILEO.COM\\A0025798"]
rcvd [CHAP Success id=0xad "CHAP authentication success, unit 248542020"]
Remote message: CHAP authentication success, unit 248542020
sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <compress VJ 0f 01>]
sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <mppe 1 0 0 60>
<bsd v1 15>]
rcvd [IPCP ConfReq id=0xba <addr 172.20.0.15> <compress VJ 07 00>]
sent [IPCP ConfAck id=0xba <addr 172.20.0.15> <compress VJ 07 00>]
rcvd [IPCP ConfNak id=0x1 <addr 172.20.75.215> <compress VJ 07 00>]
sent [IPCP ConfReq id=0x2 <addr 172.20.75.215> <compress VJ 07 00>]
rcvd [CCP ConfRej id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
sent [CCP ConfReq id=0x2 <mppe 1 0 0 60>]
rcvd [IPCP ConfAck id=0x2 <addr 172.20.75.215> <compress VJ 07 00>]
local  IP address 172.20.75.215
remote IP address 172.20.0.15
Script /etc/ppp/ip-up started (pid 8703)
rcvd [CCP ConfNak id=0x2 <mppe 1 0 0 20>]
sent [CCP ConfReq id=0x3 <mppe 1 0 0 20>]
Script /etc/ppp/ip-up finished (pid 8703), status = 0x0
rcvd [CCP ConfReq id=0xb9 <mppe 1 0 0 20>]
sent [CCP ConfAck id=0xb9 <mppe 1 0 0 20>]
rcvd [CCP ConfAck id=0x3 <mppe 1 0 0 20>]
MPPE 40 bit, stateless compression enabled
rcvd [LCP ProtRej id=0xeb 02 61 aa a2 fd b5 f4 70 83 dc 57 ea d9 91 4a c5
34 e2 30 99 6c db e7 7f 9b 96 e9 9a 70 87 cf 2b ...
]
Protocol-Reject for unsupported protocol 0x261
rcvd [LCP ProtRej id=0xec d6 3d 56 c9 bc b3 dd ab 62 69 9b fa 8d 52 44 f9
cb 58 00 96 b6 8c 7c 10 6b ef 33 b7 6f ad a0 63 ...
]
Protocol-Reject for unsupported protocol 0xd63d
rcvd [LCP ProtRej id=0xed 1e 51 4f 2b 99 80 aa f2 df e6 99 e0 b1 42 90 cd
0e 11 d6 ef 2c 0c 58 c9 2c 10 88 06 7c 68 bf d8 ...
]
Protocol-Reject for unsupported protocol 0x1e51
rcvd [CCP ResetReq id=0xd4]
sent [CCP ResetAck id=0xd4]

 
 
 

1. Where is latest pppd 2.3.11 please?

The origin of pppd versions is cs.anu.edu.au, in pub/software/ppp.

As to the second question, I doubt it.  Pppd is very unlikely to be
the cause of an unreliable connection, but the pppd configuration on
the other hand....

--

/* 97.3% of all statistics are made up. */

2. x11amp 0.7 screeching

3. ppp 2.3.11 not working

4. Strange ISDN Problems with 2.4

5. mod_ssl 2.3.11-1.3.6 & 2.2.8-STABLE install problems

6. PPP link

7. Installing elm 2.3.11 on RS6000

8. Gateway ensoniq 1373 sound drivers

9. 2.3.11 ppp, framing errors are killing me

10. trouble ppp 2.3.11 & Kernel 2.2.16

11. Kernel 2.3.11 - error

12. ppp 2.3.11 hanging..

13. More detail for my pppd log, PPPD seems Okay, but No ping work!