FTP and Kerberos - Kerberos V4 krb_mk_req !!

FTP and Kerberos - Kerberos V4 krb_mk_req !!

Post by karthik bala gu » Wed, 21 Jul 2004 20:37:24



Hi,
I get the following Kerberos related error
when i do FTP from another machine(redhat 9.0)
to my machine(redhat 9.0).

How to solve this problem ?
Should i Need to start/stop some daemons ?

here is what happens when i do FTP !!! --------->>>>>>>>> Here is it .....>>>>

Connected to 107.108.89.173.
220 localhost.localdomain FTP server (Version 5.60)
ready.
334 Using authentication type GSSAPI; ADAT must follow
GSSAPI accepted as authentication type
GSSAPI error major: Miscellaneous failure
GSSAPI error minor: No credentials cache found
GSSAPI error: initializing context
GSSAPI authentication failed
334 Using authentication type KERBEROS_V4; ADAT must
follow
KERBEROS_V4 accepted as authentication type
Kerberos V4 krb_mk_req failed: You have no tickets
cached
Name (107.108.89.173:karthik): bye
530 Must perform authentication before identifying
USER.
Login failed.
Remote system type is UNIX.
Using binary mode to transfer files.

---------------->>> That was the msg that i got .........>>>>>>>>>>>>>>>>>>

I don't know what is going on my ftp server if I try
to connect it shows that error.

Should Both the machines have kerberos installed , i dont think it is
mandatory .
should i need to do some configuration in initialisation files ?

Kindly anyone tell a soln,
karthik bala guru

 
 
 

FTP and Kerberos - Kerberos V4 krb_mk_req !!

Post by karthik bala gu » Fri, 06 Aug 2004 02:15:10


Hi,
I got it solved. It is mandatory if one side is kerberos authenticated then
the other side should have the support the decrypt the keys.
Then,
U can access other system if u have kerberos around you and
the others dont have it .
Then,
u can uninstall kerberos, with just wu-ftpd - a normal ftp  without
kerberos enabled.

Cheeeeers,
thanx for ur support,
karthik bala guru


Quote:> Hi,
> I get the following Kerberos related error
> when i do FTP from another machine(redhat 9.0)
> to my machine(redhat 9.0).

> How to solve this problem ?
> Should i Need to start/stop some daemons ?

> here is what happens when i do FTP !!! --------->>>>>>>>> Here is it .....>>>>

> Connected to 107.108.89.173.
> 220 localhost.localdomain FTP server (Version 5.60)
> ready.
> 334 Using authentication type GSSAPI; ADAT must follow
> GSSAPI accepted as authentication type
> GSSAPI error major: Miscellaneous failure
> GSSAPI error minor: No credentials cache found
> GSSAPI error: initializing context
> GSSAPI authentication failed
> 334 Using authentication type KERBEROS_V4; ADAT must
> follow
> KERBEROS_V4 accepted as authentication type
> Kerberos V4 krb_mk_req failed: You have no tickets
> cached
> Name (107.108.89.173:karthik): bye
> 530 Must perform authentication before identifying
> USER.
> Login failed.
> Remote system type is UNIX.
> Using binary mode to transfer files.

> ---------------->>> That was the msg that i got .........>>>>>>>>>>>>>>>>>>

> I don't know what is going on my ftp server if I try
> to connect it shows that error.

> Should Both the machines have kerberos installed , i dont think it is
> mandatory .
> should i need to do some configuration in initialisation files ?

> Kindly anyone tell a soln,
> karthik bala guru


 
 
 

1. What are kerberos and kerberos administration ?

Hi all,
When I read services on Linux machine, I find two servives, namely
Kerberos at port 88 and Kerberos Administration at port 749. But I don't
know anything about them. Please give me explanation about them, or tell
where I can get documentay about them ( as much as possible).
Thanks for any help.
Ha Le

Sent via Deja.com http://www.deja.com/
Before you buy.

2. Boot floppy with filesystem?

3. Kerberos DES Library is required for Kerberos support

4. [PATCH 2.5] Fix JFFS when procfs is not enabled

5. Kerberos v4/v5 compatibility

6. Communicator & Java: screwed?

7. Kerberos V4 and Linux. . .

8. Dam WIN 2000 RC3 rocks !!!!!!

9. kerberos v4 on solaris?

10. Fetchmail and Kerberos v4, PLEASE HELP!!

11. Help! Building kerberos V4 on Solaris2.1

12. kerberos V4 or 5 on Solaris 2.3

13. Kerberos v4 and v5. Need some advice please!