(2) 3C905B-TX cards in one linux box not detecting speed correctly

(2) 3C905B-TX cards in one linux box not detecting speed correctly

Post by Tomm » Fri, 11 Feb 2000 04:00:00



I have 2 3c905b's in the same linux machine.  The first one is connected to
my ADSL modem and operates at 10MBit.  The other is attached to my internal
network and I use IP masquerading to see the net.  However, I cannot get my
internal NIC to operate at 100MBit.  When Linux initially detects the nics,
it sees the speeds as they have been configured by 3com's diagnostic
utility.  It shows the ADSL nic as 10 and the internal as 100.  However,
when it loads the driver, it knocks the internal NIC down to 10.

Has anyone experienced this?  I am running redhat 6.1 and kernel 2.2.12.

Thanks in advance
Thomas

 
 
 

1. Linux not recognizing 3c905b-tx card

I have a 3Com 3c905b-tx card installed in my computer that works find from
Windows 98, but I cannot get Linux to recognize it.  I've reconfigured and
recompiled my kernel for the proper interface support, but it does not find
the card at boot time.  I've also tried to specify the "ether" option at the
LILO command line, but that does not help either.
I've read the Ethernet HOWTO and tried everything listed there under the
heading of "Ethercard is not detected at boot", but to no avail.

What else am I missing?????

TIA
Todd Breiholz

2. help with setup

3. 3c905B-TX problems -> Unknown adapter type 9055 detected

4. mtools problems (can't initialize A:)

5. 3COM Fast Etherlink XL 10/100Base-TX (3c905B-TX)

6. VIA Pro 133A chipset

7. 3C905B-TX and 3C980-TX -any known problems?

8. Zip/Unzip

9. 3C905B-TX : TX=0 !

10. Trying to setup firewall on linux box with two network cards, cards are not configuring correctly

11. 3com 3c905b-tx card, driver needed..

12. 3c905B-TX Card Driver Problem....

13. RX errors with 3Com 3c905b-TX PCI card on RedHat6.0