2 IDE Controllers with Linux 1.2.13 - Possible?

2 IDE Controllers with Linux 1.2.13 - Possible?

Post by Dag Adams » Tue, 06 Feb 1996 04:00:00



Hello-

Has anyone been lucky enough to get two IDE controllers to work
on the same box.

Here's what I've come up with:

SCENARIO (1):

IDE0
Master 540MB     HD
SLAVE  1GIG      HD

IDE1
Sony             CD

All work under DOS can't mount CD in Linux

SCENARIO (2)

IDE0
Master 540MB    HD
SLAVE  Sony     CD

IDE1
MASTER  1 GIG   HD

All work under DOS and can Linux FDISK the GIG drive... but then when
I am in the middle of placing the file system on the  2nd drive -
- it burps - and inconsistantly at different times.

Just a limitation?  (should problably be using SCSI anyways)

I made sure the Master Slave settings were proper too.

Suggestions would be appreciated - I don't use the CD that much but it
would be nice.

Thanks
Dag    

 
 
 

2 IDE Controllers with Linux 1.2.13 - Possible?

Post by Rhys Thury » Fri, 09 Feb 1996 04:00:00


: Hello-

: Has anyone been lucky enough to get two IDE controllers to work
: on the same box.

: Here's what I've come up with:

: SCENARIO (1):

: IDE0
: Master 540MB     HD
: SLAVE  1GIG      HD

: IDE1
: Sony             CD

I have this setup on the machine I am using right now.  Make sure that
the kernel is compiled with the new IDE driver, along with ATAPI
support.  Also, make *sure* you run the new MAKEDEV in
/usr/src/linux/drivers/block/MAKEDEV.ide so that all your device numbers
are correct.  I couldn't get it to work either until I did this.  Lastly,
make sure that your I/O addresses on both controllers conform to the
standard for IDE0 and IDE1, and that your IRQ for IDE0 is 14 and your IRQ
for IDE1 is 15.

If you *still* have problems after that, it may be a defect, because I've
had multiple IDE controllers, SCSI controllers, and IDE/ATAPI CD-ROMs
*all* in my machine for quite some time, *all* working under DOS and
Linux, no problems whatsoever since Linux v1.1.75.  :)

--
He played the king as if afraid someone else would play the ace.
                --John Mason Brown, drama critic

                                                        --ccthuryn

 
 
 

2 IDE Controllers with Linux 1.2.13 - Possible?

Post by Mahmut Kurs » Tue, 13 Feb 1996 04:00:00


 > Has anyone been lucky enough to get two IDE controllers to work
 > on the same box.
 > Here's what I've come up with:
 > SCENARIO (1):
 > IDE0
 > Master 540MB     HD
 > SLAVE  1GIG      HD
 > IDE1
 > Sony             CD
 > All work under DOS can't mount CD in Linux

I installed Slackware from a Sony Doublespeed ATAPI CDROM
but this was with the 1.3.X Kernel.
It was IDE0 = 1.2 GB EIDE HD Maxtor Master
IDE1 = Sony CDROM ATAPI Master

 
 
 

1. 1.2.13 patch needed for 2 IDE controllers?

Do I need a patch if I want to use 2 IDE controllers (3 harddisks in my
case, non E-IDE) on my 1.2.13 kernel? If not, how do I make my kernel see
the extra harddisk; if so, any ideas on where to get the patch?

Thanks.

                                                                robert

2. Compiling 1.2.13 with gcc-2.7.2

3. IDE/ATAPI kernel (1.2.13) won't recognize secondary controller

4. BIOS calls under Linux ?

5. 2 IDE Controllers with 1.2.13 - Problem?

6. Dip up 100% of the time

7. strange problems 1.2.13 --> 2.0.0 --> 1.2.13

8. Process numbers of BGed jobs

9. LINUX 1.2.13 problems with SCSI HDD and IDE CD ROM

10. Conner 800 meg IDE Tape Drive & Linux 1.2.13

11. Hitachi IDE/ATAPI CD-ROM and Linux 1.2.13

12. 1.2.13, Floppy controller tape drives

13. ide resets under slackware 1.2.13