Where are located files for Hardware Network configuration ?

Where are located files for Hardware Network configuration ?

Post by Stev » Sat, 11 Jun 2011 00:53:14



Hi,

I am using virtualization. Guest and Host are Fedora 14

When I've got the image running, I've got on my image :
Hardware xxxx associated to Eth0

Now, if I back and restore the image on a different machine.... The hardware
which is the same, most of the time, is associated to eth2 or eth3

The problem is that I cannot start by : service network start
It cannot find eth0 !!!

Where is located the file ( on Fedora 14 ) saying that I have such hardware
, associated to ethX ?

Thanks for your help

 
 
 

Where are located files for Hardware Network configuration ?

Post by Kurt Harder » Sat, 11 Jun 2011 14:56:32


Hi Steve,

Am 09.06.2011 17:53, schrieb Steve:

Quote:> When I've got the image running, I've got on my image :
> Hardware xxxx associated to Eth0

> Now, if I back and restore the image on a different machine.... The hardware
> which is the same, most of the time, is associated to eth2 or eth3

Thats not only true for different virtual machines it happens even on
new hardware. udev ist detecting a new network card and creates a new
entry in /etc/udev/rules.d/xx-persistent-net.rules keeping the old eth0.
If you remove this file before booting on the new machine it should word.

Quote:> The problem is that I cannot start by : service network start
> It cannot find eth0 !!!

The hardware for eth0 is gone :-).

Quote:> Where is located the file ( on Fedora 14 ) saying that I have such hardware
> , associated to ethX ?

/etc/udev/rules.d

Regards, Kurt

--
KHTronik - Kurt Harders
Elektronik, Softwareentwicklung, Opensource-Beratung
Leimbacher Str. 36
42281 Wuppertal

T +49 202  2 50 11 64
F +49 202  2 50 11 65
M +49 171  8 36 82 33

 
 
 

Where are located files for Hardware Network configuration ?

Post by Stev » Sat, 11 Jun 2011 16:13:33



> Hi Steve,

> Am 09.06.2011 17:53, schrieb Steve:

>> When I've got the image running, I've got on my image :
>> Hardware xxxx associated to Eth0

>> Now, if I back and restore the image on a different machine.... The
>> hardware which is the same, most of the time, is associated to eth2 or
>> eth3

> Thats not only true for different virtual machines it happens even on
> new hardware. udev ist detecting a new network card and creates a new
> entry in /etc/udev/rules.d/xx-persistent-net.rules keeping the old eth0.
> If you remove this file before booting on the new machine it should word.

>> The problem is that I cannot start by : service network start
>> It cannot find eth0 !!!

> The hardware for eth0 is gone :-).

>> Where is located the file ( on Fedora 14 ) saying that I have such
>> hardware , associated to ethX ?

> /etc/udev/rules.d

> Regards, Kurt

Hi Kurt,

Thank you foryour reply.
I had a look in my Fedora ( /etc/udev/rules.d ) , but I can't find any info
in this folder.

I have some files like :
* 10-Vboxdrv.rules
* 40-hplip.rules

But nothing concerning "network" !?!?