pppd: "Couldn't get channel number: Input/output error"

pppd: "Couldn't get channel number: Input/output error"

Post by Cyril ADRIA » Fri, 06 Apr 2001 02:48:13



        Hello,

        I'm new to this newsgroup--I was directed here by ppp-howto.

        I am  trying to create  a nullmodem connection between  two computers,
the "server" running Linux.

        Some relevant details:

                - Debian Woody
                - kernel 2.4.3 with devfs
                - pppd version 2.4.0f-1
                - ppp0 is up: it is my Internet connection

        I tried many things (changing /etc/ppp/options, etc to no avail) and I
always get the same result. Here is a sample:

--8<--
galadriel:~# pppd -detach crtscts lock proxyarp 192.168.168.1:192.168.168.2 /dev/ttyS1 38400
Couldn't get channel number: Input/output error
-->8--

        The worst thing is, if I  don't give "-detach", pppd exits with status
0, and no error message, but no  process in background, and of course still no
ppp1 available.

        Could somebody help?

        Thanks,

                Cyril
--
Cyril ADRIAN                             <http://www.chez.com/cadrian>

 
 
 

pppd: "Couldn't get channel number: Input/output error"

Post by Clifford Kit » Fri, 06 Apr 2001 07:01:59


Quote:> I am  trying to create  a nullmodem connection between two computers,
> the "server" running Linux.
>                 - Debian Woody
>                 - kernel 2.4.3 with devfs
>                 - pppd version 2.4.0f-1

This is not pppd from the mainstream pppd series, Debian must
have modified it.  The lastest is pppd 2.4.1 available via ftp from
ftp.samba.org in /pub/ppp which is the new pppd repository.  The 2.4.0
and most of the 2.4.0bx series' had minor but sometimes annoying bugs.

Quote:>                 - ppp0 is up: it is my Internet connection
> I tried many things (changing /etc/ppp/options, etc to no avail) and I
> always get the same result. Here is a sample:
> galadriel:~# pppd -detach crtscts lock proxyarp 192.168.168.1:192.168.168.2
> /dev/ttyS1 38400
> Couldn't get channel number: Input/output error

Do you have /dev/ppp created?  Or the line

LOOKUP          ppp             MODLOAD

in /etc/devfsd.conf, if you are using the ppp_generic module?

Read about these in the 2.4.1 source package README.linux file.  Or in
the Documentation/Changes file in the 2.4.3 kernel source tree.

I'm using a manually created /dev/ppp, pppd 2.4.1, and the 2.4.3 kernel,
but only one connection.  If the problem has to do with two connections,
or is devfs specific, then I'm not able to help much there.

(A couple of cheap NIC cards and a crossover cable would perform much
better than a null modem connection.)

--

/* To extract lines:  View file with "vi -R".  Move cursor to first line.
   Press "v".  Move cursor to mark lines (Esc unmarks).  Write lines to
   fubar with ":w fubar <Enter>".  Exit with ":q <Enter>". */