showmount

showmount

Post by S├ębastien TRICAU » Mon, 13 Mar 2000 04:00:00



Hello everybody,
I have a problem with my showmount command.
When I execute the command like this : "showmount -e remote_IP"
I have no answer, and after my RPC is killed by a long time for the request.
Thanks.
 
 
 

showmount

Post by Steve Housem » Mon, 13 Mar 2000 04:00:00


Not quite sure what your symptoms are, but is the portmap running
on the remote system ... check on there (ie the remote system)  that
# ps -aux | grep portmap
# shows something
#rpcinfo -p
   program vers proto   port
    100000    2   tcp    111  portmapper
    100000    2   udp    111  portmapper
    100005    1   udp    703  mountd
    100005    1   tcp    705  mountd
    100005    2   udp    708  mountd
    100005    2   tcp    710  mountd
    100005    3   udp    713  mountd
    100005    3   tcp    715  mountd
    100003    2   udp   2049  nfs

check that /etc/hosts.allow , deny on server are ok , ie
remove them to allow all , and then work from there (man 5 hosts_access)
The portmapper and mountd both use hosts_access, see man for
portmap and mountd.

Check that names to ip for client and server resolve both ways
on client and server.

and on client system check that
# rpcinfo -p <server>
shows same as on server and then showmount -e <server> should work.

Cheers,

Steve Houseman

--

currently  steve.houseman at * net      

 
 
 

1. showmount command

 Hi,

 Is there any way of preventing a remote Unix machine from
 using the "showmount -a" command to determine what other
 Unix machines are mounting my disk drives?  Can I specify
 what machines can use this command to determine who is
 mounting my drives?

 Thanks,

 Chris Robinson

Sent via Deja.com http://www.deja.com/
Before you buy.

2. suck / suckxover / regex

3. How to understand showmount

4. The wonderful Linux community

5. sunos shutdown message showmount: ... RPC: Program not registered

6. Have linux send getty to another computer

7. linux SLS 1.06 showmount

8. Help needed re: Modem

9. Showmount

10. Incorrect output from showmount

11. problem with showmount and nfs

12. showmount says "RPC: Program not registered"

13. How to disable showmount and rpcinfo ?