Samba Win98 Logons

Samba Win98 Logons

Post by Claudi » Sat, 24 Mar 2001 09:55:56



I am running a Linux server using samba and I have 3 Win98SE Workstations
connected to it.

Problem:  At the end of the day, all users but one shuts down their
computers for the night. The linux box stays running. When users return to
work the next morning to login, the server denies their request with
"password invalid for this domain." When I do a samba restart command, the
users can then login... Why?

 
 
 

Samba Win98 Logons

Post by Dean Thompso » Sat, 24 Mar 2001 10:50:43


Hi Claudia,

Quote:> I am running a Linux server using samba and I have 3 Win98SE Workstations
> connected to it.

> Problem:  At the end of the day, all users but one shuts down their
> computers for the night. The linux box stays running. When users return to
> work the next morning to login, the server denies their request with
> "password invalid for this domain." When I do a samba restart command, the
> users can then login... Why?

Just a few quick questions?
  * What version of SAMBA are you running, Samba 2.0.7 or Samba 2.2 or
     something earlier than that ?
  * Check to make sure that SAMBA is running in daemon mode and is not
     closing down when the last user logs off.  I presume it is being started
     with the -D parameter ?
  * What do the /var/log/smb.log (or equilvalent) say about SAMBA's actions ?

See ya

Dean Thompson

--
+____________________________+____________________________________________+

| Bach. Computing (Hons)     | ICQ     - 45191180                         |
| PhD Student                | Office  - <Off-Campus>                     |
| School Comp.Sci & Soft.Eng | Phone   - +61 3 9903 2787 (Gen. Office)    |
| MONASH (Caulfield Campus)  | Fax     - +61 3 9903 1077                  |
| Melbourne, Australia       |                                            |
+----------------------------+--------------------------------------------+

 
 
 

1. Can't get Win98 clients to logon to Samba

Running Win98 Clients
Server is RedHat 6 with Samba 2.0.5a

One thing to also note...first time ever setting up Samba

Here is my smb.conf file

; smb.conf starts here
; smb.conf's global parameters section
[global]
 ; set the netbios machine name for the server
 ; server name
 netbios name = REMY
 ; description of the server as seen from a Win client
 server string = Samba %v
 ; set the workgroup membership
 ; domain name
 workgroup = VEGA
 ; set Samba to authenticate in user mode security
 security = user

 smb passwd file = \usr\bin\smbpasswd
 hosts allow = 192.168.10.1/255.255.255.0
 encrypt passwords = yes
 password level = 4
 domain logons = yes
 logon script = logon.bat

 ; makes shares automatically visible on a browse list
 auto services = psmith jsmith swap

 os level = 64
 domain master = yes
 local master = yes
 preferred master = yes

 browseable = yes
 writeable = yes
 locking = no
 case sensitive = no
 default case = lower
 preserve case = yes
 short preserve case = no

[netlogon]
 comment = NETLOGON Service
 path = /home/samba/logon
 locking = no
 public = no
 writeable = no

; share name
[swap]
  ; text to list when browsing the share
  ; from a client machine
  comment = Shared Drive For All Users
  ; absolute path to the directory
  path = /home/swap
  ; should the drive be writeable
  writeable = yes
  ; users allowed to connect to the share


  ; enforce file locking?
  locking = yes
  ; default file creation permission mask
  create mode = 0660
  ; default directory creation permission mask
  directory mode = 0770
 ; share name
 [homes]
  comment = Home Drive
  path = %H
  writeable = yes
  valid users = %S
  create mode = 0600
  directory mode = 0700
  locking = no
; smb.conf file ends here

also to create the encrypted passwords I issued this command
cat /etc/passwd | mksmbpasswd.sh > /usr/bin/smbpasswd
which took the linux passwords and made the smbpasswd file that is
called for in this line of the smb.conf
 smb passwd file = \usr\bin\smbpasswd

When I am at the client machines at the log in I type in the user name
(jdoe) password (test) and the domain (vega) and I get back the error
message stating "The domain password you supplied is not correct, or
access to your logon server has been denied"

I am stuck and confused any help appreciated and other information you
need just let me know

Thanks
Stone

2. pages in memory, but not in use, not in swap?

3. WIN98 does not logon to Samba when DNS is set in Linux

4. OpenGL accelaration on a Banshee video card

5. SAMBA - Win98 Machines and ICS through Win98 ok - no Windows network in linux

6. booting from MCP750 PowerPC

7. Samba 2.0.5 on FreeBSD 3.1-RELEASE - very very slow writing to Samba from win98

8. Erik Funkenbusch violates usenet netiquette (was can't use Outlook Express)

9. Samba question: Win98 workstation with a private IP can't see Samba

10. WIN98 logon initiates a dialup to the Internet.

11. WIn98 logon

12. Migrate Win98 client to Linux and keep NT Domain logon?

13. Linux logon to netware 4.xx and share the internet link provided by a win98 machine