in.ttysnoopd not updating utmp on exit ?

in.ttysnoopd not updating utmp on exit ?

Post by Brock Norve » Fri, 26 Jan 1996 04:00:00



Has any one had this experience and come up with a solution ? Currently,
we have the snooping telnet installed for helping some new users out, and
when they exit thier telnet session, the utmp entry only gets removed once
in a great while. Not a major concern, but rather annoying if one is using
who or finger..

Brock

--
Brock Norvell                       "Many men go fishing all of their lives

Senior Programmer/Analyst            they are after."
Keane, Inc.                         - Henry David Thoreau

#include <std/disclaimer.h>           /* My opinions, not Keane's      */
#include <std/pgpkey.h>               /* Finger for PGP key            */

 
 
 

1. xterm not updating utmp on exit

Hello,

        my xterm/color_xterm are SUID root.  When I leave X and run
`finger` or `who` or aything, I still see a crap-load of people "logged
in" on ttyp ports.  They're not there, of course.  What's causing this,
and how can I fix it?  Thanks,

BTW, here is the ls -la output...
-rwsr-xr-x   1 root     bin        145276 Jun 11  1995 /usr/X11/bin/color_xterm*
-rwsr-xr-x   1 root     root       134412 Jul 23  1995 /usr/X11/bin/xterm*


Kickin' it since 1.1.59  http://www.ecst.csuchico.edu/~bryanxms
/* Do not distribute this message across the Microsoft(tm) Network */

2. pid 25's child link is bad

3. xterm doesn't update utmp when exiting

4. fonts size default in xwin

5. xterms not updating utmp

6. how to compile kde 1.1.2 ???

7. utmp not updating

8. Source code for BSD Unix commands

9. utmp not updated after rsh

10. xterms not updating utmp

11. /etc/utmp not updated, why ?

12. utmp not getting updated correctly when a user logs out

13. Plug-ins not not seen by Gimp