Can't create files on mounted Novell-Volumes

Can't create files on mounted Novell-Volumes

Post by K. Hoffrat » Wed, 10 Mar 2004 04:56:20



Hello all.

I have some problems with ncpmount under SuSE 9.0 to an Novell 4.11 server
running NDS.
The goal is to re-export the mounted Novell-Volumes via Samba to Windows clients.
To test the whole thing i wanted to take it simple an just create / change files from
the shell. But there the problem begins...

I can mount the volumes successfully, but when i try to create a new file as a
"normal" user it says permission denied. As root it works without any problem.

I created the mountpoint the following way:
     su smbnovell
     md /daten/server1
     chmod 777 /daten/server1

This results in the following directory structure:
     drwxrwxrwx  root     root    ./
     drwxrwxrwx  root     root    ../
     drwxrwxrwx  smbnovell  users  server1/

After this i can mount the Novell-Volumes with the following command:
     ncpmount -S Server1 -U valid.user.context -P xxx -u smbnovell \
       -g users -f 777 -d 777 /daten/server1

The volumes get mounted and i can change into the subdirectories, see files,
open them, change and save them.
But when i try to create a new file it says "Permission denied".
As an example i try to create a file in "/daten/server1/disk2/Allgemein".
I do an "cd /daten/server1/disk2/Allgemein" and then "cp test.txt test1.txt"

Result: "Permission denied".

The permissions for the file / directory are as follows:
     drwxrwxrwx  smbnovell  users  ./
     drwxrwxrwx  smbnovell  users  ../
     -rwxrwxrwx  smbnovell  users  test1.txt

Anyone experienced this earlier? I tried to solve this problem for the last
3 days, but now i'm helpless.
Since root can create files, i think the problem is within the linux
permissions, but i since i'm new to linux, i can't find where is the problem.

Every help is very appreciated.

TiA,

Karsten

 
 
 

Can't create files on mounted Novell-Volumes

Post by Bill Marcu » Wed, 10 Mar 2004 06:33:20


On 8 Mar 2004 19:56:20 GMT, K. Hoffrath

> Hello all.

> I have some problems with ncpmount under SuSE 9.0 to an Novell 4.11
> server running NDS. The goal is to re-export the mounted
> Novell-Volumes via Samba to Windows clients. To test the whole thing i
> wanted to take it simple an just create / change files from the shell.
> But there the problem begins...

> I can mount the volumes successfully, but when i try to create a new
> file as a "normal" user it says permission denied. As root it works
> without any problem.

I'm not sure, but maybe it's like Samba, where you need uid= and umask=
options.

--
Incrsease your earoning poswer and gaerner profwessional resspect.
Get the Un1iversity Dewgree you have already earned.
 [from the prestigious, non-accredited University of Spam!]

 
 
 

Can't create files on mounted Novell-Volumes

Post by K. Hoffrat » Wed, 10 Mar 2004 18:53:07



> On 8 Mar 2004 19:56:20 GMT, K. Hoffrath

> > Hello all.

> > I have some problems with ncpmount under SuSE 9.0 to an Novell 4.11
> > server running NDS. The goal is to re-export the mounted
> > Novell-Volumes via Samba to Windows clients. To test the whole thing i
> > wanted to take it simple an just create / change files from the shell.
> > But there the problem begins...

> > I can mount the volumes successfully, but when i try to create a new
> > file as a "normal" user it says permission denied. As root it works
> > without any problem.

> I'm not sure, but maybe it's like Samba, where you need uid= and umask=
> options.

Thanks for your response.

If i understand "man ncpmount" correct, thats what -u/-g are for.
Anyway, i solved my problem by creating an entry in /etc/fstab. It's strange, put with
the entry in fstab and just calling "mount /daten/server1" it works.

--
Karsten Hoffrath

 
 
 

1. Error while cp'ing files from mounted Novell volumes

Hi there!

I've been running a Linux machine (Kernel 2.0.33) and have mounted a
Novell volume. While copying a larger amount of files, from the Novell
server to a local disk suddenly some errors are written to stdout "[a
path on novell server] cannot copy cyclic symbolic link". When copying
the files several times, the path where this error occurs is not always
the same. The message is very strange, because Novell doesn't offer
symbolic links, so there can't be a problem copying symbolic links.
Perhaps a bug in the IPX or NCP drivers?

Anybody else having such problems? Anybody knows a solution for this
problem?

Here some details about the Linux machine:
486 DX 66MHz
Asus APG4 Board (Aries chipset)
32MB RAM
2 IDE hard drives (both WD with 850MB & 2.1GB)
Trident ISA VGA
WD8003 ISA Network card (BNC connected to Cheapernet)

Details about the Novell-Machine:
Running Netware 4.1 with frame type 802.2 (NE2000 compatible card)
OS2 namespace added

Any help or comments appreciated.

Thanx

2. sendmail

3. Can't mount Novell volume using NCPFS

4. looking for raid5 ide controller

5. Can't mount Novell NetWare 6 volumes from Linux - help please!

6. apache & netscape faq addition?

7. Can't Mount Novell Volume using NCPFS

8. HELP - Missing code in kernel source

9. Veritas Volume Manager: Volume doesn't create "rdsk" entry

10. Mounting Volume Manager File Systems without the Volume Manager software

11. Have OpenBSD possibility to mount Novell volumes?

12. Mounting Novell Netware Volumes

13. Mount of Novell 3.2 Server Volumes using IPX/NCP not possible using SuSE 8.2