Setserial and 115200 baud

Setserial and 115200 baud

Post by Chuck Carls » Fri, 14 Apr 1995 04:00:00



I am trying to set my modem serial port to 115200.  I know you have to use
setserial as follows:

        setserial /dev/modem spd_vhi

Setserial will then convert 38.4kbps to 115200bps.  However, the modem is
being set to 9600.

I think that setserial is looking at some init info somewhere and finding
9600.  I need to change that info to 38400bps.

I am using getty_ps if it matters.

Any ideas?

Regards, Chuck

 
 
 

Setserial and 115200 baud

Post by Bernd Eckenfe » Sat, 15 Apr 1995 04:00:00



> I am using getty_ps if it matters.
> Any ideas?

U have to tell getty to use the right Entry from the gettydefs File:

/etc/inittab
...
s1:234:respawn:/sbin/getty    ttyS1  38400
...

/etc/gettydefs
...

...

Greetings
Bernd
-- __


  o--o           *QUAK* Jetzt auch mit Plueschtier in der .Sig!


 
 
 

Setserial and 115200 baud

Post by Peter Jon » Sat, 15 Apr 1995 04:00:00


: I am trying to set my modem serial port to 115200.  I know you have to use
: setserial as follows:

:       setserial /dev/modem spd_vhi

: Setserial will then convert 38.4kbps to 115200bps.  However, the modem is
: being set to 9600.

Setserial does not do anything to your modem.

You'll need to check the modem manual to see how to lock the port to 115200.
On the Hayes Optimas we have here it's as simple as:
$ kermit -l /dev/cua0 -b 115200 -Y -C 'script ~0 ATZ OK~r ~0, quit'
The modems were set up at 115200 (that is, the AT&W0 was issued at that
speed).

-- Peter
--
Drealm Conference System -- (+44) 181 568 4305 (V.FC)
The home of drealmBBS -------- six lines -- live chat

 
 
 

Setserial and 115200 baud

Post by Chuck Carls » Sat, 15 Apr 1995 04:00:00



: : I am trying to set my modem serial port to 115200.  I know you have to use
: : setserial as follows:

: :     setserial /dev/modem spd_vhi

: : Setserial will then convert 38.4kbps to 115200bps.  However, the modem is
: : being set to 9600.

: Setserial does not do anything to your modem.

: You'll need to check the modem manual to see how to lock the port to 115200.

I should mention that I am using an external modem, so locking it to 115200
and not setting the 16550a on the pc will not work together properly.

Regards, Chuck

 
 
 

Setserial and 115200 baud

Post by Chuck Carls » Sat, 15 Apr 1995 04:00:00



: > I am using getty_ps if it matters.
: > Any ideas?

: U have to tell getty to use the right Entry from the gettydefs File:

: /etc/inittab
: ...
: s1:234:respawn:/sbin/getty    ttyS1  38400
: ...

: /etc/gettydefs
: ...

: ...

Thanks for that suggestion.

I found the entry in inittab you mentioned and it was commented out.
I uncommented it and then reran setserial.  Setserial now gives me the
message 'Modem busy'.  Seyon thinks the modem is busy also.

Any more thoughts?

Regards, Chuck