Problems with Token Ring Adapters & v2.0.23

Problems with Token Ring Adapters & v2.0.23

Post by Timm Gleaso » Sat, 07 Dec 1996 04:00:00



I have been trying for some time to attempt to get a token ring network
card working wth version 2.0.23 of Linux.
I have been using the 3Com TokenLink Velocity PCI card and would lke any
feedback as to what kinds of token cards others have had luck with.

****************************************************************************
"Duct tape is like the Force. It has a light side, a dark
side, and it holds the universe together...."   -Carl Zwanzig

"You've read the e-mail! Now see the web page!"
****************************************************************************

N2H2, Creators of Bess -- 1301 Fifth Avenue, Suite 1501, Seattle, WA
98101
http://weber.u.washington.edu/~mcanlish/        http://n2h2.com/
***************************************************************************

 
 
 

Problems with Token Ring Adapters & v2.0.23

Post by Paul P. Nort » Mon, 09 Dec 1996 04:00:00



> I have been trying for some time to attempt to get a token ring network
> card working wth version 2.0.23 of Linux.
> I have been using the 3Com TokenLink Velocity PCI card and would lke any
> feedback as to what kinds of token cards others have had luck with.

The TokenLink Velocity isn't supported and I wasn't able to get the
technical information from 3Com to write a driver.

Paul

 
 
 

Problems with Token Ring Adapters & v2.0.23

Post by Chris C » Sat, 14 Dec 1996 04:00:00


So far I have only had any success with an old IBM ISA 4/16 MB card.  The Intel
card was not recognised.

Actually, I'm having problems even with the IBM board.  Any packet addressed to the subnet
broadcast address fails.  The error bing logged as:-
tr0: xmit ret_code: 22 xmit error code: 88 or 8C

Not having any documentation (and very little Token Ring experience), I don't know where to
start trying to debug the problem...

Chris

 
 
 

Problems with Token Ring Adapters & v2.0.23

Post by Paul P. Nort » Tue, 17 Dec 1996 04:00:00



>So far I have only had any success with an old IBM ISA 4/16 MB card.  The Intel
>card was not recognised.

>Actually, I'm having problems even with the IBM board.  Any packet addressed to the subnet
>broadcast address fails.  The error bing logged as:-
>tr0: xmit ret_code: 22 xmit error code: 88 or 8C

Retcode 22, error code 88 means you put a frame on the ring that
nobody recognized as being addressed to them as destination and
nobody copied it.

Quote:

>Not having any documentation (and very little Token Ring experience), I don't know where to
>start trying to debug the problem...

>Chris

I'll try to duplicate it tonight...

Paul
--
Paul P. Norton                  

 
 
 

1. token ring token ring token ring

I would advice either going to a more recent kernel, or back to 1.2.x,
and applying the TR patch.  As far as I can tell, the built-in TR support
in 1.3 was broken early on, and not fixed until very recently.

I had no end of problems - normally showing as booting and init'ing the
TR card ok, could ping ok, but any more then that (such as telnet or ftp,
either into or out of the Linux machine) gave a kernel panic.

Compiled up 1.3.72 the other day and it's been running perfectly ever
since.  I'm using a Madge Straight Blue right now but have also used
some older IBM 4/16 cards.

Leonard

2. changing password every 3 months on nis?

3. TOKEN RING? (unfortunately *IBM* Token Ring)

4. Xemacs on RH5.2

5. Token Ring & 5.0.2 & Problems....

6. Failures in nmbd and netbios-ns/udp

7. Token ring & linux & 3com 3c619c & unknown command 0x80 ???

8. tar command hanging

9. Courier 0.23 or 0.23a for FreeBSD 4.0 Problems.

10. phpfi2.0b11 auf linux2.0.23 laeuft nicht ;(

11. IBM PCI Token-Ring adapter configuration

12. INETD dies with a Token Ring adapter

13. HELP: IBM Auto 16/4 Token-Ring ISA Adapter