DIP/SLIP works great from command line, but fails as cron job (??)

DIP/SLIP works great from command line, but fails as cron job (??)

Post by Mc » Fri, 10 Jan 1997 04:00:00



Hi.   I use DIP and SLIP to access an Internet provider, and my script
      file which invokes DIP works fine if I invoke it from the command
      line.  I can run Xwindows and Netscape, ftp, etc...
      But if I try to invoke DIP via "at" or "cron", it fails to connect,
      and yet there are no error messages.  I invoke DIP with verbose
      mode, and check the log that cron emails me.  Everything seems fine.
      All the dialog with my internet provider is there, right up to the
      point where I tell my isp to start SLIP.  No problem, except that the
      line drops.  It seems as if the daemon for DIP is not being hived-off
      as a seperate process correctly when cron tries to do it.

      I am running older versions of things, but I suspect there is some
      simple tweak to fix this.  I have read the DIP HOW-To's, and tried
      sunsite.unc.edu to get latest docs, but was turfed off by their "go
      away" version of ftp.   Any suggestions??

      Versions:  DIP      3.3.7L-uri
                 SLIP     0.8.3
                 (Kernel) 1.2.1  

      Any help greatly appreciated.         - Mark Langdon, Toronto, Canada

 
 
 

DIP/SLIP works great from command line, but fails as cron job (??)

Post by Toni » Fri, 17 Jan 1997 04:00:00



> Hi.   I use DIP and SLIP to access an Internet provider, and my script
>       file which invokes DIP works fine if I invoke it from the command
>       line.  I can run Xwindows and Netscape, ftp, etc...
>       But if I try to invoke DIP via "at" or "cron", it fails to connect,
>       and yet there are no error messages.  I invoke DIP with verbose
>       mode, and check the log that cron emails me.  Everything seems fine.
>       All the dialog with my internet provider is there, right up to the
>       point where I tell my isp to start SLIP.  No problem, except that the
>       line drops.  It seems as if the daemon for DIP is not being hived-off
>       as a seperate process correctly when cron tries to do it.

>       I am running older versions of things, but I suspect there is some
>       simple tweak to fix this.  I have read the DIP HOW-To's, and tried
>       sunsite.unc.edu to get latest docs, but was turfed off by their "go
>       away" version of ftp.   Any suggestions??

>       Versions:  DIP      3.3.7L-uri
>                  SLIP     0.8.3
>                  (Kernel) 1.2.1

>       Any help greatly appreciated.         - Mark Langdon, Toronto, Canada


Hi Mark,

I have experienced some problems with dip while
executing it with the -v option and the standar
output wasn't a true terminal. When you run it from
cron, what dip gets as standar output is a file, not
a terminal, so it fails. Try it without the -v option.

Regards and good luck.

Toni

 
 
 

1. cron fails; command line OK

I've got a puzzling problem...
I have an entry in cron as follows:
55 2 * * * find /apps/d2/outputs -name "*" -type f -mtime +7
-exec rm {} \;
Mail is sent that says "incomplete statement" and the command
does not execute.
When I execute from the command line - it works.
I think that it has not worked since we went from 3.2.5 to 4.3.2
a couple of weeks ago, although I can't imagine that would
matter.
Thanks in advance for any ideas.

2. Tagline Campaign against Snoopware

3. PPP fails where SLIP works (in dip)

4. help with setting up printer

5. PPP Client (works great with GUI rp3) but how about the command line???

6. Radius Binary Available

7. NFS Installation using RedHat5

8. Talk/Not Work via SLIP/Works Great Locally

9. SLIP and DIP not working after reinstall of Slackware 1.2(SLIP)

10. SLIP connection: nslookup works but command line addrs not resolved!?

11. GREAT JOBS-GREAT PAY" WVT"