Delay in rsh returning to prompt?

Delay in rsh returning to prompt?

Post by Walter Preuning » Fri, 17 Mar 1995 15:46:09



I have a 486 Linux box connected to an IBM RS/6000 by 10Base2. a command
such as "rsh walter ls" performs the ls on walter (linux) by takes about
a minute to return to the command prompt. From walter the command "rsh hs
ls" returns immediatly after performing the ls. Why? "rsh walter" drops
me into a shell with no delays and there is no delay upon exiting.
My kernel and network code is from Slackware 2.02 (kernel 1.1.54).

Thanks in advance,
Walter

 
 
 

Delay in rsh returning to prompt?

Post by Jim Youngblo » Sun, 26 Mar 1995 00:50:34


Quote:Walterp writes:
> . . .the command "rsh hs ls" returns immediatly after performing the ls.
> Why? "rsh walter" drops me into a shell with no delays and there is
> no delay upon exiting.

This seems to be a GENERAL problem.  We are running Slackware 2.1 (kernel
1.1.94) on a Sun ethernet network.  As we see the problem we can log into
the Linux system (via rsh) from one of the Suns and will sporadicly
experience delays of up more than a minute where there is no typeahead or
any response to keyboard input.  

Does anyone know of a solution?

 
 
 

1. rsh never returns to prompt - SIGTTIN

I would appreciate any help on this one.

I execute a rsh to stop an informix database prior to raw backup.  The
rsh to take it down works fine, however, when I execute the following
line to restart the database - the database starts but the rsh never
returns:

# rsh HOST "su - informix -c \". /opt/informix/.profile; setsrv
INSTNAME; oninit\""

If I then use CTRL-Z and bg to put it in the background and execute jobs
- it reports Stopped (SIGTTIN).  I've tried using -n option to rsh,
redirecting /dev/null to stdin (inside the -c portion and to rsh itself)
and have run out of ideas.


MUCH APPRECIATED!
Chris Hurt

2. NIS problem with HP-NIS

3. rsh does not return: rsh -n spica /etc/init.d/autofs start ?

4. Bizarre Network Unreachable Issue on VAIO

5. Delayed telnet login prompt on Redhat6.0

6. Xfree86

7. puzzling delay between connection and login prompt

8. ppp with t-online

9. **long** delay before login prompt

10. Delay in prompt appearance in new terms and xterms - why?

11. FTPd Delays on Linux 1.1.8 - 2 minutes for prompt - wierd

12. long delay between connection and telnet prompt

13. delayed login prompt thru' telnet ??