need help using dip for SLIP connection

need help using dip for SLIP connection

Post by Jeremy Blumenfel » Wed, 21 Oct 1998 04:00:00



I have a rocketport serial port in a RedHat linux box.
I am trying to hook-up a (wireless) modem to one of the ports.
I have verified that the modem works by running the cu program which
reads and writes properly to the port.  However, when I try to run DIP
to set-up a slip connection with the modem, the modem doesn't reply
properly.  If i send an AT string and then wait for a reply the system
simply hangs while waiting, even if there is a time-out set.

any help greatly appreciated.
--
Jeremy Blumenfeld

 
 
 

need help using dip for SLIP connection

Post by Kalevi Hautanie » Thu, 22 Oct 1998 04:00:00


: I have a rocketport serial port in a RedHat linux box.
: I am trying to hook-up a (wireless) modem to one of the ports.
: I have verified that the modem works by running the cu program which
: reads and writes properly to the port.  However, when I try to run DIP
: to set-up a slip connection with the modem, the modem doesn't reply
: properly.  If i send an AT string and then wait for a reply the system
: simply hangs while waiting, even if there is a time-out set.

Have you tried to use minicom? If it can use your modem, simply copy the
init string it uses to your dipscript and try again. All the modems of
these days are not ready for Linux use in their factory default settings.

Kalevi

--
Kalevi J Hautaniemi,      Marjatankatu 12,     33730 Tampere,  FINLAND.
****  http://oh3tr.ele.tut.fi/~oh3fg/ ****  On air:  OH3FG, KO4BC  ****
tel:+358-3-364-7446    fax:+358-3-364-2476    mobile:+358-50-590-2243

 
 
 

need help using dip for SLIP connection

Post by Clifford Ki » Fri, 23 Oct 1998 04:00:00


: I have a rocketport serial port in a RedHat linux box.
: I am trying to hook-up a (wireless) modem to one of the ports.
: I have verified that the modem works by running the cu program which
: reads and writes properly to the port.  However, when I try to run DIP
: to set-up a slip connection with the modem, the modem doesn't reply
: properly.  If i send an AT string and then wait for a reply the system
: simply hangs while waiting, even if there is a time-out set.

This is strange if you are using dip -i, providing the correct port
(/dev/ttySx, your modem device node), and entering "term" afterward to
run the term program.  This is a very minimal procedure and should work.
It doesn't seem likely that wireless would have anything to do with it
failing if you were successful with cu, although admittedly I have no
experience with wireless.

--
Clifford Kite                                           Not a guru. (tm)

 
 
 

1. slip-dip connection need help

hi,

        i have problem to connect linux to slip server at school using dip.
everytime, i dialup to my school's annex server. from the noise of my modem i
am sure the connection is established but nothing else (it should display some
message). the program just sit there and does nothing. it happens either using
script or entering commands.
        but if i use "term" to dial in dip, the connection is ok.
        does anyone know what wrong?

thanks

--
  ~/
:-(

2. Where is xfs started in Mandrake 7.2 (where can I put the -res 120)

3. NEED HELP w/ getting SLIP using DIP

4. Tough problem!!!

5. Using dip to establish PPP -connection (need help)

6. Personal Web Server

7. Using DIP to make a TIA SLIP connection

8. kernel 2.4 and Modules

9. Unstable SLIP connection using DIP

10. SLIP Connection to University SLIP Server: Need Help

11. HELP with dip and dynamic SLIP connection

12. Help with SLIP server setup in Linux using DIP

13. Help: Running a SLIP server using DIP