Newbie: Help setting up 2 NICs

Newbie: Help setting up 2 NICs

Post by Elbow » Tue, 27 Jun 2000 04:00:00



I am trying to set up a linux machine with 2 ethernet cards to
use
as a router for IP masquerading. I am running RedHat 6.1. The
machine is a P120 wi/ 16M ram.
        The first NIC sets up fine, but when I run ifconfig to set up
the second, I get an error:
eth1 Cannot allocated 65536 byte receive ring
SIOCSIFLAGS: Cannot allocated memory

I am basically a linux newbie. I have some experience using
redhat
but none with setup/administration.

Thanks,
Nathan

Got questions?  Get answers over the phone at Keen.com.
Up to 100 minutes free!
http://www.keen.com

 
 
 

Newbie: Help setting up 2 NICs

Post by Manfred Bart » Wed, 28 Jun 2000 04:00:00



> I am trying to set up a linux machine with 2 ethernet cards to
> use
> as a router for IP masquerading. I am running RedHat 6.1. The
> machine is a P120 wi/ 16M ram.
>    The first NIC sets up fine, but when I run ifconfig to set up
> the second, I get an error:
> eth1 Cannot allocated 65536 byte receive ring
> SIOCSIFLAGS: Cannot allocated memory

Try telling the kernel to look for 2 NICs at boot.  In your
/etc/lilo.conf, add a line:
        append = "ether=eth0 ether=eth1"
and run lilo, then reboot and watch the startup messages.
You can also recall the startup messages later with ``dmesg''.

Also try: <http://www.linuxdoc.org/HOWTO/Ethernet-HOWTO.html>

HTH
--
Manfred

 
 
 

Newbie: Help setting up 2 NICs

Post by Elbow » Wed, 28 Jun 2000 04:00:00


The kernel is already detecting both ethernet cards when it
starts up. If I ifconfig eth1 first, it works fine, but I get
errors when I try to setup eth0.
Both cards are identical, btw.

Nathan

Got questions?  Get answers over the phone at Keen.com.
Up to 100 minutes free!
http://www.keen.com

 
 
 

Newbie: Help setting up 2 NICs

Post by Manfred Bart » Thu, 29 Jun 2000 04:00:00



> The kernel is already detecting both ethernet cards when it
> starts up. If I ifconfig eth1 first, it works fine, but I get
> errors when I try to setup eth0.
> Both cards are identical, btw.

From your first message it sounded a bit like the 2nd card was not
detected.  Strange.

What are the startup messages for eth0 and eth1?
What are your ifconfig commands and the error messages?

--
Manfred

 
 
 

Newbie: Help setting up 2 NICs

Post by elb.. » Thu, 29 Jun 2000 04:00:00



I am trying to set up a linux machine with 2 ethernet cards to
use
as a router for IP masquerading. I am running RedHat 6.1. The
machine is a P120 wi/ 16M ram.
        The first NIC sets up fine, but when I run ifconfig to set up
the second, I get an error:
eth1 Cannot allocated 65536 byte receive ring
SIOCSIFLAGS: Cannot allocated memory

I am basically a linux newbie. I have some experience using
redhat
but none with setup/administration.

Thanks,
Nathan

Got questions?  Get answers over the phone at Keen.com.
Up to 100 minutes free!
http://www.keen.com

 
 
 

Newbie: Help setting up 2 NICs

Post by manfred.ba.. » Thu, 29 Jun 2000 04:00:00




> I am trying to set up a linux machine with 2 ethernet cards to
> use
> as a router for IP masquerading. I am running RedHat 6.1. The
> machine is a P120 wi/ 16M ram.
>    The first NIC sets up fine, but when I run ifconfig to set up
> the second, I get an error:
> eth1 Cannot allocated 65536 byte receive ring
> SIOCSIFLAGS: Cannot allocated memory

Try telling the kernel to look for 2 NICs at boot.  In your
/etc/lilo.conf, add a line:
        append = "ether=eth0 ether=eth1"
and run lilo, then reboot and watch the startup messages.
You can also recall the startup messages later with ``dmesg''.

Also try: <http://www.linuxdoc.org/HOWTO/Ethernet-HOWTO.html>

HTH
--
Manfred

 
 
 

Newbie: Help setting up 2 NICs

Post by elb.. » Thu, 29 Jun 2000 04:00:00



The kernel is already detecting both ethernet cards when it
starts up. If I ifconfig eth1 first, it works fine, but I get
errors when I try to setup eth0.
Both cards are identical, btw.

Nathan

Got questions?  Get answers over the phone at Keen.com.
Up to 100 minutes free!
http://www.keen.com

 
 
 

Newbie: Help setting up 2 NICs

Post by manfred.ba.. » Thu, 29 Jun 2000 04:00:00




> The kernel is already detecting both ethernet cards when it
> starts up. If I ifconfig eth1 first, it works fine, but I get
> errors when I try to setup eth0.
> Both cards are identical, btw.

From your first message it sounded a bit like the 2nd card was not
detected.  Strange.

What are the startup messages for eth0 and eth1?
What are your ifconfig commands and the error messages?

--
Manfred

 
 
 

1. Newbie in need for help with setting up second NIC

Hi All,

I brought a Netra AC200 in hope to learn more about Solaris.  From the
back it has two NIC sockets.  I like to know if the NICs are setup as
reductant or if they are two separate NICs.  If the later I would like
to setup the second nic to a different subnet.

I have read a few post on the web and find that I need to set the
local-mac-address? to True so the mac address will show on both NIC.
However, this was not the case for me.

I have the ifconfig -a output.

lo0: flags=1000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv4> mtu 8232 index
1
        inet 127.0.0.1 netmask ff000000
eri0: flags=1000843<UP,BROADCAST,RUNNING,MULTICAST,IPv4> mtu 1500
index 2
        inet 192.168.0.106 netmask ffffff00 broadcast 192.168.0.255
        ether 0:3:ba:6:13:c4
lo0: flags=2000849<UP,LOOPBACK,RUNNING,MULTICAST,IPv6> mtu 8252 index
1
        inet6 ::1/128
eri0: flags=2000841<UP,RUNNING,MULTICAST,IPv6> mtu 1500 index 2
        ether 0:3:ba:6:13:c4
        inet6 fe80::203:baff:fe06:13c4/10
#

And the netstat -rn output

Routing Table: IPv6
  Destination/Mask            Gateway                   Flags Ref  
Use   If
--------------------------- --------------------------- ----- ---
------ -----
fe80::/10                   fe80::203:baff:fe06:13c4    U       1    
0 eri0
ff00::/8                    fe80::203:baff:fe06:13c4    U       1    
0 eri0
default                     fe80::203:baff:fe06:13c4    U       1    
0 eri0
::1                         ::1                         UH      3    
22 lo0

If I'm reading this right.  I says that I have two NICs, but they both
have the same name "eri0" and MAC address.

How could I configure the second with a different name and IP address.

Thanks,
Michael.

2. Ultra SPARC II 400 operating temperatures

3. Shape Ups,Men's Shape Ups,Men's Skechers Shape Ups - new styles!

4. Problem with upgrade Xfree86 3.3.5->4.0

5. UPS - software driver for the APC Smart UPS - 600 (Please HELP )

6. Printing Problem - /dev/lp0: No such device.

7. Newbie trying to set up Linux with two NICs

8. include/linux/kd.h code cleanup

9. Newbie Q: How to set NIC card on HP Kayak XU?

10. HELP HELP HELP NEWBIE Cannot get the DHCP set up properly and cannot connect to internet

11. Newbie question about NIC settings

12. newbie: setting NIC speed?

13. setting up the NIC - newbie question