Awkward installation problem (Networking)

Awkward installation problem (Networking)

Post by Andree Jacobso » Fri, 23 Jul 1999 04:00:00



Hi there all you linux gurus (I hope!)

I'm trying to install Redhat 6.0 on a standard machine with a
3com 905B-TX network card.

I boot the bootnet floppy in expert mode and chose to install via ftp
so far so good, I also chose the 3com 90x (Boomerang) driver for
installation even though the installation program suggests the 3C509
driver.

Anyway I enter the Static IP address information as it should be
entered. Then I click OK and get the following error message and the
installations hangs:

SIOCADDR: Network is unreachable

After reading other questions in similar newsgroups I figured out that
this happens when the gateway is not found. So looking at the other
consoles I see that the card is properly found but when initialized with
the Static IP address information I provided, the gateway and dns
address has been changed into
xxx.yyy.[subnet].0 and xxx.yyy.[subnet].255 which is not what I entered.

Does anyone know why this happens? Why would the installation program
change the values I entered? Makes no sence to me!

Please post replies to newsgroup and mail, thanks!

/Andree Jacobson
 Lule? university of technology
 Sweden

 
 
 

1. Networking problem - Works directly after installation fails after reboot no ifconfig or route problems (I think)

Ok, now im totally lost so any help is appreciated...

All help but 'run redhat/slackware etc'

Ok here is my problem...

I installed Debian 2.0  2.0.34 kernel

I have a 3Com Etherlink III 3C509

IP: 10.0.0.30
Netmask 255.0.0.0
Broadcast 10.255.255.255
Network 10.0.0.0
No gateway

Directly after installation it works fine,
I can ping from my win98 box and I can ping any other machine from my linux
box.

First i did after login with root was to reboot
Then my network was down....
I cant ping my linux box from the win98 box
and when i try to ping any  IP within the 10.0.0.0 net ping replies with
(win98 is 10.0.0.20 but any ip in this net gives me same result)
Send to: Operation not permitted

I can ping my own IP 10.0.0.30

If i ping any IP outside my local network I get Network unreachable as it's
supposed to tell me...

ifconfig tells me my eth0 is up and running and kernel route looks ok
10.0.0.0 is routed to eth0

This is just confusing and I have reinstalled 4 times... same thing every
time!

help! :/

/Johan

2. implementing backspace in curses

3. R5 FTP Installation networking problems or X problems

4. notatla Macintosh want to open plenty of those question

5. Installation server for Linux (Network installation)

6. Sendmail or Smail?

7. Question of Upload speeds (very awkward situation)

8. how to install qt on mklinux ?

9. Summertime awkward install?

10. How awkward in LinuxPPC

11. drag with trackball awkward, suggestions?

12. Why is samba is awkward to get print share working?

13. removing unwated awkward files