XFree86 Configuration problems.

XFree86 Configuration problems.

Post by cbod.. » Tue, 12 Sep 1995 04:00:00



If anyone can help with configuring XFree86  I would appreciate it.
 I have been
reading Matt Welsh's Linux book. Some of the steps he suggested seemed
to
work. Such as: 1)linking the file /usr/X11R6/bin/X to the server that
I need.
In my case I chose XF86_VGA16. I linked it with the line "ln -sf
/usr/X11R6/bin/XF86_VGA16 /usrX11R6/bin/X"  2) I edited my path with
the
PATH=$PATH:/usr/X11R6/bin  (I am pretty sure this is just a temporary
setting
though, I am unsure how to permanently add this to my path statement.
I
checked out my profile file and my .bsrc file and could not find a
path
statement in there. So I know I need to edit it permanently I am just
unsure
of where my path statement is located.) 3) I  then added the line
/usr/X11R6/lib to my "/etc/ld.so.conf" file. I then ran
"/sbin/ldconfig" from
root. I have no idea what that did but it worked (i.e. no errors).
Then I
tried to run "startx", and "xinit". Both gave me the same error.

          Fatal Server error
          you must specify a keyboard in Xconfig

Then when I looked at Xconfig it has this:

mouseman "/dev/ttyS0
BaudRate 1200
vga256
Chipset "tvga8900c"
Modes "800x600" "640x480"

The above settings are the ones that I specify when I run off the CD
and run
"xinit"
My question, obvioulsy is what do I do now. How do I permanently set
my path
statement and can I just add a keyboard line to the above "Xconfig"
file?
According to Matt Welsh
The Xconfig file should have a keyboard section that looks like:

Keyboard
        Protocal "Standard"
        AutoRepeat 500 5
        ServerNumLock
EndSection

Can I just edit the Xconfig file and add the above? I checked out the
Xconfig.sample file and it is divided into sections and doesn't look
anything
like mine. So I am confused. It seems as though this is the final
step. Any
help is appreciated.

chris


 
 
 

1. XFree86 Configuration Problems

I have successfully installed a dual boot linux system (Win 95/Mandrake
6.0). This box has a Number Nine Imagine Series 2 Video card (4 MB
RAM), IBM 526 RAMDAC. I have gotten all of the monitor timings nailed
down. I use xf86config to go through the process of setting up the
mouse, keyboard, monitor, video card. It all works fine, I bring up the
stored X configuration it is all saved. When I run startx I keep
getting an error message:

"Device found, unable to resolve display modes"

Then xinit dies. I have gone through meticulously and verified all of
the data that I am feeding the configuration. I have tried both the
XF86_I128 xserver as well as the stock 256 xserver. I have tried to
limit the display modes to 1024x768 and below.

Any suggestions as to how to get X up and running???!!! Any pointers to
faqs, how-tos, etc would be helpful, however, I have gone through what
I beleive to be all of the stock X material...

Sent via Deja.com http://www.deja.com/
Before you buy.

2. help synchronizing threads.........

3. ThinkPad 765L XFree86 configuration problems

4. Philosophy (Linux's greatest strength?)

5. XFree86 Configuration Problems

6. Cirrus 7548 (laptop) & X incompatibilty

7. XFree86 Configuration Problem

8. kpilot

9. Help ! XFree86 configuration problem

10. XFree86 Configuration Problem( with Stealth 64 Graphics 2001 )

11. HELP !! HELP!! Xfree86 Configuration problems

12. XFree86 & Mouse configuration problem with FreeBSD

13. Configuration problem with XFree86 3.1.2 for Mach32 server - xf86conf (0/1)